RM8 won't connect to internet any more, although it did during the testing period

Since installing the final version of RM8 and importing my RM7 files, RM8 won’t connect to the internet . It did during the testing period. And RM7 was OK before that. I haven’t changed my computer or operating system (Mac Mini under Sierra) and the internet works for every other app, including this community’s pages. I loaded v 8.1.4 today, and the problem is still the same.

So I don’t get webhints, and the home page says it can’t do the three things via the internet (read news, get support and check for updates). I can only be aware of updates by looking on RM’s downloads web page or this community.

As with other Mac users, the app seems very un-Mac like. There’s no “About RootsMagic” menu item to show the version number etc. And the version number doesn’t show in the Apps Get Info - it’s always v 1.0.0 which is nonsense. It takes about three minutes to complete opening - maybe because it’s looking for things on the internet and can’t find anything?

Can anyone suggest what to try?

Upper right main window, click on the tricolon to get the dropdown menu:

I can’t help on Mac matters.

Have you got some anti-virus or firewall software that is blocking RM8 from accessing the internet?

Thanks for that - and I can see that I’ve got 8.1.5, not 8.1.4.

Here’s my Mac’s menu that doesn’t have About RootsMagic:
Screen Shot 2022-01-10 at 17.18.15
which isn’t what Macs normally show top left.

And here’s what Get Info shows when looking at the app file:

Screen Shot 2022-01-10 at 15.44.03

Thanks for the suggestion. I use ESET antivirus and the Mac’s own firewall. It doesn’t block anything else that I use, but I’ll dip into their menus to see if there’s something helpful to reset.


ADDED LATER - I disabled the antivirus protection and set the Mac firewall to allow RootsMagic access to the internet. It didn’t help - the problem is the same. It was OK before with the trial versions and RM7.

That’s not a RootsMagic menu. Don’t you have the ‘three dots’, vertical ellipsis, tricolon in the upper right of the main RM window? Tap it.

Tom is, of course, correct, but dutyhog was highlighting that RM8 is very much not in the tradition of a ‘normal’ Mac program, as many have already highlighted. Maybe because it is so far from being a normal Mac program that the lack of an About option from a menu bar pull-down is acceptable - not really, but I am prepared to concede that - but the fact that the real program version number isn’t displayed when one uses Get Info against the application - nothing to do with whether RM8 is running or not - is inexcusable. It should - MUST - display the correct version info. (Note - this is a display from the installed application, not the downloaded disk image that is yet to be installed.)

Thanks for explaining that for me, JP1. It is, of course, a pain when an app doesn’t behave like most other Mac apps.

But my main problem is still that RM8 itself doesn’t seem to connect to the internet. I want to have webhints back again.

This seems very odd. I wonder if anyone else is successfully using Sierra, though why the beta worked OK but not the production version is definitely odd.

Without some error messages (somewhere) or a trace of what is happening (or failing), I’m out of ideas. Sorry.

I could have elaborated, JP1. The beta version worked at first, but lost the internet connections about 3/4 of the way through development. I did report the snag. Clicking on send a report to RM doesn’t get anywhere - I can’t see a report stored on my Mac before it tries to send it to RM.

I had also tried RM7 as an .exe app using Wine (which I use for several Windows apps) - it seemed faster than the Mac version of RM7, even though that was used via a version of Winebottler.

For a couple of days, I’ve had problems opening RM8. When eventually it opens the ‘News’, ‘Help and Support’ and ‘Updates’ windows cannot connect to the internet and the windows have a revolving circle of dots. An error report was sent. Connecting to Ancestry and Family Search work fine.

Trying RM7 there is a similar problem; the RootsMagic news windows says, ‘Unable to contact RootsMagic news server’.

Using Windows 11.

Anyone else having this problem?

Do you have the UK Edition of RootsMagic? S&N Genealogy supplies the news feed for the UK Edition. They are currently updating their servers.

I have the UK PC version of both 7 & 8, 8 refuses to open and as someone commented I just get the revolving dots when I try and open version 8, however version 7 seems ok.

Yes, Renée, I do have the UK version. How would S & N dating their servers affect the delay in opening RM8? It takes about 25 seconds to open whilst showing in the toolbar what you see in the picture.

If RM8 is delayed in opening then that’s a different issue. You can get on our chats and we would happy to see what’s going on. More than likely it’s your security software. Go to www.rootsmagic.com and open a chat. The best time to reach an agent is M-F, 8:00-4:00 pm (MT).

I’m the OP, and still have no luck with RM8 connecting to the internet, so it doesn’t get news feeds or communicate with RM. I’m in the UK. I’ll try a chat on www.rootsmagic.com next time I’m within 8:00-4:00 pm (MT)

If you are in the UK and have the UK Edition of RM8 then contact S&N Genealogy. They can tell you what’s happening with their servers.

I have phoned S & N and they are are aware of the problem. They are in contact with RootsMagic to try and rectify the problem. They said they will e-mail me when it is sorted out.

My RM8 is back this morning. :grinning:

Mine isn’t, though. Here’s a screenshot of the error messages that RM8 shows on my Mac:
Screen Shot 2022-05-05 at 10.32.40

Maybe it works in Dorset, but not in Scotland - some legal problem?