RM8 for Mac OS - Access Violation Error

Spot on! AVs happen even with RM8 only on the internal mac drive. No other mac program in decades of use have ever given me such errors. This includes all other mac genealogy programs: FTM; Heredis; Macfamilytree; Reunion.

1 Like

Agreed. I should have made it clear that I was addressing the risk of live syncing the database file only and that that risk is far lower than the incident rate of access violations we experience from causes within the program on both platforms.

1 Like

This page may be representative of the causes of these errors…

I am just impressed you can write a program that so badly violates strict mac OS requirements and have it run at all. Guess those requirements are not an app stopper unless you try to get it on the Apple app store.

1 Like

I bought RootsMagic 8 about a week ago and having the problem with Access Violation also. I can’t seem to attribute it to a single action on my part. I’m running v on a MacBook Pro running macOS Monterey.

Welcome to the wonderful world of Windows badness exported to the mac. RM8 is simply sharing that windows pain with mac users in a badly ported beta program. It is not you. I just gave up today and uninstalled RM8 from my new M1 mac.

1 Like

I too am running RM 8.1.5 under Monterey (on an iMac with an M1 chip and on a 2017 MacBook). I too get Access Violation Errors, but they tend to come in spasms - I can go several hours/days without getting any, or I can get a rash of them. They’re annoying, but I’ve learned to live with them.
Curiously, they do seem to be happening less frequently, but this may be because I’m doing something differently - problem is, can’t work out what that might be.
I have made it my practice to always run the DB tools when I open RM at the beginning of a session, and always when I re-open RM after an Access Violation Error. This is actually carried over from my RM7 days, even though I rarely got these errors with RM7

has the 8.1.6 mac bug fix stopped access violation errors? I have uninstalled RM8 for it’s flakyness on mac.

It hasn’t done much good here. I am getting close to uninstalling it myself. The thing that I’ve noticed that helps, but doesn’t really stop them, is to type more slowly and to let things “settle” between entries. This piece of bloatware is unbelievable in it’s CPU usage. If the typing gets to lagging behind by fingers by several letters, even at the slower speed, I can predict access violation within 5 seconds, accurately.

My perception is that with RM 8.1.6 access violation errors have certainly become considerably less frequent. I didn’t have a single one in a day’s work yesterday, even using some of the procedures that had almost inevitably triggered them for me in the past.
By the way, I agree that typing more slowly also seems to reduce the incidence as well!

Just upgraded to RM 8.1.6. Opened very small database went to settings logged back into FamilySearch, then checked I was logged into my Ancestry account. Immediately after that was presented with an Access Violation error. I had not even started any database work. I had high hopes but once again they were dashed. Running on a fully speced MacBookAir with M1 processor, Mac OS 12.1. I just don’t understand why this is so hard for RM8. FTM 2019, MacFamily Tree v9 and other native Mac apps including Final Cut Pro X run without issue on this device. It is so frustrating given I really do want use RM8 but won’t as long as I keep getting these errors. Furthermore clicked on send error report, that seemed to work, presented with an alert that I should restart the application. Tried to close the app and was presented with the spinning beachball of death, minutes later still the spinning beachball of death so Force Quit was the only solution to close the application.

Nothing limiting about your M1 mac. Problem is Rootsmagic port to the mac was done without hiring professional mac help and reflected in the many ways RM8 does not behave like a regular mac program. Bugs may get worked out in 6-12 months but design choices will remain. All 4 other mac genealogy programs run just fine and use very little cpu %. Check activity monitor the next time you run RM8. Only a zoom session uses as much cpu for me. FTM runs at 0.1% not 20-60%.

1 Like

I’m really sad to log in here in late Feb 2022 after installing RM8 yesterday, and to see that the problems I’m having (crash, crash, crash) have been reported since October 2021. I’m using the latest update I even upgraded to macOS Monterey, with no improvement. Unreliable software performance from FTM is what brought me to RM7, so I expected better. I don’t mind a learning curve, and I don’t mind taking 5 minutes to figure out that the “memorize” button is the icon that looks like “copy page.” But, I do mind trusting 10 years of work to a platform that I don’t have confidence in. So, it is back to RM7 for now.

On my first reopen of RM7 after installing Monterey, I got the message that RM7 would not be useable on any further MacOS updates. Good thing I have a very down-rev iMac in storage that I didn’t get rid of yet and a bit more desk space, if it comes to that. Boo.

Keeping RM8 in the cooler to hope another rev makes it useable.

1 Like

what problems did you have with FTM and when? Since Mackiev took it over and fixed in in 2017 it has been a smooth stable platform with an excellent manual for me. I had hoped to also use RM8 but find it not ready for release yet on my 2022 MBP M1 Pro. Both FTM 2019 (free update this year) and RM8 have good tree and excellent person views unlike the other 3 mac genealogy programs (heredis; MFT; reunion).

Whilst RM8 gets sorted for Mac OS sometime in the future, I have decided to keep FTM 2019. I have also just gone back to using MacFamily Tree now version 10 has been released. I am currently bringing my MFT database up to alignment with my FTM database with the intent to make it my primary database. V10 has a demo version you can use to check it out. It is a pure Mac only app which seamlessly works across Mac OS and IOS. It is on special until 27March. The biggest improvement for me was the total revamp of source and citation handling which is now very flexible. Check it out but make sure you do a GEDCOM import to see if the results are adequate enough to migrate from another platform. It doesn’t integrate (sync) with Ancestry if that is a requirement but it does with FamilySearch if that helps. The manuals for both the OS and IOS versions are available on the Synium website to research the application at no cost.

They didn’t take anything over and fix it. They had already been producing the Mac version for quite sometime prior to acquiring the program outright. Due to this, one would have expected the Mac version to have been quite functional when Ancestry still owned it, but from what you suggest, it wasn’t.

Perhaps they should change their name to Mackyiv in line with the KyivNotKiev campaign

From their website: “Many of our talented staff live and work there, where we’ve had offices in Kyiv for more than a quarter century.”

Let’s hope they are all OK and get through this stupid war.

1 Like

That’s been my thinking, too. They seem to want to support the Mac and are trying to do so. I hope they have or will get some Mac software developers onboard at RM. Development on Windows and on Mac are very different. It sounds like they understand that but are not liking the answer. I trust another 3-6 months into RM8 things will be better. The writing is on the wall as far as home computers are Macs today to be compatible with iPhones and iPads. Corporate America is still deeply vested in Microsoft but they don’t do much genealogy.

1 Like

As genealogists we know how important sources are. Can you provide some that state that “the writing is on the wall …” Also I believe that Android has a bigger share of the market than iPhone/iPad but will stick with the word “believe” whilst I track down some sources.

It’s now June 2022, and I’m on RM version 8.1.8, running on a Mac computer using Monterey 12.0.1 … I’m still experiencing several access violation errors per hour when using this program. :frowning:
I hate to start over, but I’m really, really tempted to try running Legacy (for Windows) through Wine.