RM8 for Mac OS - Access Violation Error

Now running RM 8.1.3 on a new iMac with the new Mac chip, and OS Monterey (though I have been running Monterey for a few weeks on my old machine). Curiously , Access Violation Errors seem to have reduced in frequency - I actually had 2 days without any! However, have had a few today, which is annoying as I was beginning to hope I was out of the woods

M1 iMac, sigh! I am 6 months away from getting a new mac.

M1’s faster performance and better RAM memory management may help reduce access violation errors despite RM8. In decades of mac use I have never seen AV errors and think they reflect a deeply flawed attempt at a native mac app. A successful port of Windows behavior to the mac.

Sorry to disappoint but I have been using RM8 with an M1 MacBook Air fully speced since the community preview phase some improvements the laster releases of RM8 but not enough to ditch my primary databases in Family Tree Maker or Mac FamilyTree.

Yes, the speed is almost disconcerting.
My old iMac was clearly ailing which is what pushed my purchase of a new one forward by 6 months. Don’t know myself!

I too am staying with FTM but reading the RM8 wiki and using RM8 as a helper tool.
MacFamliyTree is a very smooth runing mac program but I could not tolerate the awful pedigree trees and the very fragmented person data display.

1 Like

Well updated to RM 8.1.3 today, very small database with a handful of sources and media files. Added existing repository to three existing sources, opened one media file, resized using the magnifying tool in the image viewer, closed the image viewer window and bam Access Violation. Upadate my existing RM trouble ticket so I hope that helps them. One positive sign clicked on the send error report button on the Access Violation window and it appeared to send!

After upgrade to MBP 14 M1 Pro and Monterey RM8 now opens in 15 sec instead of 1-2 minutes. It still takes an amazing %CPU: 50% in use and 20% idle while FTM 2019 uses 0.1%. Both are Intel apps. However flipping through the program screens did not immediately trigger access violation crashes. Leaving RM8 open for several hours also did not cause crashes.

Family search automatch took only 5 minutes instead of 2 hours. Apparently throwing a Cray supercomputer at a badly written program can help a lot.

Creating a new file from a gedcom worked the first time instead of crashing one or two times before success. However uploading a file with media to Ancestry still triggered an access violation crash. Upload without media did work. My file is only 370 people, 500 media and 1000 citations (tiny).

RE: Access Violations: Had them repeatedly - after getting a new MacAir and a new install of RM8 - also was getting error message trying to access Dropbox to backup - finally got a Couldn’t start Dropbox - Tried to follow online instructions from DB on fixing permissions but the error window would interrupt those attempts -finally got DB on the line - Required going into system preferences and making changes to Full Disk Access, File & Folder and Accessibility folders - All seems. fine now (there was a RM data file on Dropbox that I put back on my local drive also just in case it was a factor) Now I bu RM8 to Dropbox & have had no recent access errors

Exactly what preference settings did you change to reduce access errors:
security->full disk access (seems risky)
->files folders. RM8 has access to docs and downloads only
accessibility->??? Main one and which inside it or inside Security? Risky.

Strange as FTM 2019 needed none of this. RM tech support always liked adding RM7 to firewall but I have nothing there.

On any new mac or OS update it really pays to review ALL preference settings to find new choices and switches Apple has changed.

I have to agree given the apparent stability issues with RM 8 I would be very hesitant given the application full disk access rather than files and folder access. The previous post has raised citing the issue with Dropbox has me wondering if the Access Violation errors I have been getting with RM 8 could be in some way attributable to the fact that my RM8 file folders are stored on my iCloud Drive. I may need to try moving my database to a local drive to see if the Access Violation situation improves. Not an ideal solution for me as I frequently work between my laptop and my desktop.

I spoke too soon. I ended up in the Dropbox chat because the error message attached which occurred this am. After I went thru their instructions which I outlined. I went back into RM8 and not only was Dropbox available, but I backed up to DB and worked awhile w no access errors. So I assumed it was all fixed.

Now I am getting frequent access errors again and the following message when I try to BU to Dropbox. This screen comes up first and then RM8 just shuts down and does not appear to do any BU at all.

However, I can back up to the local drive w no difficulty. Dropbox tech told me that any further problems with backing up RM8 had to be addressed by the RM8 techs. I’m way past any level of experience & appreciate the concerns expressed about granting full permissions as mentioned above. I believe it is only DropBox permissions that we changed as of now.

I thought that people had nearly always had problems when trying to use any variety of cloud drive for storing their active RM file, RM7 or RM8. I don’t see why iCloud should be an exception to this advice.

Storing your primary database anywhere but on your internal computer drive seems fraught with risk. You can always finish your work there and place a new copy on icloud drive or dropbox. Could you not allow your other device(s) to sync with icloud drive for seamless access? You would just need to be aware of which device has the latest database and update the other from icloud drive.

RM users seem tied to dropbox use but this is an older sharing service not a reliable backup solution and is not mac friendly.

For me the primary reasons for using a cloud drive twofold, one ease of moving from one device to another without the need to try to remember which device has the latest copy and secondly as all my devices sufficient storage to maintain a local cloud drive copy on the device I effectively have three backups of my database one in the cloud one on each local drive and that is before my TimeMachine backup and my NAS drive backup. However, no system is perfect but it works for me. Currently my main genealogy database still resides with FTM 2019 which works flawlessly with my database workflow. My move to RM was prompted by the pre-release hype for RM 8 (MacOS) being a 64bit Mac native application. Having purchased RM7 I liked the way the application worked but was not happy that it ran under a wrapper. When the release of Catalina broke the wrapper and I had to wait what seemed an inordinate time for the fix, I was keen to move to RM 8. Having taken part in the trials for RM 8 despite the problems with pre-release versions the only major issue not fixed on full release for me was Access Violation errors. Given over my many years of Mac OS usage the fact that I had never encountered this Windows error in a Mac OS application has filled me with dread about committing years of genealogy work to RM8. One day perhaps the problem will be resolved. Until them RM8 for me will only remain an app that I occasionally use. So much promise unfulfilled.

Just out of curiosity, and since I do not use iCloud with my iPads, iCloud has a local folder/file/directory (whatever you want to call it), correct? RM’s old goto is never edit a datase file stored in a location that may sync during usage. I have been doing precisely that for about 15 years now with Google drive and have never had an issue. More recently, I have done the same with Dropbox, again, never an issue. Generally I pause synching while I am working, then turn it back on when I am done. I would think iCloud should be at least as robust as Dropbox and Google Drive. In otherwords, I wouldn’t be overly certain that iCloud has anything to do with it. I think it is more likely that RM has a boatload of work that needs to be done.

What is your FTM workflow? That too is my program with RM8 only as a helper tool with its better tree display to find where I am in FTM. RM8’s different display of some data helps me find problems in FTM file.

Access violation errors are only the most devastating and obvious flaws with RM8. Activity monitor shows FTM humming along at 0.2% CPU while RM8 runs at 20% idle and 50% doing anything on my MBP M1 Pro. I really want to like this program for its more readable display but poor design choices and abnormal mac behaviour just bring back all the reasons I left Microsoft hell years ago.

Consider Backblaze as a cloud backup option. It costs $ but is as automatic as Time Machine and safe from local disasters. It would not provide the shareability of icloud drive or dropbox.

I have used iCloud extensively for the work flow for most of my Mac applications that support cloud storage as I often work across the Apple eco system. By and large I have not had any major issues. The good news is the Access Violation errors do not appear to be cloud storage induced. Moved my databases to my local drive. Opened two databases, the first about 1000 persons with associated media and sources and the second 8 people with associated media and sources. On opening the second database “ACCESS VIOLATION” error. So tried shutting down the app without backing up then reopened the two databases with no error. Drag and dropped 4 individuals from the larger database to the smaller database. All good! Closed the larger database and “ACCESS VIOLATION” error. I must admit I am not sure why I keep torturing myself!

With FTM (2019) in iCloud I have a Family Tree Maker Folder which replicates the folder structure FTM creates on your local drive in my iCloud drive and moved my FTM files to the relevant FTM folder in iCloud. I then set the FTM preferences to point the relevant iCloud folders for database, backup and media. From then on open the database from iCloud drive. The process is no different to using DropBox. When I move between my Intel Mac and my M1 MacBook Air or vice versa I always ensure that after shutting down the application that the local copy of iCloud drive has synced up to the cloud before shutting down. When I power up the other device I always ensure the local copy of iCloud drive has synced down from the cloud before launching the application.

That is key to avoiding database file conflicts or corruption when working on one that is in a cloud-synced folder, with the exception of OneDrive. It is the only one to my knowledge which visibly pauses automatically the synchronization of a .rmgc or .rmtree file when it is open in RM. It’s possible that others now do too but they did not previously and do not flag a pause. And maybe OneDrive does so only in Windows.

The risk with active syncing of a working sqlite database file is that the file is changing so frequently that sync cannot keep up, increasing the probability of confusion between the original and the cloud copy. It’s not a myth. Not pausing sync is inviting a problem.

Whilst I have never encountered any problems I agree it can be an issue. However, the Access Violation errors occurring with RM8 I don’t believe can be contributed to using a cloud service given my recent experience when I moved my databases back to my local drive. For a Mac user unfortunately RM8 just does not measure up to any other native Mac OS application I have or am currently using.

1 Like