RM7 database file won't close through "End task" procedure in Windows 10

My RM7 file will not file close. I click “end task” which Windows indicates it completes, and then reboot the computer and try again to open RM. When I click to open the RM7 program only a small portion of the RM screen shows up, and when one clicks anywhere on it or tries to enlarge the partial screen the program makes a dinging sound, thus not letting me use the “file” choices on the left of the open RM screen. I have heard the dinging sound previously when choosing to select an already existing place, and something seems not to work for a second or two.

I have tried to copy the complete program file and paste it to another computer, but since the file is open, no existing processes related to the locked up open file will work. I did restore my most recent backup to another computer, but I lost an hour of some extensive work and really do not want to have to repeat it. Moreover, I want to use the 17 In laptop for my data entry, not the one with the smaller screen.

Can someone help?

Typically in RM 7, a dinging noise means that you have a person’s edit screen, report etc minimized and need to close that before moving on–But since you used end task and rebooted the computer, that should have taken care of that…

So-- when you opened RM 7-- did this window appear?

and did you close it ?

If not, it MIGHT be minimized along the edge of the task bar

or your window is so small that you can’t see it to close it…

here are instructions on how you can change the size of the window in a program

hope it helps

Thanks for the suggestions. I signed on with the computer hat has my login this time. I only get the initial green screen with the RootsMagic logo. I don’t get the second one with the RootsMagic News although I did previous to this problem. There is too small an area of the Rm7 pedigree screen showing. What I see takes up about 2/3 of the screen across but is about /3 cut off on the right hand of the screen. The depth is truncated -goes down to the word file at the top left of the screen. I was able to get to the screen you described to maximize the shortcut, but I could not get that procedure to work either. The rest of the computer is working perfectly fine with the glitch in RM the only problem.

Follow-up - After writing the previous reply, I went back and tried two of the same “end task” combinations that I had been trying all along. Low and behold, the problem disappeared. Thank you.

Glad it finally cured itself-- now that it’s working right, you might want to resize the RM 7 main widow pane so it doesn’t happen again-- either 1/2 or 2/3 of the screen smack dab in the middle so that the News is always in the center of your screen as it sounds like it was off the page…

BY the way, you can OPT out of news on RM 7
just click on do not show again and hit close…

I see that your problem cleared itself, but you seem to imply that you use “End task” regularly. Are you using the Windows 10 Task Manager to shut down RootsMagic? If so, hopefully that is only for situations where RootsMagic is hung in some way and is not responsive. Certainly task manager should not be used regularly to end a RootsMagic session.

When you use Task Manager ‘end task’ the RootsMagic program does not have the opportunity to close all of its processes “nicely”. This is similar to pulling the power plug on your computer. Even though Windows may be able to recover from a power failure most of the time, it is certainly not a safe way to shut your computer donw.

Likewise,you should always exit RootsMagic through the File/Exit menu option or the Exit program icon in the menu bar or the red “X” in the upper right corner of the window. Those exit processes close everything down nicely.

I use Task Manager 'end task" when RootsMagic gets hung and so far, I don’t believe it has ever corrupted my database. However, that is far from guaranteed. I would never use task manager if I can exit normally within RootsMagic.

1 Like

I have used RM through all its versions and know how to close the program. However, there are some issues with using FamilySearch that cause RM to lock up, thus making it necessary to use “End task” a few times per week.

Perhaps I should explain that I am editing a large database (296,000+) and am comparing many of my entries with missing facts to what is on FamilySearch. Since I tend to work on my database 8 to 10 hours daily, I give this aspect of the program a good workout!

I suspect the program screen got resized and locked up in the first place when I left the laptop open on the bed while I went to another room, and while I was gone, the dog jumped on the computer. There was no problem when I left the room. Who knows how many keys a dog’s paw hits with one encounter? Lesson learned - don’t leave your computer unattended where the dog can jump on it
I want to thank people for their suggestions.