Is RM 9 working properly

When i open RM9 on my computer ,I am finding it very difficult to exit the program ,to escape I am having to use the shutdown & restart button the x(close) in the corner isn’t working.
windows 10
Opera browser
does it with Chrome as well

Without any further details it is difficult to ascertain the cause. It could be a program crash or a corrupt data base. However, there is an easier way than having to shut down and restart your computer to quit an unresponsive application.

In Windows, press Ctrl + Shift + Esc on your keyboard to bring up Task Manager, or press Ctrl + Alt + Delete and you will see a few options. To open the Task Manager, select Task Manager

Right click the RootsMagic app and select End task

thanks,also I have updated my ancestry family tree and tried the program again and it is still importing the whole tree again even after the changes

Not sure what you mean. When you use TreeShare, you can display “only changed people” otherwise you will see All the people in your database.

The only reason that I can imagine to cause this kind of problem(s) is when you try to close the program while it’s in the middle of something, like downloading a very big tree from Ancestry, or when the program tries to write a backup to a drive that doesn’t respond.

Can you tell us a little more about this? How large is your tree?

Unless, of course, you use the drop down in “Show Everyone” and filter by a named group.

Thanks for all the replies ,I will persevere with it and try again later.

there was only about 2000 people ,i think

On Ancestry, during sync, or in the RM tree on your PC?

I use RM 9 with my main tree every day, with more than 14,000 persons, and occasionally use it for a reference tree, with more than 600,000, and I’ve never seen it hang like that.

This is why I’m curious about what you’re actually doing. Is there an active TreeShare window open somewhere? Could it be hidden behind another one?

tried loads of times to download this one tree and failed,tried on a different computer running 64 bit ?? and it worked ,could be that the said tree on first computer had an open window somewhere,i thought I had deleted said file and backup before I tried again

Yes but Muddywaters hasn’t gotten that far, he is still trying to Download the Ancestry tree. Once successful he can create Groups.

thanks for all the replies ,got all trees working now albeit one is on seperate computer.all backed up media & tree’s and saved to data stick except the media to the stick!!

It might be as simple as making sure your curser is directly on the X. I have a similar situation where, when I hit the arrows to scroll up or down, if my curser is not really centered, nothing happens. I think those target areas are too small. Maybe a program tweak might help

So made up a usb data stick from 64 bit computer and managed to transfer to the 32 bit computer without the attached media files(media still on 64 bit computer

Ending the task in this way may seriously risk corruption in the database as records and files are open and locked. Only use theis Windows function in an emergency i.e. if the application completely locks up and cant be released.