RM7 and RM9 open at the same time

In RM9, I did “Open a RootsMagic file” then selected the rmgc database I’m using in RM7.
I saved it in a completely different folder on my computer (not in Dropbox).
I gave it a different file name.
RM7 was open at the same time as I did all this.

When navigating around in RM9 in Descendant View, I keep getting this Error:
Access violation at address 0000000002F93A94 in module ‘RootsMagic.exe’. Read of address FFFFFFFFFFFFFFFF.

  1. Is RM9 using my RM7 database at the same time that RM7 is using it?
  2. If not, why do I keep getting the error?

When I close RM7, I do not get the error.

Using Windows 10 and RM9.1.4.0.

v9 will convert the 7 database when you just Open A RootsMagic file - you really want to do the Import of your 7 database. I have never “just Opened” an existing v7 file before.

OK, I tried it that way, by importing the RM7 database. I’m still getting the error message, though, when RM7 is open at the same time.

Close both 7 & 9, reboot and just open 9 and run the Tools. You can run both at same time - I do.

This is one of those situations that sounds impossible. When RM9 imports an RM7 database, it does read it all. But it only reads it during the import. It doesn’t read it again thereafter. I wonder if it would help to close RM9 completely after the import and and reopen it before navigating around in RM9 in Descendant View. I’m grasping at straws, but maybe there is something still dangling around in RM9 left over from the RM7 import. I doubt that would have any effect to do that, but it’s the only straw I can think of.

Also, I’m still on RM I didn’t upgrade to RM after all the problem reports. I know the main problem with RM was with the installer and that the installer problem was fixed very quickly. But it’s not clear to me if there are still RM problems floating around that are not related to the installer problem.

I ran the 4 Database Tools in RM9 and restarted. After about 8 times of navigating, moving from Family View to Descendants View causes the same error. Also the same error appears after moving from Tools to Descendants View.

I notice there is a slight pause when selecting People until the People page displays. RM9 seems very sluggish.

@mapleleaf I have never tried opening an RM 7 database that way BUT it does convert it to an RM 9 file so I doubt if that is the problem-- I have in the past had RM 7, RM 8 and RM9 all open at the same time with the same database and had no problems…

One suggestion is to make sure that you have paused dropbox BUT don’t think that is the problem…

One problem with the newest update is trying to use 2 monitors–it causes access violations very quickly…
I believe you are having the same problem as described in this thread–

Basically-- this error will happen in 3 to 8 clicks-- the number of clicks depends on what view you start in-- pedigree/ then family then descendant and if you change to a different person BUT once in the descendant view IF you click on the CHEVRON/ARROW next to the person highlighted TO GO UP to his father-- the error occurs…

The workaround I have used is to highlight someone else listed further down the page and click on the chevron NEXT to their name then navigate back to the original person-- once back to the original person, I can go up to their father or any where else I want and the error does NOT occur UNTIL (USUALLY) I TRY TO CLOSE THE DATABASE or databases— I have NOT found where any data was lost when it occurs when closing— I will also note that I have not tried using this method for a long time in descendant’s view–so it may crop up again after 50 clicks–just something to play with…

That sounds like the problem I have, and I am using two monitors.

Okay, so the error was reported in Sept 2023 and it’s still not fixed?!

My database is on the C drive (C:\Genealogy\RM_Databases) and not in OneDrive or Dropbox.

@mapleleaf – Besides the error I described, the use of 2 MONITORS is definitely also part of the problem if you updated to version…

This is a very long thread BUT basically as you get further down, it was found that most people were using 2 monitors–when they used just their laptop, they had no problems,

I still have errors that happen that were reported originally in RM 8—the problems is that as they try to fix an error, the techs have to make sure the fix does NOT CAUSE more problems and sometimes figuring out what is the cause of the problem is like looking for a needle in a haystack…

Thanks for the info. I will keep on using RM7 since I don’t trust using a program that keeps having errors.

Noting there are separate issues being mingled together on this thread.
Prior to 9.1.4
• Descendant view access violation error when clicking on the first arrow.
• AV error going in an other of lists multiple times.
New to 9.1.4
Access violations using multiple monitors or split screens - which seem the most likely cause of the issues reported here.

just curious as to the reason behind having 7 & 9 open at same time? I do but my reasons will be different I bet.

My main reason is that I am continuing to maintain my RM7 database while at the same time using my RM9 database as my production database. I suspect that very few if any other RM users would have the same reason to have both RM7 and RM9 open at the same time.

But given that I already have both of them open at the same time, I sometimes am able to do a quick lookup in one of them while I’m working in the other one. This kind of thing was supported by RM7 in the sense that you could have the same database open twice in two different sub-windows. That allowed you to have be looking at two different places in the same database at the same time. That feature has been lost in RM9 because a given database can only be open once at the same time, and you can’t be looking at two different places in the same database at the same time.

In RM 9 you can “almost” have the same database open in two windows, by running RM9 twice, for example as “RootsMagic.exe” and as “RootsMagic - Kopie.exe”.
If you open the same database in both sessions, for one of the sessions the database will go into read only, but still you can look up something in both sessions, but change the database only in one of the 2 sessions.

RootsMagic has an option to Copy an open database. Then it can be opened beside the currently open one and navigated/referenced.

1 Like