RM9 - Create a New RootsMagic file needs update to Import option

Import option in v9.0 initial release still reads Rootsmagic 1-7 (should be 1-8).

Actually, if you are coming from RM 1-7 (.rmgc) you still need to import. With a RM8 (.rmtree) database you simply open it in RM9 and it will convert it to the new file format. Make sure to create a backup in RM8 before you convert the database.

1 Like

Does RM9 convert the existing RM8 database, thus replacing it or does it create a new RM9 database, leaving the RM8 alone? Can RM9 and RM8 run at the same time on their respective different copies of a database?

Converts existing RM8 database in situ. Haven’t tried running RM8 and RM9 simultaneously but see no reason why they could not. I’ve run RM7 and RM8 together.

The RM8 Database is overwritten, so you will have to use different database names or different folders if you want to use RM8 and RM9.

@steambuff, for several versions of RM I have always copied my RM folders to a new folder and done the upgrade there, just in case it overwrites the previous database version.

Unlike earlier versions RM8 and RM9 cannot be run at the same time, even if you have the 32-bit and the 64-bit versions installed. You will need to rename one of the rootsmagic.exe files in the Program Files or Program Files (x86) folder in order to do that. The RM8 database is converted, not a new file created. You should backup the RM8 database before converting. Once converted in RM9 it will no longer open in RM8. This is like earlier version between RM1-6 or 7. Only version 6 & 7 kept the same file format so they could be opened between those two versions.

Really?? Because I appear to be doing just that. Of course they appear to be using the same settings but so far, no problem. No rootsmagic.exe file was harmed in the making of these screenshots!


1 Like

Yes you are right that you can run both files on RM 8 and RM 9 as LONG AS THEY HAVE DIFFERENT NAMES-- IF you Open a file in RM 9 and then try to open the same named file in RM 8-- you get this message

So my question is how do you rename a file-- during import , right after???

You don’t import it. Make a copy and keep the same name. I have one folder called RootsMagic8 and another called RootsMagic9. Both have a file named Family.rmtree. Both work just fine. It is known already that when you open a file in 9, it is converted and can not go back to 8. Renee said that the program file, rootsmagic.exe had to be renamed. It doesn’t and my pictures show them running at the same time. I never claimed that the two programs could share a database file.

1 Like

I have a file for RM 8 and another file for RM 9–in RM 8 settings it shows everything is suppose to be saved to RM 8–

in RM 9, it says everything is suppose to be saved to RM 9

but when I look in the Rm 9 file all it has is the backup trees

So how do I get my rm.tree into RM 9

Move or copy it from the RM8 folder to the RM9 folder using your OS file manager. When you browse for files in RM, you are in a limited version of the OS file manager and can do so with it. If you opened the RM8 .rmtree file with RM9, it has been converted in place and cannot be reopened by RM8.

In addition to what @TomH said about manually copying, you can also restore a RM8 backup file, just so long as you make sure that you restore it to your Rootsmagic 9 folder.

Thanks Tom and @kfunk for the info on how to do this BUT why is the RM 9 saving my new RM 9 rm.tree to my RM8 file when I’m telling it to save it to RM 9 once I hit backup on the file?

I created a RM Data 9 folder and copied my 8 databases to it. Then I opened and converted them. Running 7,8 and 9 simultaneously.

If the file you opened with RM9 was somewhere else than the path you set as the default RM9 database folder, it will not move it, even if it was a RM8 file that it upgraded on opening. It’s not a ‘new’ file which would be created in your default RM9 database folder. When you backup a database, it does create a new .rmbackup file which will be created in the default backup folder defined in settings.

BTW - you might type in a path in Folder Settings that does not exist. In earlier versions, no such folder gets created by RM so the new file goes to the root of the Documents folder. I expect that is still the same.


Thanks Tom–I now understand what is going on… but want to ask another question-- I understand how I can manual move the database from the RM8 file to the RM 9 file but both @ MadDog and you also said I could copy the files to the folder-- I am on Windows 11–so by copying the files, do you mean using SHARE as I can’t get anything else to work…


You are making this way too hard. Simply go into your folder where the RM8 file is stored. Right click on the file (for example MyFile.rmtree). Then change to your RM9 folder and right click in a blank area, select Paste. Boom! File is moved. Start up Rootsmagic 9, Click the File, Click ‘Open a RootsMagic file’ at the bottom of the screen, click the ‘Browse for File’, point the program at your RM9 folder where you just copied the file to., select and click ‘Open’. Preston, it opens, converts and does all the other bits. Next time you open RM9, it should either open automatically or be in your list of recent files depending on how you set things up. These steps are pretty much the same steps that we have been taking to move files (any files) since the beginning of Windows time. There is nothing new to this.

1 Like