RM 8 on Linux/Wine

it looks like 8.2.0 fixes my problems with ubuntu!
previously i could not enter data as the cursor focus seemed broken.
with 8.2.0, rootmagic 8 now seems to work.

i’m using playonlinux to install under wine and this is the first time rm8 has worked for me.

i need to do more use testing, but this is very encouraging

1 Like

looks like a clarification is needed here.

rm8 worked fine on my laptop, but not on my desktop, both running ubuntu jammy jellyfish,
so i compared the two setups.

works: wine with windows 10, gdiplus added to libraries
fails: wine with windows 7, no gdiplus

i changed my desktop wine configuration to windows 10, added gdiplus to the libararies, and the desktop now works.


Thanks for that. I thought I would give it a try, but getting gdiplus installed looks like it is no longer possible with PlayonLinux.

I would really like to get this working with wine, but no luck so far.

My latest experiments with Linux Mint 20.3, and Linux Mint Debian Edition 5, have been quite succesful with two simple adaptions:

  1. Uncheck the enhanced browsing in the RootsMagic install program,
  2. Use winecfg to set the Windows version to 10.

I’m using Wine 7.0 stable, without PlayOnLinux, and did not install gdiplus.

Did this on another computer and it did seem to work. No internet though.


with playonlinux,

  1. select the rootsmagic program
  2. configure
  3. wine
  4. configure wine
  5. libraries
  6. selection gdiplus from dropdown for new override
  7. apply

one issue here i don’t understand.
running rm8, in descendants view

  1. on my laptop, the names are chopped off and names are not complete
  2. on my desktop, no names show up at all in this view

this seems to likely be something related to screen resolution or some display functionality.

any ideas out there?


do you have any issues with the display in descendants view? (see comment above)


Does web sync work?


sorry, i don’t use web synch, everything is local here

have you looked at descendants view? any problems?

For me sync is the most important feature.

@cat6man I can’t try that view, because I’m using RM 8 Essentials. Pedigree and Family view are OK.

Do things change when you force a refresh by resizing windows?

changing resolution on desktop made no difference, no names visible in descendants view on my desktop ubuntu machine

i get a descendants tree structure, dates and locations show up, but the names are missing.
if i put the cursor on where the name should be displayed, i get information about the person, so it seems to clearly be a display error.

any idea what part of microsoft windows10 is responsible for display functionality?

is it directX? from what i can tell, there are many versions of directX, not just directX9 or directX10, but subvariants like d3dx9-29

Well, sort of. Direct 3D and DirectX are part of it, but in this case, I suspect it’s a font problem. And I think that, because you can see a tree structure, so it’s clear that the shapes can be drawn. And Windows always has a fallback scenario to start software drawing when DirectX is not there to access your video card.

You may see more when you run RootsMagic in terminal mode. You can do that by changing directory to

~/.wine/drive_c/Program Files (x86)/RootsMagic 8

and then typing

wine RootsMagic.exe

You’ll probably see a lot of output then, including lines that tell you which fonts are found, if any.

I changed directory by using Nemo to display hidden files, navigating to the proper path, and start terminal there, but you can of course also use the cd command with the proper parameters and backslashes where needed.

this is what i got

wine RootsMagic.exe
00bc:err:setupapi:SetupDefaultQueueCallbackW copy error 1812 L"@mscms.dll,-1" → L"C:\windows\system32\spool\drivers\color\srgb color space profile.icm"
00bc:err:setupapi:SetupDefaultQueueCallbackW copy error 1812 L"@C:\windows\system32\ws2_32.dll,-1" → L"C:\windows\system32\drivers\etc\hosts"
00bc:err:setupapi:SetupDefaultQueueCallbackW copy error 1812 L"@C:\windows\system32\ws2_32.dll,-2" → L"C:\windows\system32\drivers\etc\networks"
00bc:err:setupapi:SetupDefaultQueueCallbackW copy error 1812 L"@C:\windows\system32\ws2_32.dll,-3" → L"C:\windows\system32\drivers\etc\protocol"
00bc:err:setupapi:SetupDefaultQueueCallbackW copy error 1812 L"@C:\windows\system32\ws2_32.dll,-4" → L"C:\windows\system32\drivers\etc\services"
00bc:err:setupapi:SetupDefaultQueueCallbackW copy error 1812 L"@wineusb.sys,-1" → L"C:\windows\inf\wineusb.inf"
Could not find Wine Gecko. HTML rendering will be disabled.
Could not find Wine Gecko. HTML rendering will be disabled.
wine: configuration in L"/home/marty/.wine" has been updated.
0024:err:module:process_init L"C:\windows\system32\RootsMagic.exe" not found

Did you change directory before typing the command?

Your working directory must be the one that contains RootsMagic.exe

my path on ubuntu was not the same as yours, but i found the correct one.
i get only one error message when i start this way on a command line.
i do see that i now get the truncated surnames (same as on laptop) instead of no surnames as all.


wine RootsMagic.exe
00f8:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

update: i can get rid of that error message with the command line
sudo apt-get remove winbind && sudo apt-get install winbind

however, names are still trunctated (usually to 5 letters but sometimes fewer, sometimes more, depending on where in the tree people reside)

another update: when i run from the command line with wine, i see truncated surnames.
when i run the previously installed program from playonlinux, i get no visible surnames

maybe i should uninstall everything and try a clean install…tomorrow!

Well, I got that winbind error too, but I think it’s irrelevant to the font issues. And when I run RM from the command line, I see a lot of other messages too, about fonts, and those are the ones that I find the most interesting.

Note that I use Wine 7 on LMDE 5, which is based on debian, not ubuntu.

I also found that PlayOnLinux is too rigid, so it really gets in the way with how I want to work. I use winetricks instead, and sometimes just winecfg.

Uninstalling is a good idea, I think, and I suggest winetricks for that, even though its UI is not as fancy as that of PlayOnLinux. It gives me more control, so it helps me to know what I am doing.

In the mean time, I also installed Linux Mint 21, which is based on ubuntu 22.04, so that I have an environment that is quite similar to yours on my laptop, with the Wine version supplied by Mint/ubuntu, which is 6 point something.

And on that, I got RM 8 to work with GDI+ and the Windows version set to 10. I installed the program without the modern web browsing (Edge) component, using the Uninstall feature of winetricks, which has an Install option.

i installed under winetricks and i only see one problem, similar to the laptop case, where the last letter of surnames is often (but not always missing) on in the descendant view. all the folks are there, i just can’t get all the surnames correct in that view on screen. when i print the descendants tree, all the surnames are correct, so i can live with that since i only use descendant view when print it out or saving to pdf.

thanks for the winetricks tip on installation. i had no idea “install” was hiding behind “uninstall”!