RM 8 on Linux/Wine

I wonder if any Linux users have yet been able to get RM 8 to run in Wine. After years of running previous versions with only minor glitches, so far version 8 is completely failing to run for me.

I’m on Ubuntu 20.04 and Wine 6.0.1 (current stable version). I downloaded the Windows installer and am installing to a separate Winebottle so as not to corrupt my default environment. The setup runs fine, and when I launch Rootsmagic.exe I get the prompt that asks if I want the licensed or the free version. After I select Free Version, I get a Program Error message. Looking at the messages that scroll by in the Terminal, I’m getting this error:
wine: Unhandled exception 0x0eedfade in thread 24 at address 7B00FD36 (thread 0024), starting debugger…

I’m not finding much helpful info about that error yet, and will continue to work this from the Wine angle as well. But I wonder if anyone has had the same experience and, if so, suggestions on whether this is a winnable problem. I’ve really been looking forward to version 8 and don’t want to get stuck on 7. But before I buy it, I need to know I can make it run on Linux.

After seeing a thread about RM still being 32-bit, I thought I’d try setting the environment in a new Winebottle to 32-bit (WINEARCH=win32), but I get the same result that way as well.


A very brief search brought the following threads up:

WINEARCH: How do you run a 32-bit Windows program on Ubuntu 20.04 using wine? - Ask Ubuntu

sudo dpkg --add-architecture i386: How do you run a 32-bit Windows program on Ubuntu 20.04 using wine? - Ask Ubuntu

1 Like

Thank you for the suggestions. I’m encouraged that I got such a quick reply from anyone. This is a great community, but I know I’m really out on an island as a Linux user. We’re an odd bunch.

However, I’ve done both of these things. The add-architecture bit is something I do when first installing Wine, and the WINEARCH bit is how I went about setting up a 32-bit Winebottle for by test. The file system in that Winebottle looks good, as I’d expect a 32-bit OS to look, so I think all is well there.

Thanks again. I welcome all input. I really want to find a way to make this work.

Just letting the RM Team know there are other users in the community interested in using RM8 with Linux.
Because of large multiple monitors I still run RM7/RM8 on an older but still very capable fast Win7 workstation. However, when circumstance dictate buying a new workstation it will run Linux, leaving Windows behind. By that time I hope a more mature RM8 is working with Wine.


I used almost identical configuration except chose licensed version at the end. The following dialog box would not even allow me to enter licence name or key, almost as if keyboard input was being blocked in the text boxes. I’ve tried installing various libraries and fonts recommended for RM 7 using winetricks but nothing worked yet. Still searching for solution.

I’m hoping that they will compile RM for Linux.
That’s what cross platform is all about

1 Like

Are there any genealogy programs written for Linux?

The one program that I know of with a Linux version is Gramps. It’s also free and open source. I tried it years ago when I was looking for somewhere else to go after Ancestry announced they were discontinuing Family Tree Maker. I don’t remember what factors made me go a different direction, but I doubt most people would consider it a good replacement for RM.

1 Like

Perhaps the potential user base does not make it economic.

Not exactly answering your question but I downloaded Virt-Manager from https://virt-manager.org/, installed it, downloaded a Windows 10 ISO file, installed it in Virt-Manager (with a lot of help from YouTube videos). Then installed RootsMagic 8.
It works fine.

One thing though, I have not been able to pass files between Windows 10 (in Virt-Manager) and the rest of the Linux file system and vice-versa. I think there is supposed to be a way though.
For me it has not been much of a problem so far. I use Ancestry.co.uk on Linux and then sync to RootsMagic 8.

There are some YouTube videos that show you how to DeBloat Windows 10.

1 Like

Using a Windows VM is certainly one option. I use VirtualBox myself (https://www.virtualbox.org/). That’s fine for kicking the tires on RootsMagic 8, which I’ve already done. I also have my old Family Tree Maker installed in a Windows 7 VM for when I occasional want to do some specific task with that. But as an every day practice for going about my work, that’s not the way I want to go. If I eventually end up in a situation where that’s my least bad option, maybe. But I figure I have a long time to use RM7 before I’m forced to make a choice like that.

As for my first preference, I’ve been toying around with Winetricks to see if I can find the right thing to add to Wine to make RM8 work. So far, I haven’t found the magic bullet. If I figure it out, I’ll post the solution here for benefit of any other Linux nerds out there.

P.S. VirtualBox would solve your file transfer problem. It has a Shared Folders feature where a directory on your host file system appears in your VM as a drive mapped to a network share. So moving files is as easy as dragging from a folder on one drive to a folder on another drive.

1 Like

I am also experimenting with a VM, albeit Linux guest on Windows host. I anticipate that at some point I might get out of Windows and thus have Linux as host, at which point a Windows VM should work to handle RM and 2 other apps that I use that don’t have Linux compilations. The Shared Folders is a great idea, but I must admit that I am having trouble with the permissions settings to enable me to actually access the host folders… hopefully a problem that I will figure out and resolve soon.

another linux user here.
i have been happily using RM7 under wine with no problems.
i found that wine needed to load a few things that were not in the default.
all credit to the link below, from which i’ve extracted a few paragraphs at the bottom.

i assume we could do the same thing with RM8 if we just knew which additional installations options were needed. since RM8 runs on MAC, they must have solved this problem already by identifying the windows components needed.

now we just need someone good enough at computer software to identify those for us…unfortunately, that Windows expertise is way outside my skillset

(from above)
Today I took another look at the problem. First I installed a Linux program called PlayOnLinux … “a graphical front-end for the Wine software compatibility layer which allows Linux users to install Windows-based video games, Microsoft Office, Microsoft Internet Explorer, as well as many other applications”. This program was easily installed by opening the Ubuntu Software Center and searching for PlayOnLinux in the default repositories.

RootsMagic is not one of the pre-programmed PlayOnLinux games or utilities, but by clicking the big + icon in the top menu to install a new program and in the bottom left by clicking the ‘Install a non-listed program’ link I was able to re-install the RootsMagic6 and RootsMagic7 programs into two separate virtual program areas. Neither worked at first until I enabled the necessary GDIplus component features. This is done easily within PlayOnLinux by highlighting the program and selecting the ‘Configure’ link in the right menu area, and then clicking the ‘Install components’ tab, highlighting ‘gdiplus’ from the list and finally clicking ‘Install’ at bottom right. PlayOnLinux does all the heavy lifting and figures out what to download and install from there.

To get my RootsMagic7 to work, I only also had to install the ‘ie6’ component for my RootsMagic7 program, again after highlighting RootsMagic7 (that’s what I called it when I set it up), and then selecting ‘Configure’ in the right menu area, then clicking the ‘Install components’ tab and highlighting ‘Internet Explorer 6’ and finally clicking the ‘Install’ button at bottom right.

Addendum: Also installed (using PlayOnLinux) the ‘Flashplayer’ and ‘msxml6’ components to get the interface between familysearch and rootsmagic to work properly … as above highlighted, then selected ‘Configure’, and then selected the desired components, then ‘Install’ … and voila!

(end quote)

in summary, it looks like RM7 needed to add

  1. GDIplus
  2. ie6
  3. msxml6

all we need from RM is the equivalent list for RM8.
we are NOT asking for ongoing support for linux, just a helping hand with getting us operational.
rootsmagic: can you help us here?

1 Like

I don’t think this applies as the Mac version of RM8 is a very different code base rather than the Windows version fudged to run on a Mac. Yes, the ‘source’ code is the same, but the development tool produces native Mac code. At least, I think that is the case.

However, the Windows version must depend on certain Windows ‘components’, so your question is very relevant.

You are correct, while rm7 used codeweaver to do a wine-like process running on a mac, rm8 apparently uses native mac code.

However, I’ve made some progress and have rm8 running under wine (ubuntu).
I have not done any use/testing yet, but it loaded fine and shows my tree.

I added the following components in Wine:

  1. gdiplus (same as for rm7)
  2. ie8 (unlike ie6 for rm7)

Just those two did it for me.
Now to see how it works :slight_smile:

Let me know how/if it works for you and any other observations/improvements.
I’m a licensed rm7 user but am only running the trial of rm8 until I convince myself that rm8 works on ubuntu.

edit: i was running 8.0, but ran into problems upgrading within app to 8.1

8.1.1 uses Edge. Maybe that is the problem.

i don’t see an ‘Edge’ component in wine

i’ll try a clean 8.1.1 installation (rather than the internal upgrade)

I did a little research and Edge doesn’t work in Wine yet. So the internal browser won’t work. Maybe see if you can get an external browser to launch from RM8 in Wine.

Thank you cat6man for the terrific hint. I tried so many different combinations with winetricks, I can’t believe I didn’t hit on that one. Actually, I can believe it. There are so many options in there. I’d even resorted to listing the DLLs that RM8 was loading in my Win7 SP1 VM and manually copying those to my Wine prefix. No-go. But with your hint, I’ve gotten RM8 to at least run. I can see glitches that I’ll need to continue to work on before I consider this ready to go an buy a license, but you’ve gotten me past the first major hurdle. Thanks again.

To summarize what’s working for me to date:
Create a 32-bit wine prefix (WINEARCH=win32)
With winetrics, install gdipuls and ie8

I’m a Gramps user since 2010, and I understand what you say. I use Gramps, because it’s the best choice for my language, which is Dutch, but it doesn’t have features like webhints, and it is also not able to sync data with Ancestry or FamilySearch, so I use RootsMagic 8 for that purpose, exchanging data with GEDCOM. I run RM 8 in VirtualBox, but would love to run it in Wine, because that would be much faster.