Running RM 9 on Linux/Wine

I just installed the new RootsMagic 9 on Wine, version 7.0.1. It runs fine, but when I start the program, I get 5 pop-ups that tell me “fspell not valid”. These pop-ups do not show up in Windows 10.

When I run Winetricks, I see no DLL offered with anything like (f)spell in its name, but I can find some DLL’s with fspell in their name in my Windows installation, and they don’t exist inside the Wine Windows folder.

Any idea about which DLL’s are needed?

In the intro video, Bruce says that the spellchecker is native to Windows or MacOS. Maybe that gives you a clue…

I bet it does, because that means that I can look for files with interesting names inside my real Windows folder, and see whether Wine can work with those.

I have the same problem with Windows 7 Pro install of Version 9. I had no problems with Windows 10. Reboot and reinstall of RootsMagic 9 was no help. I contacted tech support but they are on the way to RootsTech but were notified per the chat person.

OK, that’s nice to know, because it may lead to the name of a Microsoft spelling package that I can also try to install in Wine, which can be set to act like Windows 10, but doesn’t have those native spelling components.

I have never known of a spell checker in win 7.

OK, I didn’t know one either, but it would help to have a downloadable one.

I got RootsMagic9 to work today on a Kubuntu 22.04 system.
I installed the 64 bit version of RootsMagic9, as I had already converted my database in the virtual installation and copied the file over to the Wine install once I had it running.
PlayOnLinux gives Wine a bit of a GUI.
My Wine version is 6.17 (64 bit). Made the Wine Configuration be Windows 10.
The fspell error is a missing dll named:
I copied a version from a virtual installation from:
and pasted that file into the same location within the Wine installation.


OK, that’s nice, thanks! I tried several other files, after seeing their names in wine logs, and even tried hacking the registry, and nothing helped.

This file does the job, in Wine 7.0.1.

I’m using winetricks here, because that gives me a better sense of control.

I just upgraded to RM9 and was able to install it with winetricks, then added the fspell-fixing dll.
So far, so good.
Now I can’t figure out how to import my rm8 files.
I follow the instructions on the rootsmagic website,

Steps to Upgrade RootsMagic 9 From RootsMagic 8

  • Firstly, open RotsMagic 9 to transfer data from RM 8 to RM 9.
  • After doing so, you need to go to the file name mentioned on the left side of the RootsMagic screen.
  • Then, you have to choose to create a “new” RootsMagic file and then you need to go ahead to import from RootsMagic 1-8 or another program.
  • Then, right-click on RootsMagic versions 1-8, go there, then move your cursor over the default folder and select Documents.
  • Next, go to create a new RootsMagic screen and then you need to choose documents and then finally, move ahead to the “save button” mentioned at the bottom.
  • Go to the new file options screen and then need to click on the ok button there.

In my installation, i never see the option for version 1-8, I only see options for 1-7.

I had a “chat” yesterday with rootsmagic support and they told me that all rom8 files were “locked” and “expired” and that they could update/convert the files for me FOR A FEE! I declined and said that I wanted to do it myself.
Bizarre, huh (note I did not mention linux at all on the chat).

I assume some of you have probably figured out how to do this and I look forward to your help.

I assume

I had a “chat” yesterday with rootsmagic support and they told me that all rom8 files were “locked” and “expired” and that they could update/convert the files for me FOR A FEE! I declined and said that I wanted to do it myself.
Bizarre, huh (note I did not mention linux at all on the chat).

You did NOT speak to a RM support agent. We never offer support for a fee. Sounds like you got a hold of one of the scam sites that advertise on the internet that they are RM Support. Make sure you only go through the website and not any other site out there.

wow. it sounded bizarre and i thought i was on the rm website at the time, clicked on technical support, and a chatbox option open in the lower right. i just did this again and the chatbox is dark green. yesterday, it came up as a pale light green…very strange. you might want to warn people about this.

by the way, i looked around the forum and found that you just need to copy the rm8 files to a new location, set directory settings, and simply open the files from found files (not recent in old directory), wait a bit and get the ‘do you want to update to rm9’.

edit: it looks like the link i thought was RM was a fake.

fake link below. do not use<<<<

And I didn’t even copy them to that new location, but simply left them where they were and opened them with RM 9, which did the conversion indeed.

With the spell issue fixed, RM 9 is very stable here.

i do seem to have things working here now.

a question regarding opening files.
when i want to open an existing RM file, i get a list of ‘recent files’ and after a long search, a list of ‘found files’. even though i’ve set the folder settings to c:\users\me\My Documents\Genealogy\Rootsmagic9,
the ‘found files’ seems to search the entire c:\users\me\My Documents\ by default, which results in a very long search before it opens the file i’ve selected. any idea why the ‘found files’ is not searching just the Rootsmagic9 folder?

by the way, i’m running ubuntu 22.10 (the latest), and installed the 64bit version of RM9 with winetricks, only adding the gdiplus application and copying the fspell dll as above.

so far this seems more stable than rm8 on ubuntu, however i still have the problem with truncated names in the descendant tree view (on-screen issue, reports printed out or saved as pdf are fine).
anyone else have this problem or know a solution?

I know nothing abt the system you are using as I have Windows 11–so not sure any of this will help-- I have quite a few files in RM 9–some of the same ones in RM7 and basically all the same in RM 8-- when I go to FILE- Open a file-- it shows me all the RM 9 files that I have 1st— then RM 7–then RM 8…
Do you have a large quantity of files that you are using on RM 9?–maybe using some that you have NOT made a backup file for yet in RM 9?

When I 1st started using RM9, I just opened the files from RM 8 – so every time I backed it up and exited the program, it saved my copy to RM 8 even though my directory said

I just started over and imported all my files by gedcom ( I never have problems with data loss) and then saved them-- that put the backup in RM 9…

If you are mainly dealing with just one database right now, you could go to settings and under the 1st icon-- put a checkmark in Open last closed file…

hope it helps

1 Like

again I know nothing abt your system

when you want to open a file, are you using something like search for file or get a box similar to this
BTW— I had to go back to RM 7 for this–I haven’t found it anywhere on RM 9 which should have this

Anyway on the first image in RM 7-- it use to be that if I clicked on SEARCH FOR A FILE–it would take forever as it seemed to search the entire system on the computer–learned very quickly to click on OPEN A FILE which took me right to the RM 7 folder–just a thought and maybe somebody out there knows more than I do…

@nkess In RM 9, the search is automatic, so you can’t avoid it.

1 Like

Ennoborg, can you please post a complete set of instructions on how to install Rootsmagic 9 on Wine, 6.17 would be fine, that don’t assume that for instance we know what to do with Winetricks?

I tried your instructions for Rootsmagic 8, but they aren’t complete, and it immediately gave me some issue about the 32 vs 64 bit though I tried to install 32 bit Rootsmagic 8 in a 32 bit bottle.

Your instructions were never complete.


Hi Dora,

Are you sure that you use Wine?

I’m asking, because Wine doesn’t use the term bottle, so it looks like you’re using the bottles software, and that complicates things.

Basic installation is simple, so I have no idea what kind of instructions you need for that. It’s the config that counts, and that’s the easiest with winetricks.

I think that winecfg can only do part of the job.