Restoring a Backup

I am currently using the latest RM version I backup (to my computer) virtually every day. Today I wanted to check an earlier version of my database, so I closed it, and then clicked (File) (Restore from Backup). I chose a backup file from 2 weeks ago, and named a new directory location to restore it to. I then saved the backup (same name, to the new location) and I got the message: “This backup does not contain a valid RootsMagic file.”

Is anyone else having this problem, or am I incorrectly trying to restore a backup?

I am not having any problem with your described methodology. As a point of semantics, when you say:

I would suggest that You are not saving the backup (the backup is already saved), but rather restoring the database from backup (to the new location). When I follow your procedure, instead of an error message… I get a new RM8 database window open to the path that was specified as the new location. So, seems like there may be an issue with corruption to that particular backup file. You should demonstrably do a new backup and follow that with a Restore attempt to that same new location in order to regain assurance that backup is working for You as it should.

Is it possible that you made the backup with a Community Preview version of RM8 that was still using the RM8 file extension rather than the RMTREE file extension?

One thing you might try is to rename your backup file from two weeks ago to have a ZIP extension, then look at with a zip utility to see what is inside. You should be able to see your original RMTREE file just fine (or maybe an RM8 file, which is why I was asking).

That’s all an RM backup file really is - a zip file with a different extension. Your full RM database is zipped up inside the zip file. I’ve discovered through the years that quite a bit of software uses this trick of making a file in zip format but not with a ZIP extension. RM is not the only software that uses this trick.

1 Like

Thanks for the response. You are of course right in saying “You are not saving the backup (the backup is already saved), but rather restoring the database from backup (to the new location).” I used the word “save” because the program requires me to use the Save Button to continue.

Anyway, I just did a new backup as you suggested, and what do you know - it restored to the new location! I also tried the former backup version, and it also restored!

I had tried to restore 3 or 4 versions before I posted - several times each - and always got the message that the file was not a RootsMagic file. Go figure! Anyway, thanks again.

Thanks also for your reply. I was using the Community Preview version, but purposely picked a backup version with the RMTREE file extension to restore, so that was not my problem. Anyway, my restore seems to be working now, so thanks again for your reply.