"Publish" feature produces unreadable graphics

I love the “Publish” feature to produce custom-designed Ancestor charts to share with family members. But occasionally the output was gibberish. I asked technical support for help. They told me that they had had a few similar reports but had not been able to duplicate the problem adequately to find a fix. I think I might have found one. If I try to produce a report immediately after opening RM9, I experience the problem. But if I allow the program one or two minutes to open fully it seems to work.

I hope this helps someone else. In general I love the program and I especially like the “Publish” feature. If it just needs time to open properly and fully, that’s fine.

Please submit a detailed bug report to tech support so they can address the bug.

I submitted a bug report and worked with the tech people for a week (back & forth, even sent copies of the problem. They gave me a report # and closed me without resolution and without contacting me before closing it. I looked for my # but cannot find it. Don’t know what to tell you, except that sometimes the Publish feature for Ancestor reports works great, and sometimes all it produces gibberish across the middle of the page. No amount of fiddling with the options helps. I suspected that it might be because I am using two different size monitors, but I tried using only one monitor and that didn’t help. But sometimes, it worked just fine. Beautiful reports. All I can tell you is that I “think” it works if I give it about 3 minutes to open the program before I use it.

@wwsteen – I don’t exactly understand abt support closing it out without notifying you BUT even though you can’t find the #, you can still access the info sent back and forth–
go to https://support.rootsmagic.com/hc/en-us

upper right hand corner --submit a request- sign in

once you sign it-- your name appears in the box–click on that for a drop down menu and select

I made a request, I had a request number, we exchanged a lot of information. I spoke with the support person on the phone. I checked on the status of my request once, and it said something about the matter being closed. Can you find the request number and all the stuff I previously sent by using my name or email address? Or are you suggesting that I start all over?


@wwsteen NO Wes, I wasn’t suggesting you start all over as I really think you figured out the problem when you said you waited a couple of minutes…
I don’t know abt PHONE SUPPORT but on a chat or by email, you can sign in as I stated and still view
everything that transpired between support and you-- this is a partial list of mine…

and this is the start of one of my emails I sent


Once an item on a ticket is reported to development it is marked closed. Development works from their list. We don’t follow up when development releases an update on a reported or requested item. If you were just sending in a file then we have 3 days to retrieve it and we close the ticket. We don’t reply to SendThisFile submissions since the only activity is to download the file. The agent should be working on the initial ticket with you where the request for the file was made.

1 Like

OK. Thanks. I just had no idea what the “closed” message meant.

I’m OK, I think. The problem I was having seemed to be random, and I have tested my “fix” every time I open Roots Magic——-I allow extra time for the program to open before I try to publish a chart. So far, it seems to work consistently. If I don’t allow a minute or two for the program to open completely, then the graphics are unreadable until my next session.

I really do love the program. I think I started with RM6 or 7, and I’ve bought every update as soon as they are available. I understand that the RM9 redesign was an incredibly huge task. I’m happy to help if I can. Let me know if there is something else I can do.


1 Like