Maybe RM10 is not closing Source panels in Edit Person so much now

RootsMagic, 64 bit, Windows 10

I have noticed for the last couple of days that RM wasn’t closing the Master Source panel in the Edit Person screen out from under me as much as it used to do. It drives me crazy when RM closes that panel out from under me because I may have to re-open the panel several times to complete the data entry for a new source.

I was trying to figure out if the wonderful change in behavior came about because of RM10 or because of something else. Then I remembered that I have been running with the Use slide-in workflow on Edit Person when clicking the fact list icons feature disabled for the last couple of days. So then I was wondering if the change in the behavior of RM closing the panels out from under me had something to do with RM10 or if it had something to do with the slide-in workflow.

In case you are not familiar with the slide-in workflow, it’s a feature whereby clicking on the fact list icons in Edit Person gives you a full screen view of whichever icon you click. I typically run with the feature enabled to make more space for data entry when I am entering new sources and citations. But it’s all or nothing for all the fact list icons, and I also find some downsides when the feature is enabled. I only use the feature to get more space for entering new sources. And again if you are not familiar with the feature, it is enabled and disabled via Settings => Program Settings.

So I enabled the slide in workflow, and RM10 started closing the Master Source panel in the Edit Person screen out from under me again. Then I disabled the slide in workflow and RM10 continued closing the Master Source panel in the Edit Person screen out from under me. Go figure. Then I shut down RM10 and restarted it while leaving the slide in workflow disabled, and the good behavior returned of not closing the Master Source panel in the Edit Persons screen returned.

So I tried the same experiment with RM9. The bad behavior is identical to the bad behavior in RM10. I can eliminate the bad behavior in both RM9 and RM10 by turning the slide in workflow off and leaving it off. If I just toggle the slide in workflow on and then back off, the bad behavior returns and doesn’t go away. Well,it goes away if I turn the slide in workflow off, shut down RM, and restart RM.

If the slide in workflow really is the cause of those panels closing out from under me, that may explain why nobody but me has ever mentioned the problem. And it may explain why the RM folks hadn’t seen the problem if they tried to see it. I suspect most people don’t use the slide-in workflow feature or even know it exists.


Not sure what you mean by ‘closing out from under me’. Can you explain please? I use the slide-in workflow feature, and I’d like to understand if I’m missing something here!

The easiest way to explain is to make a short video. Actually, I made two videos and they are both very short. The first one is with the slide-in workflow on and the second one with the slide-in workflow off.

Remember that to get the full effect of keeping the panel open when the slide-in workflow is off, you have to turn off the slide-in workflow, shut down RM, and restart RM. Simply turning off the slide-in workflow off doesn’t do it.

1 Like

Confirming issue has been reported to development.

You are certainly not alone on this one. The collapsing Master source sections are very annoying. I suspect others are like me (who do use slide-in-workflow) and assume that this issue is on a fix list, since it was initially reported to development back in RM8 days.

Thanks for bringing it back into focus.