Mac user disappointed in RM8 - moving to MacFamilyTree

My expectations for RM8 were fairly modest I thought… a solid, mature program following in the footsteps of RM4 through RM7 in its functionality but running natively on Mac. As a side benefit I was looking forward to receiving any tweaks and improvements that would come with the rebuild and thoughtful, realistic user input. My databases are relatively small, the largest at just over 5,000 persons, and incorporate no media. I do not rely at all on RM integration with web-based services such as Ancestry or Family Search. I lent a small hand as a beta-tester.

I started with RM4 in 2009 and I have worked with RM8 now since it opened for beta-testing. I have finally made the decision to move on to another program as my primary one. RM8, in my experience, had been a step back from the speed, functionality and user interface from RM7… even at fairly basic levels of use.

I have been using desktop genealogy programs since The Master Genealogist was a DOS program. I have tried many since then - Windows-based on PC, then Windows-based on Mac running virtual Windows and native Mac-only programs. With my introduction to RootsMagic 4… I felt I had arrived at the best balance of features, usability, dedication to sourcing for my purposes.

All programs have their strengths and weaknesses and it is a balancing act to find the desktop application that meets one’s individual needs. Unfortunately, for me at least, that now means moving on to another platform.

A huge thank you to Bruce and the entire RM team for all your hard work and dedication. I will continue to test the RM waters in the future but for now… all the best.

Regards, Scott

I bought MFT but found the person data screen just an awful long display with endless scrolling. and the peditree…tree views were just ghastly. Unlike RM8 it is one of the smoothest running mac programs I have ever used.

Take a look at FTM 2019 on the mac. It is a stable functional program with an excellent person data screen, handles media with ease (photos; PDFs) and integrates with ancestry hints. My only gripe is the small text size. An update is expected this year.

But FTM 2019 looks horrible!

1 Like

No more so than RM8, which gets my vote and the worst UI in the last decade.

1 Like

I find the FTM interface to be great except for the text size. If you do not want the sidebars and bottom bar you can close them. The tree view is good (RM8 is bettter) and the person…edit screen is much better than RM8. It shows all facts with all media shown at the bottom and on the side for a selected fact. Media is easily dragged or copy pasted en mass to a person or fact with no “is this a jpg or pdf garbage” and the mac version simply does not stumble every few actions like click-happy RM8.

FTM is expensive, has no trial version and MacKiev makes you click through 20 pages of trinkets before you can download the program.

you’ve led a sheltered life then!

To each their own when it comes to preferences, it appears. I’ve used genealogy programs since the LDS church was offering free (pay for shipping) Mac programs and owned a personal computer since 1981.

I switched away from Family Tree Maker to Roots Magic. I found the FTM interface to be utterly non-intuitive and it never “stuck” in my muscle memory. Plus the updates were frequent and overly-pricey for what was being offered.

I looked at MacFamilyTree and found the display screens to have all sorts of bells and whistles that I wouldn’t use, and really didn’t like the interface.

I find RM8 to be easier to use and gives me the screens I want. I can’t compare it to earlier versions, as this is my first time on RM, but there are so many variables that affect speed that I disregard most comments in that regard. It’s sufficiently responsive on my setup, below.

[Mac mini early 2020, core i5, 16GB RAM, 512GB SSD, on 10.15 Catalina]

1 Like

Hardly! I have been a software developer off and on since 2005 and began working with and programming computers prior to the appearance of Windows or MacOS. I have had hands on thousands of software packages, feeware, shareware, and paid. RM8 has an interface that only the complete computer incompetent could love. It violates a shed load of UX and GUI design standards and principles. It wastes a shed load of space. It attempted to reverse the standard left to right eye movement when creating reports…which was finally changed after a good deal of harping.

Suggest you look at FTM 2019. Updates are only every 2 years or so. Things are completely different since Ancestry dumped the program and their customers due to their internal incompetence. MacKiev picked up, spent over a year fixing it and it is now a stable fast app with a good interface. It is the only program with a person edit screen similar to but better than rootsmagic. All other mac programs I tried simply do not present everything in a useful manner. FTM is high priced and text is small. RM8 text size is much better but requires a lot of clicks to get anywhere, is full of serious bugs and handles media poorly.

1 Like

My requirements and expectations are very similar to yours - a few thousand people in each file, no media, and I don’t particularly need to integrate with online databases. I also did a little beta testing. Today is the first day I have tried to use RM8 extensively - converting one of my RM7 files, using DataClean tools, tidying up sources, doing some merging, and creating groups.

I was a little disappointed in RM8 before today but I am now feeling totally disillusioned. I’ve been getting Access Violations every 10 minutes or so, requiring me to close and restart RM (I feel as if I’m using Windows rather than a Mac!) The program seems slow and lots of things I used to do with a double-click in RM7 now seem to require me to move my mouse and click on a button somewhere else on the screen. I don’t find the interface at all intuitive and, like some of the others who have commented, I’m from a software development background and have lots of experience with many types of both Windows and Mac software. I think I may need to look for something else and maybe try RM8 again later next year to see if it has improved.

1 Like

unfortunately RM8 has apparently ported some windows behavior like access violations to the mac. AVs are less frequent than initially but have multiple normal action triggers on the mac. This may be worse on mac than windows.

RM8 does have some nice features despite design flaws, non-standard mac behavior and serious bugs. I am using it as a helper tool for FTM 2019 which has the excellent person edit screen similar to RM7 showing all a person’s data.

Greetings all.

I’m a newcomer to genealogy software, so when I saw that there was a discount on Mac Family Tree for the launch of their new version, I asked a friend of mine who has been documenting the genealogy of her family for decades about her advice. She pointed me in the direction of RootsMagic as she has been a happy user of the software for years (on Windows - I’m a Mac user).

Following her links, I saw that RM8 had been launched, and that there was a free version I could try out before deciding whether to buy the full application. I downloaded and installed it.

I have to say, I’m very disappointed in the quality of the RM8 release for the Mac. It is essentially unusable. Worse, from the perspective of RootsMagic, it’s not only not a good advertisement for your product, it’s actively harmful for your company’s reputation, at least amongst Mac users. It looks and feels like it hasn’t been beta-tested with many people who aren’t already familiar with previous versions of RM - all of which, I understand, were the Windows app in some kind of wrapper to enable it to run on a Mac.

To help with efforts to resolve the problems, here’s my setup: Mac Studio with M1 Max, 32Gb of RAM. Running the latest public release of macOS (Monterey 12.3.1).

Problems: A completely un-Mac like user interface, that doesn’t look like the developers have even looked at Apple’s Human Interface Guidelines: Human Interface Guidelines - Design - Apple Developer All the functional menus are in the app, instead of the menu bar, and they’re really not easy to figure out. The fact there isn’t a ‘Help’ menu bar item, and isn’t a help file that I could find, isn’t a great experience for a new user to this ‘taster’ product.

This would be sustainable if the rest of the app worked well, but it does not. I started entering some very basic family tree information. Then I tried to open up the entry for myself, to enter a date of birth. Nothing seemed to happen. So I tried opening it up again by double clicking and got an error message telling me that the free version doesn’t support opening more than one edit screen at a time. That would be fine, but the app was still only showing me the main window. It turns out that it had opened the edit window, but when it did so, it placed it behind the main window instead of on top of it, so it was completely invisible to me and I couldn’t know that I’d already successfully opened the edit window.

Having found the edit screen, it still is completely unclear how to enter basic information like a date of birth. It’s also completely unclear why, when both parents are listed in one line for ‘parents’ there should be a second line with the same data. Choosing the item to ‘delete a fact’ - i.e. the second entry for parents results in an error message saying ‘You can only delete a fact’. Well, yes, that’s what I was trying to do. (Screenshot attached).

When I create a record for my sister, there’s no field for entering the previously entered data for her parents. After creating the record, I open it up to edit it, and I still can’t see how to add her relationship to our parents. Things are made even more frustrating because there are no tool-tips to display what different icons mean when you move your cursor over them.

In short, a very disappointing experience, and one that actively puts me off paying for the full version, which clearly can’t be your aim.

I find some of your comments difficult to follow, but I do wonder if you have gone through the Settings procedures correctly for how you want to RM to work? My Edit Person screen, for example, displays in front of the main window, not behind it. I really do think you need to play around with the program a lot more before writing it off.
And by the way, I’m a Mac user …

I’m not a fan of RM8 and, as a Windows user, find the user interface terribly inconsistent with Microsoft’s UI guidelines. However, in its defence, there is a Help system in the form of an online wiki that opens from the program in your browser. It should cover the basics such as linking a child to its parents and is accessible, iirc, with the F1 key or from a control on the upper right of the window.

At the bottom of the main window is the status bar. When an Edit Person screen has been opened you will see their name listed there. Click on it to call the Edit Persons screen forward.

In your screen shot it looks like you are trying to remove the link to the parents. That must be done outside of the Edit Person screen and in a main view. Right click on the person and select Unlink, from parents. There are other unlink options noted on the wiki page.

When you need to add links to other people that is also done outside of the Edit Person screen and in a main view. When adding parents, spouse or children you can select the option to “Select existing person” and that will create the links between individuals.

A newly opened Edit Person screen opens in front of the main window nearly all of the time, but not all of the time. However, there are all kinds of things that can cause an RM screen to pop under the main window. Such pop unders can happen for the Edit Person screen and can also happen for all kinds of other RM screens. It can be hard to know that such pop unders have happened. It can be hard to know that your lost screen really is still there somewhere. And it can be hard to get your lost screen back, even though it’s still really there somewhere.

There is a message later in this thread that explains how to identify pop unders when they happen for the Edit Person screen and how to get the missing Edit Person screens back. In my opinion, the way to identify the Edit Person screens that have popped under is very hard to notice and hard to use. It is not well designed at all. But at least it exists. For other pop unders, it’s like your RM8 has locked up and you have no way to know that your pop under screens are still there nor how to get them back.

Unfortunately, the pop under situations do not seem to be repeatable. I’ll do something that apparently causes the pop under. Then I’ll try to replicate the problem so that I can report it and it won’t happen the second time. It is very frustrating. I’m a Windows user, so I can’t speak to what the pop unders look like on a Mac.

By the way, there is nothing you can do in any of RM8’s setting screens to address this problem. Instead, the problem is deeply baked into the way RM works.

Thanks Jerry - that’s interesting.

I must confess I haven’t had the pop under screen, or not that I’ve noticed. Probably because I don’t ever try doing anything especially fancy

Hi Renee

Looking to my main window there is a lack of name at point 7. Status bar, I have a person highlighted as shown at

That indicates you have no Edit Person windows open. You have not double-clicked on any individuals to open their Edit Person screen.

Thank you for that, I see it now, but what is the point of that, please tell me.