Firefox browser & FamilySearch non-communication

Is anyone else on Mac having a problem getting the FamilySearch web page to open in Firefox from Publish/FamilySearch Central/view/Show on FamilyTree? This works fine with the Safari Browser but comes up blank in FireFox. I get lost when trying to find the offending issue in FireFox where, no doubt, the issue lies (and I fear the strain of looking is costing me brain cells – I could use a trail guide!)

I am prepared, if necessary, to use the simpler solution of changing my default browser to Safari whenever I use RootsMagic 9, but I would love a simpler solution.

Sounds like you are on a Mac. I don’t have Firefox installed there, just Chrome and Safari. Chrome is working. Hopefully someone else with Firefox on the Mac can answer.

Thanks. Hope springs eternal! :blush:

Worked fine for me. Assuming you’re running the latest version of firefox, you might try deleting all cookies - Settings, Privacy and Security, Cookies and Site Data, Manage Data button, then filter on familysearch and remove selected.

I’m not actively using RM9 - still using RM7 in anger - but just tried the suggested way of access. I was a little surprised that having selected someone who was already matched, it takes a very long time to show the two sets of data side by side - seems to take minutes not seconds at times - but whilst waiting for the two sets of data to show, selecting Show on Family Tree works just fine. Am using the latest Firefox but only MacOS Big Sur (highest level). So, works for me.

(still waiting for RM9 to load the 2 sets of facts even after several minutes typing this. I can get immediate access to Sources, Notes and Changes but Share Data still shows ‘loading’ in both sides. Most odd.)

Thanks! I see a weekend adventure ahead of me!:grin:

On mac Safari is a far better browser than Firefox and Chrome would be a good second choice. Firefox has been adding all sorts of default security/privacy layers and the settings here could be your problem.

Also consider whatever add blockers you are using in each browser (ublock original fox/chrome; wipr safari) and try with them off.

Check this article.

It explains how to delete cookies for the fs site. Likely to be the problem

Thanks! Now I know I’m going to have a busy (exciting/frustrating :face_with_peeking_eye:) weekend! :grin:

Thanks all again. Not surprisingly, my wish was not to be granted. The simplest and easiest solution is simply set Safari as my default browser whenever I’m using RootsMagic.

I’ve bolded your use from internal to RootsMagic, but you’ve not mentioned whether just external opening of Firefox and browsing the FamilySearch site is also blank?

Hi and thanks. Yes, FamilySearch opens fine in Firefox when accessed directly.

Choosy: A smarter default browser for macOS
I’m offering this to try (before buy), as a non-Mac user, thinking it just might call out to Firefox in a slightly different way than Rootsmagic and allow loading correctly.

1 Like

Interesting! I’ll check it out, thanks.