familySearch person tools connection

Looks like the connection to FamilySearch at the right side have been closed now for hours. Do others have a clue?

I’ve seen that but can’t make it happen again. FamilySearch appears to close the connection and in RM it thinks you are still logged in. Close the RM program, reopen and login should work.

5:17 p.m.


That was a new one, it helped. So good to have you around. Thank you very much.


This is definitely an issue. It’s happened to me at least twice. When it occurs, if you try to use the blue FS icon, it tells you that the FS matched person has been deleted.

RM7 used to freeze repeatedly when using FamilySearch. I think this was for the reason that @rzamor1 explains, combined with the lack of a timeout in RM7. RM9 is much better in this respect and doesn’t freeze. It would be better still if it recognised when FS had logged you out.

I’ve tried several times, but Family Search icon still doesn’t show on any person on my tree. What is wrong?

To show the FamilySearch icons go to Settings, General Settings, and check “Enable FamilySearch”. If you need temple icons go to Settings, LDS Settings and check “Enable”.

1 Like

I’d like to add my experience with this problem. In the last three days with heavy usage of the FamilySearch comparison screen, I’ve had to restart my computer several times, force quit and restart RM9 at least 20 times in order to get the blank blue FamilySearch screen on the right hand side to become active. Running RM9 on MacOS Ventura 13.5. No problems in the past, it has definitely become a problem recently. I can’t quite figure out if there is fixed protocol now that is required in order to avoid the blank blue FamilySearch screen?

FamilySearch is dropping the connection. If you log out on the FamilySearch Central screen it will let you log back in without having to close the program.

Thank you for the reply. I should have added that I have about 10 different FamilySearch tabs opened in my browser at any one time based on other research not pertinent to my present RM project. I’ll have to play around and see if I can solve my problem by deliberately logging out of just the one FamilySearch tab that I am using with RM.

As for the other tabs being open, you MIGHT try a 2nd browser— having RM open in the default browser and the other tabs in a 2nd browser like Google/ Edge/ Firefox etc…

Appreciate the idea. Sounds like a potential fix.

Made me wonder if I could change the browser where RM wants to open FAmilySearch. I.e., get RM to link up with FS in Chrome or Firefox, while I use Safari for everything else. I just had a look around the RM settings but did not see if I could change RM’s default browser for FS - but I am not skilled with RM.

Is this something you have tried?

Sorry I don’t know of any way that you can set RM 9 to use a browser other than the default browser–so your going to have to open RM with safari (default) then us one of the others to open everything else…

are you on Windows or Mac? as I know nothing abt Mac…

Mac ~ no problems until three days ago ~ during heavy use

On a Mac laptop. I am going to try switching some of the other FS tabs to Firefox and use my default (Safari) for the FS-RM link. Thanks.