Using FamilySearch with RM 9.1.3

I’m running RootsMagic 9.1.3 on a Windows 7 virtual machine under VirtualBox. Host is pop-os 22.04. I’ve been using this configuration for a number of years, using RM 7, RM 8, and RM 9.0.

When I try to use Publish | FamilySearch Central the normal login window appears. When I log in, the usual window telling me I can close the browser window comes up briefly. It then repeats about six more times. That is, I now have seven tabs open each one showing the same message.

When I go back to RM it acts as if the login did not succeed, even though it has told me I’m successfully logged in six or seven times. Webhints from family search do not appear, for example. As far as I can determine, only one thing works. I can jump to the FS entry for people I have previously synchronized with FamilySearch.

I am able to log into FS manually with no problem but it makes no difference to RM. That is as expected, of course. Once upon a time, I didn’t mind just opening multiple windows and cutting / pasting between them. Now I’m spoiled, so I’d like everything to work again!

Any suggestions? Has anyone else run into this?

Has anyone gotten OAuth login to FS working on Windows 7 at all?

I’ll presume that your VM is close to a standard Windows install, no gross file permission changes etc.

Does the blue bar in the FamilySearch Central screen indicate Signed-In at the far left?

The FS Central screen never appears. :frowning:

I’ve been using RM for 3 years, always on WIndows 7 and always in the configuration I described. Up to now it has worked well. I know that FS has changed some things, but my manual logging on and using it through a browser continues to work on that machine.

I did just move everything to new hardware and reinstalled RM so I’ll go back and revive the old machine to make sure it still connects.

FamilySearch works fine in both 7 & 9 for me. The Family Central screen not opening definitely seems wonky.

RM9 loads up six instances of msedgewebview2.exe …wonder how your Win 7 virtual machine reacts to that ?

I tested on my old laptop and found it still works. I noticed it’s still running RM 9.0.3, so it’s probably the new OAuth stuff that’s causing the problem. Is anyone else using Windows7 with the latest RM?

In the end, I installed a new Windows 10 VM, under which RM 9.1.3 works perfectly well.

I doubt it will work fully under Windows7, since webview2 is no longer supported under that OS. Thanks to @kbens0n for pointing that out.

For completeness… in case anyone else is dealing with it… I also installed Wine and tried to run under it. It worked just the same as Windows 7 with the Windows version set to that OS… i.e. not! With it set to Windows 10 I think it could be made to work but I didn’t want to fool around any more right now. At least under Wine I get messages telling me which dlls are missing. It needed Windows.System.Diagnostics.PlatformTelemetryClient, which is in my (real) Windows 10 distribution. I imagine it can be made to work with some effort but I didn’t know where to copy that dll.

Why so much effort to avoid Windows 10? First, because I use a lot of VMs and Windows 7 is the last version, which ran well on a small VM for me. Second, because I’m trying to get out of Windows entirely.

Thanks everyone for the help.

You could switch to a MacOS VM (snicker, snicker…)

I wouldn’t connect a Win7 machine to the internet and expect it to survive unscathed.

Isn’t there a stripped down ver of Win 11 available somewhere?

That’s where VMs are handy. They’re disposable and the host acts as a firewall. For example, my RootsMagic machine has nothing but RootsMagic on it and the data is backed up elsewhere.

What? Microsoft strip down a version of it’s OS? I wish! :wink:

Not from Microsoft, I don’t know much about it. See:

Windows 11 Perfect Install (

I’ve had the same issues. I’ve noticed the URL includes a NON-secure (http) request, so it might be something as simple as a coding error.

I noticed also during my investigation that webview2 documentation asks developers NOT to do any coding for older versions of webview, and I wonder if this is something Bruce has honored and is not supporting Windows 7 w/familysearch.

When doing netstat -b (must use administrative cmd shell) I show the following:
TCP Blue:9717 FIN_WAIT_2
TCP Blue:9717 FIN_WAIT_2

I have several familysearch pages that SHOW
You have successfully signed into FamilySearch.
Please return to the RootsMagic 9 desktop application to continue using it.
You can close this window.

But the window in Rootsmagic stays open and then seems to close and then open again, for 6-7 times.
It seemed to disappear (sometimes it doesn’t).
But when I look at WebHints, I see "To see FamilySearch hints you need to Sign-In to FamilySearch.

I was even previously logged into familysearch and that didn’t seem to make any difference either.

Basically everything you’ve done Charlie, with the same results. Also on version

No success.

I gave up using Windows 7 as a result. Now running under a stripped down install of Windows 10.

I have too much software installed on my windows 7 system to give it up. It’s hardened in different ways. I did buy a used laptop recently to load software for diagnosing vehicles, and to potentially load up software again for a book scanner that was sending stuff to China and scouring the hard drive in places it shouldn’t be looking (they use this same hardware/software in family history libraries for book scanning purposes by patrons). It took a little effort to scrub that software off my machine, particularly since I had to keep running to someone with a picture of the screen with instructions in chinese. Since that software looks around for personal info, and sends things back to China, I’d prefer not to use that system with RM9. (keep it as sterile as possible)

I’d hate to not use RM9 if it can’t connect on my win7 box.

I have virtualbox software on my system for one other piece of software that I need, but I don’t know much about the virtualbox software, and the linux VM is starting to grow bigger and bigger, and I need to learn how to get it tamped back down. I’m using it to run Signal, as that’s no longer supported on Win7. Not sure where to find a clean and legal copy of a windows 10 image without much cost to run RM9 on. I don’t want to do it on the laptop which will get messy out in the garage.

Build 109.0.1518.140 Microsoft Update Catalog was the last version with compatibility for Windows 7. Can’t hurt to try the appropriate (x86 or x64) runtime.

I found/installed it… or tried. It said I already had it on my system, so it didn’t reinstall. When I look at logs, I see the webview2 software running when using RM9. RM9 just doesn’t seem to get the reply back that it was successful getting on to familysearch.

FWIW, both my old Win 7 and my new Win 10 are VMs. When I switched to Win10, I couldn’t keep it working the way I wanted under VirtualBox so I’m in the process of switching to Qemu-kvm instead. So far, it seems to be a good choice.

With VMs, I find that the trick is to avoid loading them up. So, for example, I have a Windows 10 VM for software development and a separate one just for RootsMagic. “When I have time” I plan to try running under Wine instead.

What do you do for your VM licenses? And how do you roll them out? Do you build your on VM’s, or do you get them from a trusted source and go from there? Again, I am not a VM wizard. I just barely got this one rolling with help from someone else for the linux one to be able to run signal on it. I’ve heard of something called containers (much smaller than full OS’s?) but not sure if I can run just RM9 in one.