Double Click Does not appears to work

I have noticed that in RM8 when adding a new fact, or really, anything, that a double click does not work. Has anyone else noticed this?

1 Like

No. When I add a fact, I click on the “+” in the top right corner of the Person Edit view. If you click on an existing fact, the data is displaying on the right panel for that fact. Not sure what you are double clicking on to create a new fact. I haven’t found such an option.

I run into quite a few situations in RM8 where the double click seems like it ought to work and it doesn’t. I haven’t yet tried to make in inventory of such places. When I’m adding a new fact, I first have to click on the fact type I’m going to add and then I have to click on Ok to select it. It would be much easier just to double click the fact type but the double click doesn’t do anything.

The Ok button is visually far removed from the chosen fact type on the screen and it’s a long way to move the mouse. It’s completely confounding that the double click doesn’t work in this context.


Yes, it was one of the first things I noticed. I hope they will implement it eventually. Click+Return usually works in these situations, which isn’t as convenient but reasonably fast.

I get this a lot too. I’ve been working with media a lot and I think in that screen it’s when I’ve created a tag and need to go back in to fix the priority that you can’t just double click. I have seen the issue in other places too. There are far too many clicks required to get anything done.

I became used to the use of double clicks on the fact page and also the use of TAB when entering data on a fact. I found this problem with the pre-roll out test version and hopped it would be fixed when the final version rolled out. I find the lack of these features (available on earlier versions of RM) very frustrating and time consuming. I am considering going back to RM7. RM7 is also quicker moving from screens and facts.