Adding a person’s photo (image, jpg, etc.) to a person’s record in RootsMagic 9

Phew! Sometimes the easiest tasks are the hardest to understand! I have spent literally days trying to figure out how to add a new photo to a person’s record. Simple, right? Nope – only if you know how! Some of you are probably laughing, but after countless searches and reading RootsMagic information on the web, and of course the ‘manual’ at Welcome, and watching hour long RM videos on YouTube, I still could not figure it out. I read many times that you can do this from the ‘Edit Person’ page, but never was taught how to do it there! So guess how I finally learned how? Totally, by accident, that’s how. I noticed that for people who I already had photos for – as I had migrated from RM7 – that there was a small ‘media’ icon in their columns, but not in my new person’s column. I happened to left click on the blank space in the media column, and voila, the screen changed to say ‘Add Media.’ From there I could figure out the rest, which was to click on the plus (+) symbol, and select what to do next. The options are: Add New Media, or Drop New Media, or Select Existing Media.
For some reason, the wording on the Adding Media Items section seems like ‘Greek’ to me. I hope this article will help someone else. All the best. Bill

4 Likes

This is another way, from within Edit Person window:

3 Likes

The last five columns in the left hand panel of the Edit Person can contain icons that represent Note, Sources, Media, Tasks, and Addresses, respectively. The same five items can be clicked instead in the right hand panel. If there is not yet any data for one of the five items, the area for the item in the left hand panel will be blank and the corresponding item in the right hand panel will show 0. You can get the same result of adding or editing items by clicking in the left hand panel columns or by clicking in the list in the right hand panel.

Here’s a screen capture showing those five items for the Person.

Here’s a screen capture showing those same five items for a fact. In this case, the fact is a 1910 Census fact.

3 Likes

Keep in mind that you can create duplicate records using “add new Media”. (function)
To avoid adding duplicate records – I only use the DragNdrop method or add existing.
Drag-n-drop will add additional tags but not duplicate the mediaFile record.
If you add new media via the ADD NEW MEDIA option and you add the exact same media file 3 different times you will 3 different entries of the file instead of one. The main purpose of this was to allow different caption and title versions info. Some uses may want to make use of this – however in my opinion having duplicate files will only likely lead to much confusion and potential issues with other things such as GEDCOM

1 Like

I believe that is an erroneous supposition because, from RM5 to RM7, duplicating links from the database to a media file was precluded by the software. I don’t know about RM8 but I suspect that restriction was unintentionally lost during the transformation of the code to support cross-platforms.

1 Like

[quote=“TomH, post:5, topic:9235”]
I believe that is an erroneous supposition because
[/quote] yes – that was someone’s suspicion-- I do not recall RM confirming or denying the reason(s) for the change – based on some of RM’s response (or lack thereof) its quite possibly it was an “oversight”. The is a fairly big miss if not intentional.

Yes, that was my suspicion. It should not be considered a fact unless confirmed by RM.

I was considering if this is a bug in RM8/RM9 or if it a design feature. I suspect it’s a bug. If it’s intended as a design feature, then one plausible justification might be to support different captions for the same photo. I’m very sensitive to this issue because of RM5 destroying all my different captions for the same photo. But I repeat that we need to hear from RM on how this is supposed to work and about how to deal with any existing duplicate media files in our user databases.

1 Like

My suspicion based on RM silence either it is bug -or they are deciding on a course of action of the undocumented design "feature".

Definitely – fortunately for me my workflow has not created any.

That does not seem to work… Bill

That does not seem to work. Nothing comes up when I use the search box. Bill

Where are you using the Search box? What are you typing into it?

If by “search box” You mean the magnifying glass icon in this image… that option is for the Multimedia Gallery of images that have already been added:

Here are two screenshots of the search box I’m talking about.

Here’s the main Media tab.

Here’s the same thing in the Edit Person screen. This is the one that matters. Note well that you must use the Select Existing Media tab for this to work. In this screenshot I have highlighted in orange where the search box is presently located and I have highlighted in white where the search box really needs to be located. But moving the cursor over to the far right hand of the screen then back to the left side of the screen again is a major pain. I can’t think of a good reason not to move the search box to the left. The search box in the main media tab also needs to move left, but I forgot to mark the recommended place with a white box for that one.

I also reiterate my complaint that I always have to change the Media List format to List mode instead of thumbnail mode to see the file names. I don’t mind Thumbnail mode being the initial default if it must. But after I change it to List mode, it shouldn’t change back to Thumbnail mode unless I change it back. This problem is not new in RM8 and RM9, but was inherited from RM7. It really needs to be fixed.

1 Like

Thanks for all the Tips. However, I would prefer that the RM9 “Manual” include a detailed page something like this:

Steps to Add Media to a Person (like a JPG photo):

1 – From the “People” menu, click on the person you want to work on and then choose “Edit.”
(There are many ways to open Edit: one is in the person’s top left corner, or double click on their name in the Pedigree (tree) view, or choose the pencil icon (top right), or right-click on their name and choose Edit.)
2 – From the “Edit Person” screen, look for the tiny icon representing media. (It is just above and next to the person’s name.) Click in the box beside the person’s name, just under the media icon. (If new, it is blank. If there is already some media connected to the person, the media icon is in the box.)
3 – You should now see a screen on the right called “+ Add media.” Click on that.
4 – A screen with three choices will appear: “+ Add New Media,” “Drop New Media,” and “Select Existing Media.” Choose one of these options.
Note: If you click on the tiny folder icon far to the right of the Filename search box, a list of your files will open.
5 – If you use “Select Existing Media” you should see thumbnail images of what is available on your device. Change to the 3-line menu to see a list of your images in alphabetical order. You can browse the list, or search in the box on the right. Enter a term in the search box and push your “Enter” key (on a computer).
6 – Using your mouse highlight a photo (etc.) and click it. The photo should now show up on the Media screen to the right of your person’s Edit screen.
7 – Click on the photo to add a Caption, Description, etc. Or you can delete it with the small trash can icon at the top right of your screen. Note: Click the photo again to see a higher resolution and to be able to zoom in. Helpful with Census records, etc.
8 – Check the “Primary Photo” box if this is to be the main photo you see on Pedigree view, and on printed charts, etc.
9 – Be sure to “Save” any changes by clicking on the large check mark (beside the trash can) at the top of the screen. (The large check mark only appears when you are making a change.) Note: If you chose to make it a “Primary Photo,” it will now show in the left top of the person’s screen.
10 – Exit and continue working on your family tree.

3 Likes

RM8 & RM9 are just not intuitive for those of us who lack the technical knowledge/abilities of Jerry, Tom et al. I too wonder why it is such a clunky and difficult front end. I know everyone is going to scream at me but why is it that I can instinctively do everything I need to with regard to people and families in Ancestry but find it a fight every time in RM? I know Ancestry has holes too, like searching addresses. Last week I spent (country) half an hour trying to delete one set of two parents shown to an individual (the second arrived courtesy of a remarriage and subsequent census that showed a different father). It took seconds in Ancestry without any prior knowledge. My fault in the first place, I know but why is it so clunky to correct?

You’ve had good advice from people much more experienced than I, so I’ll leave you to that. My comments are for the RM computer engineers who might have occasion to read this. First, THANK YOU!!! RM9 is fantastic! Good job. I have owned RM 6-9 and I’ll buy 10 the day it comes out. It’s worth 5 times the price, but I would appreciate it if you wouldn’t raise it more than 100%. :blush:. Second, I have had problems with this photo issue (principal person photo…I forget the precisely correct name) as well. The program design would benefit from a few tweaks here, but mostly the documentation (the user manual) for the program needs a lot of work.

1 Like

Thanks Wes. Appreciate it. Bill

Over RM9 (and my very limited experience with 7) are well done.
I believe RM9 is best overall which is which is it basically the only program I use.
I use FTM for over 17 years prior. I tested Family Historian (7) which does some strengths over RM – some of the FH7 layouts are better over RM9 and FH7 is more similar in ways to RM7. The main win FH7 has in the query language which RM will never catch up. But RM allows SQL direct access whereas FH needs plugins if you do not use the built in query language.

Although FTM help build by tree I wish I switched to RM years ago – I was stuck on believing I needed the SYNC capability which did actually work without issues prior to FTM 2017.

I do not see me changing my main program for next 5 years. (Probably be RM 11 by then)

Kevin

I was not having a problem until a couple of days ago. Now when I add a jpg of the person and follow all the directions you list. the image will not appear. I tried it both my selecting the image from the existing and using the drag and drop. I tried adding information and saving but nothing works. any suggestions??

Mine stopped working about a week ago. I’ve added over a hundred photos with no problems until 2/14/2024 then I can still add media but RM9 no longer shows the image on the persons profile.
Suggestions?