What information is in a GEDCOM?

I have decided to pull the plug on Ancestry. I now use Geneanet for my European research. They have a little app that you can use to upload a gedcom. This little app I suspect uses the tags that I enter on RM8 to upload all other data that is not included in a normal Gedcom. My question is what information is included in a Normal GEDCOM. My experience with Ancestry is “No source listed” Yet using the Geneanet app all my sources are listed. Is something going on that I am totally unaware of.

1 Like


1 Like

I believe that not all genealogy software uses ALL the tags. If you make a Gedcom of your RM8 tree you can open it in any text editor and see what is available to be imported into any other product assuming that it accepts all the RM8 Gedcom tags

It is amazing that Geneanet has their own app that uploads a gedcom and searches using my tags to upload pictures and other relevant documents. Why can’t Ancestry do that?

Who knows, but you might want to ask Ancestry that question!

Thank you. That is a very useful guide.

1 Like

Now I understand a little better what is in a gedcom. Unfortunately, I don’t see it when I upload to Ancestry. I suspect it’s having to do with marketing. Then again why have tags if the GEDCOM is not going to use them. Another problem I have is locations and GPS. But that is a story for another day.

One problem. Ancestry bought Geneanet last August.

What are you trying to achieve? I know both Ancestry and Geneanet quite well, and don’t understand why you’d want to deal with GEDCOM on the Ancestry side when we have TreeShare in RootsMagic. And although the sources on Geneanet are quite primitive, they display well.

What I want is the ability to upload changes to Ancestry with tree share in a simple procedure. I am unable to achieve that. It seems Ancestry and RM8 are not on the same page. Especially after I upgraded from 7 to 8. I deleted my Ancestry tree and uploaded a new gedcom. All hell broke loose. The compare doesn’t work even on my grandfather. I couldn’t find my sources at any time. On Geneanet.com my sources are displayed without my having to enter them. The Geneanet app does it seamlessly. In short tree share doesn’t work.

Ancestry was purchased by the Blackstone group. Blackstone in turn purchased Geneanet, a French company in 2021. Somebody on this site sent me a link that showed what a gedcom contains. Funny I never see some of date that displayed in my tree on Ancestry. Never ever. Even when using RM7 with Ancestry, and that includes using tree share.

Tree share has never worked for me since upgrading RM to 8. In RM7 I could never upload my sources and citations. I even asked them about it. On Geneanet.com using their app, everything gets uploaded. Funny.

I have my tree in Gramps, and only use RootsMagic to sync information with Ancestry and FamilySearch, and I see sources on Ancestry. These are all ‘classic’ sources and citations, in the sense that I never used the templates of RootsMagic itself.

I just ran a test with TreeShare in RM 8, uploading another copy of the tree that I have in Gramps, with sources and citations, and that worked well, meaning that I see the same sources as I have in my earlier copy, which was a direct upload from a GEDCOM exported by Gramps. This suggests that sources can make it when uploaded through TreeShare.

Are your sources based on templates maybe?

I share some of the concerns mentioned in this thread. I periodically cancel my old trees on Ancestry and replace it with an updated one. My great frustration is to be able to upload the new tree with, at the very least, sources. IMHO a tree without sources is meaningless and does little to help others. Other genealogists can check the validity of my work and point out areas with which they may disagree. I would love to be able to upload photos and other attachments in one simple upload. I certainly do not have the time to upload thousands of sources and media one at a time. My rationale is to upload the information to assist others, not for my own benefit - I already have the information. Any practical options would be most welcome.

I did a gedcom upload to ancestry using rm8. Several items were crazy. It showed in compare that my grandfather was not linked. When I tried to upload it wouldn’t. I never had a problem with 7 only 8. I looked at my gedcom with word. Very interesting. I don’t use lds button. I am using windows 10. I tried 11 and it went crazy. A question. What format is being used for the gps. I looked for a help book. Not much there. Can I change the gps format? I still miss the ability of opening the same database in two windows. Who ever called 8 an improvement needs therapy.

One item that I didn’t mention. In media on rm8. The url to the media items shows a big X. That to me tells me that you never get a true copy only the url and it is not valid when you cancel the ancestry account.

I have never uploaded an RM 8 GEDCOM to Ancestry, but my personal experience is that TreeShare works both ways. With that, I mean that I can use it to download the tree that I uploaded to Ancestry from Gramps long ago, and that downloading with TreeShare means that I get the tree and all media that I attached on-line since then on my desktop, in a folder named after my tree, so when that tree is ancestry.rmtree, its media will be in folder ancestry_media.

Also, when I import my Gramps tree into RM 8, I can send it to Ancestry using TreeShare, where it arrives with sources attached. I can see that they’re all visible in the profiles on-line.

There may be a big difference between your tree and mine, which is that my sources all follow the GEDCOM standard as it was set by PAF and as it is followed by Gramps, meaning that all sources use the standard GEDCOM tags, like AUTH and TITL for a source (SOUR) and PAGE and DATE for a citation. These fields may not be used when you one of the built-in citation templates, which are non standard, and only understood by the RootsMagic software.

When it comes to sources Ancestry follows standard GEDCOM quite close.

That has not been my experience. When I cancelled my account I lost the media connection. I don’t change any rm settings. When I went looking for my sources it told me none found. I don’t tweak any settings in ancestry or rm. I don’t use tree share to upload a new tree. It won’t let me. Even using tree share to correct or add events I could see that sources or media was missing on ancestry. So after much frustration I pulled the plug. What is interesting is the problems I have on ancestry I don’t have on Geneanet. They have an app that adds to the upload. I looked at gramps. Interesting open source. The only problem I am having with Geneanet is their gps, locations. I am using a map source and then entering the gps into rm. they then read my locations and then convert to their system. I know crazy.

Um yeah, if you cancel your Ancestry account, they most certain are not going to let you have their media. They are in business to make money. If you want their toys, you pay for them.

To tell you the truth, I don’t. I have a free account, where I can upload my tree, by GEDCOM or TreeShare, and where I can share it with relatives, and where I can even add pictures from other trees, and download those with TreeShare again. I do get the usual invitations to subscribe, but even when I don’t, I can keep my tree on site, use TreeShare, and their app.

You are of course right that when you remove your account, there is no way for TreeShare to access it anymore, so it seems quite illogical to compain about things then.