Unexpected Error transferring RM7 to RM8

I downloaded RM8 last week. I followed all the directions to Create a New RM8 file and then clicked on RM 1-7 and then next clicked on RM 1-7 again. This brings up my Roots 7 tree as the default tree and has a .rmtree extension. However, when I try to open the tree, it comes up with an “Unexpected Error” box which says “invalid characters in path”.

I have tried this a few times but it always says the same thing. The error message says it has sent a notification to RM8 and I have also contacted support but have had no reply yet. Has this happened to anyone else? Any ideas?


Exactly where is your RM7 database located and exactly where are you putting your new RM8 database. By “exactly where”, I mean all the folders and subfolders where the databases are located and what are the database names.

It sounds like there may be a character in a file name or a folder name that RM8 doesn’t like. It could be a blank and or & or something like that.

Thanks for replying. My latest attempt was Lesley Family Tree for my RM7 tree which is located in This PC\Documents I have renamed it several times but every name has the same effect. The RM8 tree is in the same place but just won’t open in the software?

I don’t have any other ideas. You may have to wait until support gets back to you.

Wait a minute. Is there really a blank in “This PC”? I wonder if that could be the problem.

Yes but my computer does that on it’s own? I changed the name of my tree to one word - Ancestors -but still no luck.

“This PC” is not a location . it is simply a name given by Windows.
You will need to specify the full name as C:\ xxxx\yyyyy\ etc etc If you only have the one drive, it will likely be the C drive and something like this:
C:\users\xxxx\Documents\ where xxx is your user name. Go into File Explorer and navigate to your database file and then at the top right click and click on copy address. This will be the easiest way, then paste it into your field. Alternatively, if you keep yoor operating system on the C: drive and your data on a D: drive, simply put your RM8 database into a D:\RM8 folder on your D: drive and then it is easy to map.

Thank you.

Tried that and RM8 said a file of that name already exists. So it is copying the RM7 file correctly into RM8 and naming it correctly but when I open the file it is just an empty RM8 file with 0 persons?

What is the fully qualified name of the file location and file that you are trying to open (“C:\xxxx”) etc
What file size does File Explorer show for that file?

You are clicking on File in RM8 and then clicking on Import and selecting RM7 format ? I ask as you mentioned “Copying”… You aren’t copying but importing…

File Explorer shows C:\Users\Michael & Lesley\Documents\Ancestors.rmgc
for my RM7 file which equals 10,159 KB
Yes I know I was importing…not copying.
File Explorer shows the same for my RM8 file but with Ancestors.rmtree and only shows 1,960 KB

Might your username with and “&” in it, in the path be the problem ie the path rather than the file name?

I seem to remember this coming up in the preview but can’t recall seeing the outcome, nor quickly find it in the archived Facebook posts.

& in file names cause problems in other programs, also.

Okay will see if I can change the Username we have always had it that way so every time we upgrade our computer it gets carried forward and never a problem.

Thanks - not sure how long “support” takes getting back to people? It has been over a week.