Source Templates

I am trying to make some changes to a source template, that I want to flow through to existing sources/citations attached to it ie adding a couple of new fields, and changing the sentence structure. I am finding a few things that are confounding me:

  1. I thought items in chevrons only printed if something was entered in the field, but if I have missing data, the field name is appearing in the footnote.

  2. Where I had defaults specified in my RM7 database, these seem to still work, but if I try to set up new default text, it doesn’t seem to populate. Even though I have specified default text for a field, the only way to get it to appear in the footnote is to enter it manually.

  3. If I write text/fields for the footnote, I am unable to copy and paste the same item to the short footnote and bibliography fields. I thought the copy/paste issues had been ironed out with the last update.

  4. If I have customised a citation, I have to use ‘Reset to default’ every single time I make a change to the source template to get the change to appear. I had assumed ‘Reset to default’ meant exactly that - ie ‘forget this footnote has ever been customised’ and that I would only need to use it once, and then the citation would behave like all the others.

Anybody else experienced these, or found workarounds?

Edited: Should have said I am using Mac with M1, Big Sur.

On your #1, I haven’t seen it fail in RM8. The chevrons work just fine for my templates.

My experience with fieldnames appearing in a footnote is that it indicates a mismatch between the variable name in the sentence definition and the field name in the template definition. This seems to be true whether the variable is inside chevrons or not. And if the variable name doesn’t match the field name then the chevrons won’t work.

If you verify that your variable names and field names are matching, then perhaps you could post a screen capture of your template.

On your #2, I haven’t seen it fail in RM8.

I only have a couple of templates that provide default text. One of them is my birth record template. The first variable (AKA field) in the template is called BirthRecordType. This variable is intended to function in such a way that only one birth template is needed, no matter what kind of birth record it is. So it defaults to type Record which is very generic. I normally fill in either Certificate or Index, but if I leave the field null it fills in Record just fine.

The relevant portion of the sentence definition is as follows.

Birth <[BirthRecordType]|Record>:

On your #3, I normally don’t customize sentences for any of footnote, short footnote, or bibliography fields. I just let the template control all three sentences. So I tried customization just now by clicking on the word “Customize” in blue. It “just worked”. I used Ctrl-C for the Copy of the text and Ctrl-V for the Paste of the text. I am on RM 8.1.0.0 on Windows 10.

Re #2 Attaching image re default text. The ones for Website name and URL (Ancestry) work fine - these were pre-existing. The one for ‘Country’ (which is new) does not work. If you can see something wrong with it, I will be very grateful! :slightly_smiling_face:
Screen Shot 2021-11-09 at 7.42.20 pm|690x371

I can’t even copy and paste the one from |Ancestry as the Cmd-C doesn’t work.

Re #4: I customised the first citation by accident, so Reset to default. Then when I was changing my template none of the changes were flowing through to the citation. When I looked at the other citations, they had worked, only the first one didn’t unless I ticked Reset to Default every single time I made a change.

Re #1 Attached screenshot of where the chevrons have not worked.


Again, if you can see why it is not working… :slight_smile:

I’m rusty but I think your <, [Parish]> construct always tests true because of the leading text. Change it to <[Parish]|, [Parish]>

On second thought, your problem is that you are adding newly defined fields to a template already in use. Preexisting sources and citations do not have null or empty values in their XML data, e.g. , <Parish/>, iirc. RM outputs the name of the missing field which I think is an unnecessary holdover from the original development of RM4. To correct the output, one needs to ‘touch’ the source or citation depending on what level the field is in. That means editing each one and resaving it.

On your #4, I guess my expectations are not the same. I would assume that a customized citation would thereafter ignore the source template unless the “Reset to default” button were clicked, no matter whether template were changed or not.

For example, here is a scenario. Suppose you have 100 different citations using the same template. Suppose you customize 20 of those citations and let the template have complete control over the other 80 citations. Then suppose you make a minor change to the template. Do you really want to lose all your customizations on those 20 citations? I would think not.

Tom’s message triggered some memories. There were times in RM4-RM7 when a change to a template required me to “touch” a source to get the source to recognize the change to the template. I’m not sure I remember the exact circumstances when such a “touch” is needed and when it is not needed. But in RM4-RM7 I thought I remembered that simply adding a new field to the template had no adverse effect on existing sources that used the template and which defined no value for the new field. Indeed, I have regularly added new fields to my RM7 templates with no adverse effect on existing sources that use the templates. So I did a test.

In RM7, I added the field Extra to one of my templates, I added the variable [Extra] to the sentence, and looked at sources that used the templates. The Extra field extra was null or empty, and the footnote sentence had not changed. Therefore, simply adding a new field to a template from RM4-RM7 does not require any kind of “touch” for previously existing sources using the template with the new field.

In RM8, I added the field Extra to one of my templates, I added the variable [Extra] to the sentence, and looked at sources that used the templates. The Extra field extra was null or empty, and the footnote sentence had changed as miningthepast describes. Namely, the footnote sentence now contains the string [Extra], and adding chevrons around the string does not help. This strikes me as an error in RM8 that needs to be fixed. Otherwise, the user’s ability to define templates and to change them later will be severely limited.

I beg to differ, Jerry. I think you only went as far as the preview in the Citation Manager. Have a look at a report. Here’s my example of an extra field added to both the master source and citation in RM7 as it came out in the Indiv Summary (same for Narrative):


Looks like RM Inc only went so far as to fix it in the Manager and Edit Person preview but not the reports generator.

‘Touching’ the citation or master source used to mean actually making an edit but now it appears in RM7 that merely opening the Citation editor and OK’ing it is the magic touch to make the new empty fieldnames disappear from reports.

I’ve yet to check on RM8.

This is a laugh and even more frustrating than Jerry’s experience. Maybe it’s another boundary condition error (there’s a track record of these in RM Inc development history). One citation of the only source on the 1st person in the database. The source was created from a custom source template (also the only one in the database). The source template subsequently modified to add an extra source field and an extra citation field. Checked the narrative report and sure enough, the field names show up in the sentence as they do in RM7. So I click on Sources View to inspect the citation and see what is required to fix the unwanted appearance of field names added to a template after citations have been created: would it be the same as opening it in RM8’s equivalent to RM7’s Citation Editor and saving it?

So click on the Sources View and get the Sources List and Edit Source panes. Click on the arrow to the right of the “1” under Citations:
Get an “Argument out of range” error > Send Error Report > RM8 is hung

But get this! The RM window is in my outboard monitor. I dragged it down to my laptop monitor to see if there was something hidden behind. The window refreshes to the view Iast clicked on while the window was hung and it is back in business.

The above is seemingly perfectly repeatable.

Apparently this hanging of the program in Sources is a peculiar problem dependent on the size of the main window as I’ve discovered after reading this report from Rick Matheson: Facebook Groups

After reading it, I revisited my test and find that maximising the window clears the freeze-up while reducing it triggers the fault. Reducing it below about 2/3 screen height (1920x1080 monitor, 100% scale) is the onset; width does not seem to matter.

The same thing happens on my smaller laptop monitor (the two are stacked vertically), also 1920x1080 but 125% scale because it is smaller. Dragging the frozen window from the laptop monitor up to the 2nd monitor can also trigger the same error and results in a partially filled window:


Repeatedly dragging it up and down between monitors and sending error reports eventually restores the window to normal functionality.

I wish to report that I can confirm Tom’s observations. Even though RM7 appears to ignore a newly added source template field in an old citation based on that template when you are in the preview in the Citation Manager, the field does show up in footnotes in RM7’s reports as has been described previously in this thread.

This behavior of RM7 and RM8 will usually require every citation based on a template with a new field to be “touched” in the Citation Manager. It’s not a very happy situation. This issue certainly will not be addressed in RM7, but I hope that it may be addressed in RM8.

By the way, if you add a little gravy, crow can taste really good. :grinning:

I may be way off on this but the behavior you are seeing is also representative of those fields being Detail Fields. I do not believe the conditional brackets (chevrons) are honored for Detail Fields in formatted preview, though they may be in printed output. I would open your Source Template and see if there are Xs in the column labeld “D” of those fields. If there are, it is working as designed.