Possible Bug in Editing Master Sources

I think I just discovered a bug in RM9’s processing of source templates. Namely, if I have an existing source and citation where the field in question is a Master Source field, I cannot change the contents of the field, neither in the Edit Person screen nor from the main Sources tab. This is with my own custom source templates. It doesn’t seem to matter if the field is a text field or a name field or a date field. It can’t be changed.

Well, I can change the contents of the field, but the footnote sentence is not updated to reflect the change I made to the field. You can see that the footnote has not changed in the Edit Person screen, and you an also see that the footnote has not changed by running a report and looking at the citation in the footnotes. There is always a question in my mind if the footnote I see in the Edit Person screen is really the footnote I’m going to see in a report. So in this case, I definitely looked both places.

I am on the now current RM9, namely I don’t have a good way to run any earlier build of RM9. The closest analog I can test in the RM8 and RM9 world is RM8, where the error doesn’t occur. Namely, in RM8 if I change a field it immediately changes the footnote, both on the Edit Person screen and in reports.

I am early in the process of investigating this problem. All my source templates are completely split source templates where all the fields are Master Source Fields. I plan to do some testing where the fields are are Source Details fields, but I wanted to go ahead to report the problem as a sanity check to see if anyone else can replicate it before I spend hours in investigation.

Here is one clue. If I click on the Customize text on the Footnote bar on the bottom of the Edit Citation area of the Edit Citation panel, one of the options is Reset To Defaults. If I click on that option, then my footnote is updated properly to reflect the changes I just made to the fields. It’s almost like RM9 thinks I have customized my footnote rather than letting it take its value from the fields I have entered. And because it thinks I have customized my footnote, it doesn’t want to undo my customization.

I promise I have never customized any of my footnotes using this customization feature, ever, except in a test database a long time ago to see how the feature works. I think it’s a terrible feature that should never be used and which probably should not even be in the RM product at all. The feature makes it too easy for a user to shoot themselves in the foot. But I’ve never raised this issue because I thought it was better just not to use the feature myself and not worry about what other RM users might think about the feature. But now I’m wondering if the feature is preventing me from updating my sources and citations, even though I don’t use the feature. And I do understand that I’m not totally “prevented” because I have a workaround of doing a Customize => Reset to Defaults. But such a strange workaround should not be necessary.

I look forward to finding out if I’m the only one who can see this problem.

1 Like

I only started using any template customization with RM9 (since October) – trying to fully visualize what you are describing.
Since you use SQL – have you looked the at the blob fields and notice anything?
it might have to do with the logic of referring to master source vs custom field.
If Null use Master – if not Null use blob field or similar — at least that would be the first place I would look.

I wrote a SQL script to create 2500 citations so they had 80% of the info needed including the blob fields been attaching those manually past 8 weeks.


I don’t see that issue.
To be sure we’re talking about the same thing, attached are 2 screen caps from the Edit Person window. A before and after change. What’s changed is the Master Source field Informant where I added several ='s.
As you can see, the footnotes and bibliography sentences also changed accordingly.

Here’s a video of length 5:12 which shows the problem. I had hoped not to have to make a video at all, and I had hoped to make the video shorter, but I was not able to do so.

At one point in the video, I had to click the Customize button twice to get it to take. While making the video, I couldn’t figure out what I did wrong. Upon reviewing the video, I realize that I X’d out of the Customize dialog the first time which why it didn’t take. The second time I OK’d out of the Customize dialog, so it took. Sorry for the slight tickle in my throat and cough today during the video.

Possible Bug in Editing Sources

And by the way, the video shows a second and probably unrelated bug. Namely, after I got the change to take, the change showed in the version of the Footnote at the bottom of the screen but the change didn’t show in the version of the Footnote at the left side of the screen until I exited and re-entered the Edit Person screen. That’s a bug in the Slide-in Workflow.

I see your issue. I can’t repo it, even using slide in workflow.
Have you tried this with a a RM standard source? I’m wondering whether a problem with the sentence template is preventing update.

I think I now understand the issue. It really isn’t related to the slide in workflow. I just used the slide in workflow in my video to make things easier to see.

To better understand the issue, I created a copy of my source template and moved several fields from the Master Source area to the Source Details area. In particular, I moved the person’s name from the Master Source area to the Source Details area. I then made a new source and citation using the new template. The footnote sentence was identical to the existing source template. Having done so, all was well when I changed the person’s name from inside the Edit Person screen.

It therefore appears that the problem is specific to the data elements that are in the Master Source area. That’s probably why you couldn’t replicate my problem. The field you were using for testing and the source template you were using for testing were surely in the Source Details area. It appears that fields in the Master Source area cannot be changed from inside the Edit Person screen after they are first entered in any way other than by changing them and then clicking Customize => Reset To Defaults. I suspect that the changes are making them look customized when they are not. They are just being changed.

As I understand it, once you customize a footnote sentence, it is customized forever and changes to the template fields have no effect at all until and unless you Customize => Reset To Defaults. And remember that I never, never, never Customize. It’s just that apparently RM9 thinks I did because I changed a Master Source field. At least that’s my guess.

It occurs to me that this might be a behavior that is broken as designed. Which is to say, RM8 and RM9 are antagonistic to source splitters, and I mean really, really antagonistic to source splitters. It’s really hard to be a source splitter in RM8 or RM9. They want you to distribute the bulk of your source information into the Source Details area. So I’m guessing that the expectation might that you are not supposed to be able update Master Source fields from the Edit Person screen after they have been first entered. The expectation might be that you must update Master Source fields from the main Source tab.Or this may be a bug. I just don’t know for sure. It wasn’t a problem in in RM8. I don’t know if it was a problem in RM9 beginning with RM or if became a problem in RM9 after that.

It does work fine to update Master Source fields from the main Sources tab. At one point, I didn’t think it worked fine to update Mater Source field from the main Sources tag, either. But I may have conflated problems with parentheses in name fields turning into quotes with my new problem of not being able to change any fields at all. Indeed, I first encountered my new problem of not being able to change any fields at all while I was working on the problem of parentheses turning into quotes in name type fields.

If you’ll notice in the screen caps, the field I changed was a Maser Source field, not a details/citation field.

Then the mystery is back. It’s very puzzling.

I can’t reproduce your issue.

I couldn’t duplicate the issue either. The footnote updates dynamically, as expected, for me. Here’s the footnote sentence I used:

I wonder if it’s something in the specific footnote sentence that you’ve created that is causing it to not update? If you could paste in your source template field definitions and footnote sentence details, I’ll test again with your exact sentence.

Also, as you note, the slide-in-workflow footnote section of the left panel is static and does not update until you exit and renter the citation. That is recreatable though, as I recall, when that particular panel of information came about during the rm8 beta the stated user requirement was to have a consolidated view of several source/citation fields that didn’t require expanding the chevrons, so I have always assumed it’s working as designed with static text.

I’m going to submit my database to the RM HelpDesk with a trouble ticket. Maybe they can figure it out from that. In the meantime, here is my exact sentence that I used in my video. The source template is for information I receive directly from one person and that person is the source. The communications medium could be personal interview or email or phone call or letter or text message or Facebook message or almost anything. But the communication medium is not the source. The source is the person.

[PersonsName:reverse]: [CommunicationsMedium]<, recorded by [RecordedBy]>, [DateOfCommunication]< ([Sequence])>.
  • [PersonsName] is a Name field.
  • [CommunicationsMedium] is a Text field
  • [RecordedBy] is a Name field
  • [DateOfCommunication] is a Date field
  • [Sequence] is a Text field. It is used, only if I receive two or more different communications from the same person on the same day. It is simply a number like 1 or 2 or 3 etc. for the first or second or third communication on that day.

All the fields are Master Text fields and there are no Source Details fields. If I were going to quit being a source splitter, I would leave [PersonsName] as a Master Text field and make all the other fields into Source Details fields.

The citation that I’m working with reads as follows. It’s a “personal interview” (face to face) rather than an email or a phone all or a text message, etc. All variables were filled in the obvious way and the sequence was left null because there was only one communication from that person on that day.

Wright, Lucille: personal interview, recorded by Jerry Bryan, 12 October 2003.

I started out by changing [PersonsName] from Lucille Wright to Lucille (Lucy) Wright to test out the report of parentheses being changed to quotes, viz., Lucille (Lucy) Wright was displayed as Lucille “Lucy” Wright. Except that I couldn’t get changes take at all. So my problem analysis branched from one problem to another problem. To avoid conflating two different issues, my test now is to change Lucille Wright to Lucille Smith and that’s what I showed in my video as the change that won’t take.

Here’s a screen shot of the template. Posting the screen shot in the first place would have been easier than typing all that stuff above. But you can copy and paste from all that stuff above.

Maybe you have the same source open in two places (source tab and edit person window) and RM is not detecting the conflict

There’s any number of things I might be doing wrong, but not that one. :grinning: I see the problem if I start RM from scratch and then open the Edit Person screen as the first thing I do. I see the problem without ever touching the main Sources tab at all.

You can presumably create a new Source with all the attributes and text you want, then merge the old source into the new one?

That’s a technique that can be carried out for only a handful of Master Sources, should it be at all beneficial. The OP is an extreme “splitter” and has potentially as many Sources as there are unique citation sentences, i.e., thousands…

I already have a much simpler and easier workaround than that. Namely, in the Edit Citation panel do a Customize => Reset To Defaults. So the issue remains, why is a workaround necessary? Why doesn’t the change in the data I enter into the template just take effect immediately in the footnote generated by the template? And why can other users not replicate my results?

I did submit my database to RM for analysis. It will be interesting to see if they find anything. I was actually able to submit a two person database to them, using the magic of RM9’s new Delete Everybody in a Group feature.

Thanks for posting the source template. Unfortunately, I still cannot recreate the issue. The footnote updates dynamically when I add (Lucy) and also when I change the last name to Smith. I even tried naming the template with a leading " as you do, in the off chance that the parenthesis to quote conversion was somehow stumbling over the leading quote mark in the source template name. No dice… it all just works for me.

It will be interesting to see what the support team makes of it. (and another nice use of the new ‘Delete everybody in a group’ feature.)

One error I noticed in my post from last night is that the footnote section of the left slide-in-workflow pane updates as soon as you click the green check mark to save changes to the Master Source. You do not need to exit and renter the citation as I previously stated.

You may recall I am the one that has to change 708 footnotes to correct one word because of the severely limited “Search and Replace” feature in RM9. I am in the process and not sure if this is the same issue you are having, but when I go to Source, change the word in both footnote and shortnote, sometimes the citation is updated automatically but often I have to go into “Customize” in order to reflect the change I made in the footnotes. It’s not consistent.

Sounds like the same problem.

I think I have identified the bug, having replicated your source template and created a single citation for a new person in an existing database. It appears that the Customize Sentence feature is working backwards. What is happening is that the Reset to Defaults function is writing the current expanded sentence from each sentence template into the corresponding override field in the CitationTable instead of emptying its content. So the Reset is actually putting a “custom” sentence in. Consequently you cannot see any changes resulting from changes in the Source’s variables until you next “Reset to defaults”. @rzamor1

Edit: if you manually “customise” each sentence by deleting all content, you have “Reset to defaults”. So the logic is reversed and should be an easy fix for a developer.

1 Like