RootsMagic 9 will not load properly

I did an in place repair of Windows 10. Now RootsMagic 9 will not load correctly. The icon displays in the task tray, but will not open in the window. RootsMagic 7 works fine. Is there a repair option for RM 9 or do I just do a reinstall?

The only thing resembling a repair option is trying Ctrl-Shift-U after RootsMagic loads up. Reset Registration Key - RootsMagic Wiki

I would recommend uninstall/reinstall. You can download RM9 here - Download RootsMagic 9

RM9 never loads on the screen. The icon is in the taskbar and when I hover the mouse over it, I see a thumbnail of the homepage, but it will not show on the screen full size and I cannot remove the taskbar icon unless I do a restart. Tried a re-install with the same results.

I can remove it in Task Manager. In Task Manager, when I expand the Rootsmagic entry, I saw 3 entries for Microsoft Edge WebView2. When I tried to start RM9 again and went to Task Manager, the MS Edge entry was not there.

I also have RM7 and it loads and works fine.

Since the installation screens were visible, not sure what’s going on. Are you starting up RootsMagic from a desktop shortcut, from the Start Menu or double-clicking the RootsMagic.exe program filename in File Explorer? Using a different user login than when installed? Is there maybe some other program running that could possibly interfere? Non-Defender antivirus? Do you have multiple monitors? What was the reason for In-place repair?

We had another user report that not to long ago. They needed to adjust their firewall to allow RM access to the internet.

How dumb can I be. I use two monitors and did not have the other monitor on. Funny that 7 would load on the main monitor and 9 always loaded on the #2 monitor.
Thanks for trying to help me with a problem that I did not really have.

1 Like