RM8 for Mac OS - Access Violation Error

Is anyone using the Mac OS RM 8 version 8.0.4 and getting “Access Violation” errors? I am getting errors occurring after about 30 mins of use predominately whilst updating sources and citations.


I’ve been getting access violations with the Mac version RM 8.0.4 every 30-60 minutes, from the get-go. I’ve decided to put RM8 on hold until this (and some other troubling bugs and critical enhancements) get fixed.

1 Like

I am glad to know it is not just me. During the beta testing phase I was getting them with various releases. Some releases seemed to have solved the issue. The initial production version seemed ok but perhaps I hadn’t given it a serious work out. Hopefully they will sort it out quickly.

1 Like

Access violation errors are a new standard feature on the mac version designed to not be reportable and to encourage us to shut down the program.

Perhaps we should heed this.

1 Like

I was getting access violation errors frequently, as often as every few minutes. Running Big Sur OS on an iMac. I finally went through all of the steps outlined by RootsMagic support for “cleaning up” the computer.

It took me about 2 days to go through it all, but I’ve used the program for about 2-3 hours today, and gotten only 1 access violation error, while linking people to Ancestry with TreeShare.

I had already run database tools, restarted computer, etc.
For the anti-virus program, I went with Kaspersky Internet Security 2021 for Mac. It took about an hour or so to run the ‘Quick Scan’, which didn’t find anything, and a good 12 hours to run the full scan. It found 5 items, none of which seemed major, but I went ahead and deleted those.
Restarted computer, then downloaded CCleaner for Mac (free version), and ran the “cleaner”, and deleted a lot of duplicate files I had accumulated.
Restarted computer again.
I did not run Malwarebytes, even though it is available for Mac, because I feel like the Kaspersky program already scanned for viruses, malware, etc. No need to duplicate that.

We’ll see how long this helps! But so far, I notice a definite improvement.

Thanks Helen, I have done the majority of the things listed on the RootsMagic support site. I have antivirus software installed and scans find no errors. Problem seems to have be exacerbated by version 8.0.4. I am not convinced there proposed fixes are the solution. Unstable code is more likely the problem. Hopefully by the time they get to a release ver 8.1 things will be more stable. The one thing I don’t do when I get the error is to backup the database before exiting after the error. I would rather lose a bit of work than introduce more corruption into a back up database.


Fully agree with you there. RootsMagic have been posting this so-called “solution” for some years trying to blame something in your security, anti-virus or OS settings for such Access Violations and recommending that you install and run all sorts of 3rd party software to resolve them. They fail to explain why no other piece of software that you run has such Access Violations. During beta testing of RM8 one particular build caused me no end of Access Violations however I persevered and they disappeared in the next release. I had done nothing so it was obviously RM that was causing the problem.


There is always a major development challenge for a predominantly Windows based developer trying to implement a Mac OS solution for the Windows product especially when it needs to be a native 64 bit application.

1 Like

There have been times when Access Violations have been a problem in RM7 under Windows. That’s when the “fix document” from Renee was originally published. Never did hear from anybody that it fixed the problem.

1 Like

Today I updated RM8 to version on my Intel based iMac and my M1 based MacBook Air. So far after a number of hours on both machines no Access Violation errors. Too early to say if the problem(s) have ben resolved but at least it is a step in the right direction. Before the update I was randomly getting errors frequently with no clear logic to the cause (task being undertaken) of the error.

Access violation errors continue in a variety of situations on the mac and remain unreportable if you click the report button at least on the mac.

the frequency seems less but no other program does this on my mac at all. This is windows type behavior.

I submitted a trouble ticket through the support website. I have had a response and they are having difficulty getting it to be consistently reproducible making it difficult to pinpoint the cause. I am keeping the ticket open so that I can provide more details the next time it occurs.

I suspect there are several triggers for whatever “access violation” errors are. After the latest update the frequency has dropped but they still happen and seem related to hopping around the menus and popup windows. You can flip between two open databases but run into trouble between some screens in the same file.

A Google search indicated this is a problem on Windows when a program tries to access memory not allowed to it and one article had a series of fixes specific to Windows to try.

Your experience seems similar to mine. Most of the time I get the errors just hopping around different pages/menus usually after I have edited something. So far I haven’t had any with but not using it that much at present.

1 Like

I am new to Roots Magic, purchased 8 a couple of weeks ago and first post to the Forum. I am having a lot of error issues - access violation and a message saying ‘component named AddSourceForm already exists’ is repeatedly coming up today when trying to add a source. I can see from the thread that a things to do list on the Roots Magic support site is mentioned - where do I find this ? Should I also raise it as a technical issue? Sorry for the basic questions but I am very new to this.

Yes I am experiencing these issues with 8.1.2, was fine when using 8.1.1. I have just spent 45 mins editing Places, Splitting Merging etc no problem. I then went back to editing individuals specifically opening sources and the access violation message came up. Two days ago I was doing this same thing with 8.1.1 and no problem then yesterday I upgraded to the latest version 8.1.2 and the Access violation message kept popping up. My iMac is running Monterey.

That doesn’t sound promising. I have yet to upgrade to the latest drop of RM8 on my MacBook Air (M1) and my iMac (Intel) both running Monterey. I will do that today and let you know if I am seeing the same issues you are seeing. I am starting to feel my RM experience is reaching EoL. Fortunately I have fallback options which won’t impact my research.

Upgraded my Intel based iMac [Monterey] to 8.1.2 and spent an hour or two in the application editing and adding sources, media and people, so far no Access Violation Errors. Still early days but a similar experience to when I upgraded to version 8.1.1. Database is only small.

noted the update from this thread, installed it and tried to create a new RM8 file from a fresh FTM gedcom. 1st attempt access violation error and program must be quit. 2nd try on same gedcom and menu steps did work. Sigh…AC issue not any better.

Mbp 13 retina 2014 catalina all software current no silly antivirus to screw things up.

Gedcom is a small 369 people file with media links. The create new RM8 file window showing import progress always stops at 360 people but does import 369. When I create a new ancestry tree from this I know to uncheck media since RM8 always bombs if media are included—Sigh!

1 Like

after clicked for more info on 12/3/21 update and then doing the update RM8 crashed and had to be restarted to do the update.