RM 9 Profile images in directory but not displayed in Media Tab

Another “problem” from the download of my large Ancestry database.
My Media Tab when opened shows all the documents that were in my Ancestry Gallery but all the profile images and other photographs are not showing. The Media tab is only showing a fraction of the actual files in the folder. All the images that are shown, for some reason,are document images (Baptisms etc).
2023-07-17 15_28_44-Window

These are all .jpg formats but so are most of the missing images too. The total size of the media folder is 10Gb but what’s showing in the Media Tab is far less - I don’t know how to tell you the size.

If you open a record and then the profile the images are there and in the right media folder. So each record is linked correctly to the media it should have.

If I open the folder from Explorer all the media from Ancestry is there
When I run Fix Broken Media Links I get this message:
Fixing Complete
0 Broken media links fixed. 72 links not fixed

Is there anything I can do to bring all the media into view in the Media Tab?

Assuming you are on the Edit Person screen Media tab. Do you have “All media” showing?

Update: Looks like you have another post on this saying the Ancestry download didn’t complete. That is why your links are probably not there.

Below are some additional troubleshooting steps to help resolve broken links. However, none of these steps will fix things if your database is corrupted from the initial download not completing. One standard step that you should do is to run the db tools in order (File, Database tools). I doubt this will fix your issue but it’s the set of tools that the application provides to cleanup database inconsistencies, so it’s a good first step when you see unexpected results. (Others more versed in SQLite can provide more detail.)

As others have mentioned, there have been lots of complaints lately from folks trying to download large trees from ancestry. (It seems to be an issue on the ancestry end of the API.) If that’s the case, the best advice I’ve seen is to keep trying in the US/Europe off hours.

Regarding the response you posted, the message indicates that there are 72 files in some other directory than the one you scanned with the Fix Broken links tool. If you are unable to determine the directory, the next step is to run the “Multimedia List” report (Reports are under the Publish menu), save the output to your favorite file format, and search on “Not Found”. Each of the 72 links should have a “Not Found” label along with the file location and name where the RM database expected to find the file.

Other steps that might help your investigation would be to go to the Home menu where you will see a “File Properties” list. This list that includes the number of media images and media links in your db. Also, under the “Tools” menu there is an “Enhanced Properties List” (new with RM9). Run this tool to see some additional db metrics on your media. It will list if any of your media files are contained in the Media table but not properly linked to a source, citation, person, etc. (I wouldn’t expect this to impact your current issue, but sometimes media can get added to the db without the final “tagging” step occurring. This happens from time to time, at least for me. The Enhanced Properties List contains other useful db details.)

Good luck chasing down the issue.

1 Like

Yes. On my original posts I did confirm that my original download of our large database (26000 records), of which I’m an editor, not the owner, was freezing because of the files going into OneDrive and running out of space thee. After sorting this out and directing the files to my local Documents folder, the download completed. That’s what I’m wanting help with now.
I have also downloaded my own Ancestry database of a few hundred records and the Media Tab in RM9 all looks good.
I have also downloaded another cousin’s database, of which I’m an editor, and also a few hundred records. It downloaded fine and Media Tab in RM9 looks good.

On to this large database download - here are some views of the screen to answer your question.
Opening edit on my personal record you can see all the links to the media (12 images)

Here is a sample view of the actual Media file.

Here is a sample of the Media view in RM9
2023-07-17 15_28_44-Window

This large database belongs to a cousin here in Australia. I haven’'t been able to chat to him yet but I’m wondering if there are issues in his Ancestry records.

For the last image, can you provide a printscreen of the entire window, not just the media? I ask this because RM has several ways of viewing media associated with a people and it would help to see exactly what view you are in. (This is what Renee was referring to in her post.) For example, the printscreen of your personal record is actually showing images tagged to the “Person”. (RM tends to prefer the term “tagged” versus “linked” to refer to how media gets associated with database elements, though the program is not always consistent.) Images or documents tagged to the events that make up the person’s life record (Birth, Death, Marriage, etc) would not show up under the “Person” unless they were specifically tagged to do so. The same goes for images related to the sources and citations that support those life events. RM used to refer to the collection of all media associated with a person as the “Media Gallery”. The “Media gallery” shows media tagged to the “Person” as well as all of the media tagged to their life events. You can view all media or filter by event, source, etc.

To see the Media Gallery for a person you need to click on the image icon on the left side on the ‘Edit Person’ window and make sure the drop down list says “All Media”.

btw, congrats on getting clean treeshare downloads. Hopefully, the images are all there and just tagged to things other than the person.

1 Like

Thanks kevinm for the suggestions. No changes after trying those steps. Here’s the Enhanced Properties List

Strange that the database is working and showing the image records if a profile is opened and edited. I might have to live with this and try downloads again later. I will still try a download from the USA/Europe domain as well. I’m using Australia.

We have it now. Kevinm you have unloacked the images somehow.
I don’t have the same “All Media” display that you have, but, by clicking the list view and then running up and down the list of images I suddenly could see the photos etc. Then going back to the thumbnail view I can see all the images.
I did the same on my 2nd Windows 10 machine and it was the same. I had to go backwards and forwards list / thumbnail a few times and the images appeared.
See the new displays

Well I’m happy it’s working now, but it might be a strange bug the developers should look at.
I’m happy to help debug more if you guys wish or can we call this issue for me on WINDOWS closed?

On my Mac desktop I still have the frozen download issue with this large database. The Mac software will open from a backup, but when I try to download this large database it freezes on the 1st line at 95% (Downloading tree from Ancestry). It doesn’t even get to the 2nd and 3rd lines. Maybe I’ll just work from the back-up here
BTW - The Mac also wasn’t showing the images in the Media Tab and after going to the list view, and continually the side display bar down, it eventually started bringing up the lost images. Going back now to the Thumbnail view the lost images are appearing. (I’m running from a restore backup of the same large database on the Mac)

I have just tried closing the database and re-opening it, and the images are not showing again, until I go through the routine of view in the list view.

That’s because Kevin is showing the media attached to the person from the Edit Person screen, not from the media tab.

1 Like

Glad things are working! I can’t help but wonder if the issue with the large db was that RM was building the 16k thumbnails and that just took a while. (I don’t have any db with over 1k people and things are different at scale. There are others with >100k users so perhaps someone more knowledgeable will comment.) Anyway, good stuff! and using a backup to get the large db on your mac is a good way to go.

Couple of other thoughts re: backups:

  • Backups are your friend since there’s no “undo” capability. The program settings to “Ask for a backup on exit” and to “Append a date” are helpful.
  • Most users find it simpler to backup just the db not the media and have a manual method to periodically backup media. (Backups are zipped and relatively small but including media dramatically increases the size. Also, a backup with media lumps all media into a single folder. So if you organize your media in multiple folders that will get lost. )

Finally, RM has a lot of features and the videos on youtube are helpful as is the help wiki.. One last tip from Program Settings is to enable the RIN (Rootsmagic INdex) under the Numbers to Display (under the gear tab) . This will display a unique number after each person’s name. It’s quite helpful when you have several people with the same name and in sorting out parent-child linking issues.


That’s a novel and appropriate expansion of the acronym but, from the outset of computerised family trees, RIN has stood for Record Identification Number. In RM UI and documentation, the term “Record Number” is used.

Every table in the RM database has a primary key or rowid for each record, whether it be a place, an event, a citation, etc. It is the PersonTable whose primary key is PersonID that supplies the RIN in the user interface.


Thanks Tom. Not sure where I got that idea from. Clearly AI is not the only thing that hallucinates!

Kevin - thank you for your help. Yes backups are crucial. I was a mainframe programmer back in the days, from early 1970’s, long before the PC. We were taught to backup everything. And, we kept grandfather, father, son copies of all to roll back to in emergencies. Always to protect against human error. Our systems (eg Provincial Stores, or Motor Licensing ) often had 50-100 programs in the suite which needed to be run at different times through the year. We wrote the programs and process of running them and the computer operators ran the programs etc - so there were often errors coming in. These new programs like RM appear to be one program, but actually each facility is another program. And you the user are the computer operator and the data typist etc :slight_smile: Errors can happen.
Before I took an early retirement we had started to work on large databases like Oracle and I did a bit of SQL on PC more recently. I recall one of the big problems being the ability to share the data at the same time. Multi-threading, record locking and field locking was a headache. Big systems today like that used by FamilySearch have huge multiple databases around the world and need to sync at the same time. This is even more difficult to control. So when they have downtime think of the programmers there. :dotted_line_face: :grinning:
Yes, so my image problems here could be related to one of those program sequences that needed a jog and probably a re-look at the code by the programmer.

Thanks for the RIN tip. I might do that. I see FamilySearch displays the number on all their records. You have to use that number when downloading from them as a start person. Actually, it would be very good if Ancestry did the same instead of the whole database being downloaded. Downloading huge database in smaller chucks might have sorted my problem out quickly.

1 Like