RM 8 File is lock to "Read Only"

Hi there, I have 5-6 files on RM 8. Now my main family file has “Read Only” next to the file name in the upper left corner, and now I can’t save any info. My other family files are OK. I checked the file properties in the Windows document folder, and all of the RM 8 files have the “Read Only” box is unchecked, including the one that I can’t save to. Take care.

Are any of the files stored in a folder such as Dropbox or OneDrive which is synced to the cloud?

No, just on my hard drive.

I really don’t have any additional ideas. The only things that come to mind is that the file really is Read Only in the Windows file system or that your databases are being synced to the cloud and encountering some sort of syncing conflict. But those two possibilities have already been eliminated.

The next thing I might try would be to copy the file with a problem to a different named file, doing the copy with Windows File Explorer. See if you can open the copy from RM.

Nothing pops to mind but try Drag & Drop to a new file and see if it’s still “Read Only”. Maybe you can try a Restore too.

Ok, I think I will go to my last back up, and restore and see what happens. Thanks.

Did a Restore, everything is OK now. Thanks. Take care.

1 Like

There are two ways to have a “Read-Only” file.

  1. Open the database inside of a Shareable Drive
  2. Mark the file read-only under File Properties in Window.

When you restored the backup it created a new file and that’s why it was no longer read-only. Next time right click on the file and select Properties and under attributes uncheck Read-only. Click Apply, and then OK.

The box was unchecked. See my earlier reply.

This was created for MS Office users but also applies generally for programs such as RootsMagic: Why did my file open read-only? (microsoft.com)