Problem backing up in 7

Having given up on 8 temporarily until I get all my images in named folders to browse outside of Roots, I’m now having trouble backing up in 7.

I keep getting the above error. Is it happening to anyone else?

Something has a lock on the data file. Close RM and open it again and try the backup. Otherwise a reboot should take care of it.

It’s been like that for a few days, opened and closed the tree and the app, restarted the laptop. It still works otherwise but I am concerned at the lack of a backup. My last I can find is the 8th.

Have you tried the backup immediately upon opening the file, after a fresh restart? I am assuming your Documents folder is not somehow being sync’ed or backed up to cloud storage or some such.

I did try every possible way of doing it, but just tried again straight after my laptop did an update, and it backed up. Hopefully it won’t do it again!

Are you using Dropbox, Carbonite or some other cloud backup/sharing service that might have a lock on the file? If so, pause the syncing process and try again.


Go into File Explorer, rename the original backup file, then retry your backup
or specify a different backup file name.


Iirc there’s a long history of RM leaving the database file open and the Zip utility it uses for the backup is thus blocked from accessing it. I believe this is related to previous activity in the RM session such as WebHints, TreeShare, FamilySearch Central which is why the suggestion is made to backup at the start of the session.