Print error 217 in Rootsmagic

I have RM 9 on my PC, but when I try to print a Family Group Sheet and click on Generate Report an Error 217 occures and the computer block the program and I have to restart the computer…
I have the Edge, Google browser for internet.
Who can help me?

Don’t know if this previous link will help

Computer Blocks what program?
How are you printing? Have you tried saving as PDF?


No just the RM option, no pdf.

I second the motion to look at the previous set of messages about this problem at
RM 9 Runtime error 217 In that thread, it was reported that the problem was in a DLL that RM had updated. I don’t know if that problem has actually been fixed in subsequent downloads of RM9.

There was also a discussion of the problem being caused if you remove the Edge browser from your Windows system. I never removed Edge from my Windows system, and I still had the problem.

As you can see in the previous thread, I ran the DISM tool recommended by Microsoft on my computer. Doing so fixed the problem for me. However, the problem has returned on my computer. That makes me wonder if I’m getting the problem again from RM9 updates that have been released since I first fixed the problem.

Thanks for your reply.
I have try all the sugestions and nothing helps.
But there are more users with this problem.

Did support test your database file to try and recreate it?

My database is from a gedcom import, from a Lagacy9 program.