People List won't display properly

I have 7 groups set up in a RM8 file. When I first open the file, if I select People View, I can switch between seeing everyone or just the members of one of the groups. However, I keep losing this. I think it may be related to doing a search for people in this view. Even when I clear the search box, I can no longer see everyone or the groups - the window is completely empty. I have to quit RM and restart it to get the view back. Is there some way to reset this or is it a bug?

I cannot reproduce this problem. I tried it both using the Search box on the People List View and by using the Search tab. Everything worked fine with both ways I tried.

Could you describe your procedure in a little more detail?

Thank you for looking into it. I will be using RM later today so I’ll see if I can identify exactly when it happens and let you know. I was getting Access Violation messages every few minutes yesterday so I don’t know if they are connected.


Hi Jerry

I’ve done some experimenting and have identified exactly when the issue happens. I tried to send you screenshots but it would only accept one so I’ve sent the most relevant.

If I do a search in the People List to find someone, by entering their name in the search box to the right of People List, and then select Color Coding to colour the descendants of that person, you’ll see that the name I entered in the search box disappears.

After the color coding has finished, that box stays blank but the filtering is obviously still operational. This is what causes the issue. Even if you cancel the color coding, you still can’t get the complete list back. I have a number of groups set up and if I choose one of them, and the person isn’t in that group, I don’t see anyone.

I have found that if I type anything into the search box, even a single character, it restores it, and I can then delete what I typed to get the whole list back. Now I know how to reset it, it isn’t a problem, but I don’t think it should do that in the first place?



Ok, I think understand the issue. I can’t always reproduce it but there is definitely a bug in RM8’s search boxes. Namely, sometimes the string you enter into the search box disappears from the screen but the filter remains in operation. I have seen the same problem in several different screens because many of RM8’s screens have search boxes.

You described the problem well. The filtering remains in place, but the string being used for the filter is not visible. It happens when you leave the screen with the filter and then return to it. But the problem is not repeatable. Or at least for me, the problem is not repeatable. When I try to capture the problem so I can report it, then it won’t happen.

I think the developers need to look at every search box in RM8 to investigate this problem. Screens may need to be “refreshed” in some sense when you leave them and return to them. I have seen other things than search boxes that become confused and need refreshing if you leave a screen and return to it. There are a lot of places in RM8 that I have to kick a screen in some manner to get the screen to refresh. It’s not just search boxes which have this problem. But again, I have never been able to get such problems to be repeatable enough to report. You may have succeeded in creating such a repeatable scenario in this case. I’m going to be away from the computer for awhile, but I’ll try to recreate this problem later today using your scenario.

It’s hard to know for sure, but it’s possible that this bug is not in RM8 per se. Rather, it’s possible it’s in the tools and libraries that RM8 is using. If so, then the RM8 developers will have to report the problem to the vendors of their tools and libraries.

By the way, when I encounter this particular problem, I do the same thing you do. I type something into the search box. That seems to put everything aright. I should have recognized the problem from your symptoms more quickly than I did, but sometimes pictures are better than words in describing problems.

Thanks a lot. As I say, it seems to be triggered on opening the Color Coding dialog box - even if you immediately cancel, it still happens.

Have a good New Year.

Best wishes