Navigating pedigree view with keyboard in RM 8.2.0.0

With a larger database (60K+ people), there’s a lag when using the arrow keys on the keyboard to traverse the pedigree view. The details seem to load fairly quickly for a person that’s highlighted using the keyboard. It’s just the highlighting has a significant lag after the arrow key is pressed. The focus seems to shift fairly quickly - it’s just the highlighting that’s the issue. So if you press the arrow key 5 times really fast (within a second), the focus does seem to move to the person 5 times in that direction. However, the highlighting doesn’t indicate moving from the first person to the next person to the next person and so on. The highlighting takes some time and then jumps from the first person to the fifth person all at once. This makes it more difficult to quickly move around the pedigree view and have a visual indication of what person you’re currently focused on. RM 7 doesn’t have this lag and small RM 8 databases don’t either (moving with arrow keys and the corresponding highlighting is almost instant). It would be great to get the highlighting to follow the focus in real-time in RM 8 with large databases. Thanks for considering this enhancement.

Is anyone else experiencing this issue? We have a fairly capable workstation (Win 10 64-bit, 16GB RAM, Intel i5 3.4Ghz, SSD storage) this is happening on, so we don’t think it’s hardware or OS related.

I cannot replicate the situation you describe. My database is about the same size as yours, and my hardware and operating system setup is pretty much identical to yours. When I navigate Pedigree View with the keyboard, it seems just as crisp with RM8 as with RM7.

That’s actually somewhat curious because I have other scenarios where RM8 is very seriously slow. So I was expecting to be able to replicate your situation, but I cannot. I wonder what else might be different.

Well, I did think of one additional thing to try. One thing that sometimes becomes exceptionally slow for me with RM8 is that everything about RM8 can become slow if I filter the sidebar Index by a group. So I tried that just now, and indeed all of RM8 became extremely slow. It wasn’t just navigating Pedigree View with the keyboard. It was everything about RM8. But I did see a Pedigree View slowdown that was very similar to yours.

I doubt that you were filtering the sidebar Index by a group, so this is a shot in the dark that my symptoms are really the same as yours. The slowdown does not happen for me for every group I define. The slowdown or lack of slowdown is very sensitive to the criteria I use to define the group. And ultimately, the slowdown does not seem to be caused by the sidebar Index per se. Rather, it seems to be caused by some sort of problem in Advanced Search. I have reported the problem many times.

I wonder if You have WebHints and/or FamilySearch in action, and if so, try disabling them and retry.

Hi @thejerrybryan - thanks for testing that. I wonder if you’re trying to move 5-7 places within a second. Also, I just tested this in the Family view and there’s the same delay. I know it may not seem like much if you only move one person at a time. But if you’re trying to move around your pedigree or family view quickly, this behavior really slows down the process. Here’s an example of RM7 vs. RM8 for speed with the same database (you’ll need to download the GIFs and open them in a browser to see the “video” in action). About the middle of the RM 8 recording, you’ll see when I speed up to match the speed of moving in RM 7. The highlighting can’t keep up and it skips to the final person once you stop using the arrow key:

RM 7
screen-capture

Adding RM 8 screen recording into a second reply because I’m a new forum user and it will only allow one media item at a time.

RM 8 Screen Recording
screen-capture-rm8

Hi @kbens0n - thanks for the suggestion. I tried turning off WebHints and FamilySearch support. It didn’t change the behavior.