Media problems!

In RM7 I’ve attached media to sources (census pages etc.). In any place where there is a display media button it shows all media attached to that person regardless of whether it is attached to the person, an event or a source citation. This is one of my favorite features.

Q: How do I view all attached media in RM8?

Also, I attached images as files so they open with windows image viewer rather than within RM. I cannot get RM8 to display them at all. They are there, but there doesn’t seem to be a way to open them from within the program.

[sorry about the subject line - 15 char minimum]

In RM7, the main toolbar included a camera icon that displayed all the media associated with the currently highlighted person. You could also fillter the same list by fact/person/name and by citation for fact/person/name. The same list is available in RM7’s Edit Person screen via the Media button.

This very useful feature is missing from RM8. Nothing in RM8’s media gallery actually provides the same useful information on a per person basis.

1 Like

On your second question about being able to open media files in RM8, I am unable to replicate your problem.

If I enter media files into RM8 as type file, I can click the looking glass icon or the pencil icon and either way it opens the files in my Windows default media file viewer.

If I enter media files into RM as type image, I can click the looking glass icon or the pencil icon and I see the files either way. With the looking glass icon, I see the files in RM’s internal media viewer. With the pencil icon, I see the files in my Windows default media file viewer which in my case is Irfanview.

I very much prefer the Windows default media file viewer. Because of the way RM7 works, I have always entered my media files into RM7 as type file. Because of the way RM8 works, when/if I ever make RM8 into my production database, I plan to change my media files that actually are images into type image. I will still open them with the pencil icon and never with the looking glass icon. But changing them to type image will mean that I can access them from RM as printable media scrapbooks. Media files that that are not actually images such as PDF’s and TXT will need to remain as type file, even in RM8.

I wonder if your default Windows or Mac media viewer is not set up correctly which might prevent RM8 from being able to open the files. Do the same media files open ok in RM7?

They open properly from RM7, but in RM8 I can see that files are attached but have found no way to open them. The best I can do is to click on the button next to the file name which opens the folder but no item is selected.

If I change the file type from file to image, it will open in RM8’s viewer. Changing it back does not fix the problem either.

From the “Edit Media” panel neither the magnifying glass nor the pencil do anything. The trash can does ask whether I want to delete.

I’m pretty much out of ideas. Your RM8 obviously is not working correctly to open the files in an external viewer. It’s hard to imagine a scenario in which RM7 can use the external viewer and RM8 cannot. That’s because the external viewer function is really more of a Windows or Mac function that it is an RM function. I guess it’s time to open a trouble ticket at

Thank you Jerry. I opened a trouble ticket.

I have a very small data set here that I’m doing tree share with ancestry and learning to use RM8.

So far it seems like more trouble than it is worth. It does have some very nice features, but the data entry is slow and tedious.

Jason from support is telling me that images should only be attached as “Image” type in order to work. I tried attaching a PDF as a “File” and it worked perfectly. If the reason it isn’t working is because jpegs cannot be added as “File” type media then we have a problem. I prefer to pop up my document images in separate windows to review, not from within RM.

I have reread the thread. As I mentioned previously, I’m out of ideas and opening media files in an external viewer works for me in RM8.

I entered nearly all my media files into RM7 as type File so I could view them in an external viewer. In RM8, I’m switching all my JPG and PNG files to type Image. But RM8 allows me to view the JPG and PNG files in an external viewer anyway provided I use the pencil icon. I understood that you had tried to use the pencil icon and that RM8 failed to open your files in an external viewer. Did I understand correctly?

I sort of agree and sort of disagree with RM Support about the necessity of entering JPG and PNG files into RM as type Image or they won’t work. I did it all the time in RM7 and it worked just fine. I can do it in RM8 and it works just fine. The only problem is that if JPG and PNG files are entered into RM as type File I can’t print the files as RM photo galleries. I can open them in an external viewer. I just can’t print them as RM photo galleries. That’s why I’m switching to entering them as type Image in RM8. I wouldn’t have done so unless I could have continued viewing the files in an an external viewer by using the pencil icon.

If you have tried the pencil icon and it still doesn’t work, then I’m still out of ideas.

Yes, the pencil does nothing at all. No response.

I’ve gone back and forth with Jason. Attaching a PDF works fine. Attaching a JPG does not.

JPG opens with windows Photos from everywhere else so I’m not understanding why RM8 doesn’t do that. I’ve sent him images of my file associations as well.

I prefer my documents (most of which are jpg) to be treated as files. I like to open one or more and position them to the side of RM to compare and etc.

Most of my images are not pictures of people. I don’t thing I’d need to print them as part of a photo gallery.

Are you saying you can add a jpg as image and open it in an external program with the pencil?

I just tried a jpg added as Image - pencil does nothing for me.

The pencil does work for other file types - pdf etc.

Yes, that does work for me.

If you just go to Windows File Explorer, find a JPG file (any JPG file, doesn’t matter which one), and double click the file, what happens? Does the file open? If so, in what program does it open?

Oops, you have already answered my new questions. The file associations with the Photos app seems fine, etc. And it really should “just work” if you enter the JPG file as type File. if you do it that way, you don’t even need the pencil icon. You only need the pencil icon if you enter the JPG files as type Image.

If I were in your situation, I think I would change the file association for JPG to a different program than Photos on a purely temporary basis to see what happens with JPG files and RM. Then I would change it back to Photos.

You’ve been more helpful than Jason. I switched the association to Snip & Sketch and it works fine, photoshop too, but Photos and Paint don’t work.


Adding Media in RM8 should not require either a default or a user choice on file type. Any OS can identify file type from the extension (jpg…pdf…doc) and RM8 should just identify the type and accept one or many including a mix of types. FTM 2019 does this making the addition of media very easy and quick (copy paste) and shows items in their native program.

Well the difference is that images can be entered as “Image” file type and be opened in RM’s internal viewer or as “File” to be opened according to the system file type associations. The problem I encountered is that RM is stumbling on two programs (Photo and Paint).
Since the vast majority of my jpgs are documents rather than pictures of people, so I prefer it to open outside of RM. I’ve installed Irfanview and made the association. That is working for now.