Linking to Ancestry

12 Nov 2022 update 8.2.7 was issued to RootsMagic which fixed some linking problems with Ancestry. I did not download until 17 Nov 2022

17 Nov 2022 (Thu) I was having problems with linking to Ancestry so I Unlinked RM to Ancestry.

18 Nov 2022 (Fri) I could not re-link to Ancestry so I decided to delete my Ancestry tree and again upload my RM tree to Ancestry. I had no luck. I contacted Ancestry technical support and was told that it takes 24 hours for a tree to be deleted.

20 Nov 2022 (Sun) Tried to upload my RM tree to Ancestry, received an error message, “Tree has been deleted from Ancestry”

To link my tree, I go to the Publish page and click the Ancestry button. Why can’t I upload my RM tree to Ancestry?

If on the 17th you went to Settings, WebHints and clicked on “Disconnect from Ancestry Tree” you should have been able to upload immediately. It doesn’t require the existing Ancestry tree to be deleted first. I’m wondering if you’ve opened different databases?


Thank you for your reply.

I was not aware that I could have uploaded immediately - too late now!

I did not open a different database.

I just now looked at Ancestry and my Tiefenbach & Simsalek tree is not there.
I tried uploading again yesterday (Sunday) and got the error, tree has been eliminated.

Maybe they don’t work on the weekends, I’ll try again today (Monday).

Dave Tiefenbach

Can you get a screen shot of that error message. I’ve never seen that when uploading.

I think you have not used “Disconnect from Ancestry tree” in Settings > Webhint. That is what removes the linkages your RM database has to its TreeShared Ancestry Tree. By deleting the AMT, you’ve broken the links but not removed them.


I go to Publish page and click Ancestry button and get the attached message.

I’m not sure how to attach the message, I tried the Upload and here is the result. Did it work?


I did use the Disconnect from Ancestry Tree and I deleted the tree from Ancestry. Now when I try to Upload I get the error

You’ll only get that message when the database is connected to a tree, even if the tree is no longer there. Restart your computer and then open RM and go to Settings, WebHint and click on “Disconnect from Ancestry tree” again. If it still has an issue with being connected when it shouldn’t be send in a support ticket with a backup of the database. Let us know if you are on a PC or Mac computer.


Disconnecting from Ancestry again solved the problem

Thanks, Renee

I ran into this issue a couple of weeks ago when Ancestry wasn’t playing nice with RM. I did CTRL+Shift+U and restarted RM.

Once RM was released, the issue went away.

Thanks, my problem has been resolved.


You are right, I did disconnect from Ancestry again and this time it worked.