Gedcom with latitude and longitude not importing in RM8

I am testing the newest release on my Mac. My source database has every place geocoded. The places themselves imported but not the geocode. I’ve explored Settings to see if there was something there that controls it. Is this a bug? If not, is there a rational for not bringing them in in the import process? Thank you!

I would suggest that maybe there was a bug. On my PC the geocoding imported. AT least I have the latitudes and longitudes without having to geocode in RM8.

Geocoding did not import into my RM8 database on my PC; however, there is a command to geocode all places, and that worked like a champ.

I wonder if places I geocoded by hand will be imported. Has anyone tested that?

Hello dear user, I read your posts with interest. Because I am looking for the reason why I cannot geocoordinate my data manually.
So here’s my situation: I’ve imported my family tree from Ancestry into RM 8. I used “geocoed all Places” for the local administration and its mapping. That helped in many areas. Not in some. That’s the way it is. Especially when it is a “cow village” in former Germany and present-day Poland, where you can barely tell the 80 year time difference visually :wink: :grinning:.
I think to myself, no problem, you just enter the coordinates manually. I also proceeded as Terry wrote, supplemented by not only entering the information in the notes, but also in the fields for longitude and latitude. BUT: After inserting the degree of longitude and switching to the field for the degree of latitude, the data in the degree of longitude disappeared and automatically set to 0.0000000 N. No “Enter” or saving helps. Not even manual entry. The only change here: The longitude of the data record changes automatically to 5.0000000 N (original starts with 53, …).
Choosing a single place to geocoordinate doesn’t work at all.
For me, geocoordination is a key factor in getting family ties on the map. I come from Germany, and with it a lot of ancestors. But there are also places in distant Russia where ancestors lost their lives and very many descendants of emigrated ancestors in the USA.
So far there has been no response from support. Maybe someone here knows for advice and help.
Best regards, Tom

I did open a support ticket. A small test file was provided to RootsMagic support last week so that they could figure out why a gedcom with geocoding is not importing correctly. I did not actually test manually creating as I have spent hours and hours doing the same work in my current software. And using the geocode all did get some of them but not my small townlands (mine are all in Ireland where yours are Germany or Russia). I would possibly open a separate support ticket for the inability to manually geocode within the software itself?


I find RM fails to geocode 10-20% of my places. It can be quite fussy about having the exact full location.

To manually geocode I copy the Place onto Google Maps. Then right-click on a chosen location on the map. Up comes a menu with lat/long at the top. Choose that.

Back in RM paste that into the Longitude. CLICK THE TICK top right. RM then transfers the second half of the co-ordinates into the latitude. RM then recognises the place and adds the red dot to its map. I can check its pointing to the right location from mapping top left.

You can also just hit Enter instead of clicking the tick - one of the places where the keyboard entry works!

Good morning (at least here)!
Thank you for your answers. I did the same thing.
The exact dates are 53.602055 and 15.899211 / Dolgie in Poland.
I copied the data into the latitude column. The field was outlined in red (invalid). So the decimal place changed from point to comma . The tick in the top right was now there - and activated. Latitude jumped to the value 5,0000000 and Longitufe to 0.
And the pin was in South Africa, but not in Poland. I then tried all possible variations of this input. The result was always the same.
Then I had the location automatically geocoordinated again. The district town of Drawsko Pomorskie, 30 kilometers away from Dolgie, is offered to me. So I chose it and thought that I could change the saved data by hand. Latitude only worked again in the field. When I went to Longitude — whoosh :partying_face:, the Latitude was again 5.00000000.
Again and again the manually entered values ​​jump to 5.00 … and / or in the longitude to 1.00 … I can only imagine that it is due to the programming of the location mapping of RM 8, which is due to the individuality of the Computer that uses Microsoft updates and software in general (including anti-virus software) can lead to various problems in the execution of the scripts. However, that would be very unsatisfactory.
Let’s see if the support is still in touch.
I once had that with Legacy. The program ran on my “old” PC, the newer PC always blocked something in such a way that an essential script could not be executed. All this with the same software status. Technology also has a life of its own. :rofl: :rofl: :rofl:

Best regards, Tom

Just as a test I went to Google Maps, positioned my cursor in about the centre of Dolgie and got the following co-ordinates which I pasted into the Latitude field, hit enter and populated the longitude field 53.78544244988218, 16.806535101629784

The RM map shows me to be in Dolgie. Not at all sure why it is not working for you.

EDIT: I think there may be two places called Dolgie! Back to your co-ords and I wonder if you have the correct format which is 53.602055, 15.899211 (note the comma+space after the latitude value).

1 Like

I did the same test as @Terry and got the same results.

Hello, thank you very much for your help and effort.
I tried Terry’s coordinates. But I am persecuted by failure after us.
I have recorded the pictures of the situation in the attached:
1 = the empty field
2 = entering the coordinates Terry posted here. I also took over the empty field and comma. The check mark to save was also displayed.
3 = After clicking the tick the desolate end results. Latitude automatically jumps to 69,7236111 N in memory, the longitude to 0 and I’m back east of the Ivory Coast.

But at least that is more and different than before. There was only ever one 6,000.
We are approaching. I will check and repair my PC once in the system and reinstall RM8.
Best regards and thanks again Tom

1 Like

@Tom - Don’t know how this thread has evolved to You entering a pair of geo-coordinates into the Latitude field of the Edit Place screen… but, that will NEVER work (EDIT: after the fact, I’ve been informed of the feature supporting that method of data entry). RM8 doesn’t understand any value that contains a comma.

I believe your problem may have started with copying/pasting values to be entered in those two fields (Latitude & Longitude each separately) that contain punctuation that RM8 does not understand. For example, it should not be 53° 36′ 7″ it should be 53° 36’ 7" (note the first has back tick and double back tick, while the second has apostrophe and quote mark). With this change, RM8 will no longer show the field as red when you paste values.

Remarkably that’s exactly what does work. You paste the whole of
“53.60199757601126, 15.898389332845147”
into latitude, click the tick or press enter and RM flips the second number into the longitude line below. It also converts it into “53.6019976 N” and “15.8983893 E”.

Well it does for several of us. Our problem is it doesnt work for @Tom.

Apologies for the broad generalization. I’m still on vacation at the beach w/o my genealogy PC and was merely keying off seeing the comma. Glad it works as you folks describe.

1 Like

I am puzzled by RM’s fussy geocoder. How come it won’t recognise
Denver, Colorado, USA
so I have to manually geocode via Google. Thats one of many. For others it wants the city and county named if the same. Other times it wants the county not listed before RM will code.

Does that place get a red map dot and geocode for other users?

Works for me. When I just add Denver, Colorado as a new place and then right-click to Geocode selected place… I get Denver, Denver, Colorado, United States added as the Standard and the Lat/Long filled in.

Thats what I would expect to happen. Wonder why its doesnt for me. Tx for checking.

The , USA is not a recognizable element in any Place name that I tried

It doesn’t work for me either. I am not getting the geodata in RM.