Manually adding latitude and longitude - odd behaviour


when I tried to add Latitude and Longitude to Place details, the value is changed to 53,0000000 N and 0,0000000 E. I tried . and , with same result. Even if I copy/paste the values, it’s modified.
Does anybody experienced this as well and maybe has some suggestions/solutions?

Best regards,

Paste both the latitude & longitude in the Latitude field. As long as there is a comma between them hit Enter and it will split between both fields.

1 Like

Thank you, Renee.

I did as you suggested. After splitting between both fields it changes again to 53,0000000 N and changes 11.2305 E to 11,6402 E (when hitting enter the values change but switch to 53,0000000 N and 0,0000000 E after I hit the “save” button)

Screenshot 2023-07-18 184939

I think I see the issue. Its showing commas instead of periods. What are you entering? If I enter 53.1375, 11.2305 it will gives me.


Actually I have tried anything, commas and periods.
But in this case I copied it with periods.
After hitting “save” it changes anyway.

Once again, it is RM’s insensitivity to regional settings. The comma is the decimal indicator in the user’s region, not a period.

I work on a win10 system with German regional settings. There is no way to get Latitude and Longitude into RM .
If I use “geocode all places” that works for those places that are recognized.
If I then try to change only one digit, the whole number changes to zero.
My conclusion is, that with German setting the Windows system I can’t put in any geocodes into rootsmagic no matter if version 7,8 or 9.

1 Like

Thank you. I found another comment by a French user of RM adding lat and longitude data manually and he had the same problems with a French regional setting.

Steps to change between period or comma:
1. Windows search for “Control Panel”
2. Click "Change date, time, or number formats under “Clock and Region”
3. Click “Additional settings”
Change the decimal separator from comma to period without changing the country. You don’t need to restart the computer. Just run RM.


That solved the issue. Thank you!

Hey Renee

Wow Thanks for the info-- now can you help me fix my clock as it gains time after resetting it many times ? :rofl: just kidding abt the help but not abt the clock…

Wanted to say that on Windows 11, additional settings are on under REGION–maybe everybody else knew that BUT I didn’t…
again Thanks

Had the same problem, I got this answer:

To review the status of the request and add additional comments, follow the link below:

You can also add a comment by replying to this email.

Jason, Apr 3, 2023, 08:25 MDT:
Thank you for contacting support.

This issue is the windows settings for international languages. This has been reported and is on our development list.

RootsMagic inc.

I hope this issue is still on their development list…

Yes, the report to development regarding international versions of Windows and settings is still there.

Bug is still there in RM
Would appreciate a fix, too.


The developers should get out of the office more often- maybe do some international traveling.