Freezing working with notes in 9.0.1

We have been seeing user reports of version 9.0.1 freezing when working with notes, but have been unable to duplicate this. Development has requested us to ask users who have encountered this the following questions to help narrow down what might be happening.

  1. Does this problem also happen in the original 9.0.0 version?

  2. When exactly does the freeze occur? When typing? When saving the note? When clicking the left arrow to close the note? Sometime else?

  3. Does the freeze only happen when you have run spell check in the note? Or will it freeze even if you haven’t used spell check?

  4. Is there a sequence that you can duplicate that will always cause the freeze to happen?

  5. Is there a particular note it happens with more frequently, or does it happen in all notes?

  6. What computer / OS version are you running?

For me, it didn’t occur in v9.0.0, I updated yesterday and had no issues, but today in v9.0.1, I have been working with Treeshare and adding notes to new census facts. I managed to add notes to two census facts, but when I try to add notes to a third, it freezes.

I am running it on Windows 10, 64 bit OS.

I experienced no problem in RM9.0.0 and seems to occur when clicking with the LMB in an empty note. It seems to be random and I have experienced it in both the Fact Note and Research Note and it tends to occur after working for some time as if a memory leak.
Using Windows11 64bit

Hi @rzamor1

I’m on a HP laptop using Windows 11 Home version 22H2 with Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 2.80 GHz with 16.0GB Ram. I’m using the 64 bit RM and only encountered this issue with the release of My RM database is stored on my hard drive (not stored or linked to cloud etc).

I’ve noticed that the freezing occurs as soon as I go into a note – specifically yesterday when I was entering citations the system would freeze as soon as I selected the research note and the sliding window engaged. It is at this point that the cursor froze. I had not typed anything and the spell check had obviously not been utilised. The same thing occurred when I was entering the description to a media (image) file. The only solution (that I could find) would be to use task manager to exit the program.

I had quite a few Internet (Chrome) windows open at the time as well as Outlook, Excel and Word but these programs weren’t affected – the freeze only occurred in RM.

When this issue occurred yesterday, I’d only just turned on the computer and started working on RM (which is contrary to what @dennis experienced). I worked for about half hour and encountered freezing each time I went into a note (4 times in total I believe).

I’ve not got much time again today, but later this evening when I’m able I’ll try to experiment to see if I can work out situations where the issue is repeatable.

Thanks so much Renee. I can’t believe how responsive the company is to issues such as this – puts some of the bigger companies to shame!

See my answers above.


Elynn Boss

FYI - this seems to happen only when I attempt to add a new note. Doesn’t seem to occur when I am editing an existing note.


  1. I’ve been using RM9 quite heavily since its release, going through a 750+ tree updating new sources. I had no problems at all in RM9.0.0 only since the 9.0.1 update yesterday.

  2. Experienced the problem 9/10 times today. Most frequent when adding a media file (.jpg) to a citation and wanting to enter text into the media “Description:” field on the Edit Media form.

  3. The freeze happens immediately I click the mouse in the Text field. The mouse cursor changes from a text (I bar) to an egg-timer after about 30-40 seconds but the egg timer doesn’t rotate. Task manager is the only means of exit.

  4. All concurrent applications remain fully functional. [findmypast; ancestry, ms edge browser]

  5. After closing via Task Manager sometimes data that was already entered in the other Edit Media fields is saved, sometimes not.

  6. Can’t replicate the problem every time, but it’s sufficiently frequent to be a serious hindrance.

  7. Using Windows 11 Home, 64 bit version. Data stored on OneDrive (which I know you don’t recommend but has caused no problem in previous version – back to RM4!)

Hope you can come up with a fix.

Thanks… mike

Just had it happen when I was trying to type in the note for a fact. Had entered several notes in this session prior to it happening, both in facts and citations. Had not run spell check during this session. Don’t think I could duplicate the sequence I used. I’m using Windows 10, 64-bit version of RM 9.0.1 and never had this happen with extensive use of 64-bit version of RM 9.0.0.

Just attempted to add a new research note when creating a new citation. I entered one line, and then RM froze up. Had to use task manager to end RM. Seems to be happening more and more frequently for me, but so far only when I add a new note or detail comment. Hasn’t happened yet when I edit an existing one.

Freezing in notes started with v.9.0.1, I am running windows 11 Pro on an HP Pavilion 360. I was adding notes to my list of Addresses in RM, moving from one person to the next. I was using NotePad to collect relationship information about each person, and then copy/paste from Notepad into Address notes. After doing this for 3 persons, on the 4th person RM froze immediately when I opened the note window. I had to use Task Manager to terminate RM.

People! They are already aware of the problem. Scroll up and read Renee’s post. The smart thing to do is email support and answer the questions that she asked so that she can gather her info and pass it along.

Using version 9.1 with a PC running the latest version of Win 11 Pro. The app has locked up several times, and I couldn’t recall the actual sequence of events leading up to this until today:

I opened RootsMagic 9.01
Selected the home person.
Opened note.
Attempted to type something and it immediatly froze.
Selected Task Manager and closed the app.
Rebooted the PC.
Opened RootsMagic 9.01
Selected home person.
Opened note.
Successfully added a note and the app did not lock up.
Returned to home person.
App working as it should.

It appears to be hit and miss with the freezing, at other times I was in Family search and checking out hints and the program froze, however my memory didn’t serve me well enough to list the sequence of events leading to it.
Hope this helps.


Using 9.01. x64 bit version on Windows 10 Pro with 32GB of ram.

I did not notice any freezing in 9.0.0 version. It froze on me after I had synced an ancestor from Familysearch to RM. Then I open the note (from Familysearch) that was on his person. I clicked to add a space at the top of the note. As soon as the space was created the program froze and had to kill RM in task manager. Overall I’ve been very surprised at how stable RM 9 has been. This is my first crash/freeze in probably 30 hours of use.

Hi @rzamor1
I’ve been working on RM9 tonight and have noticed the following with regards to the issue with the program freezing when entering notes:

It seems that if I start to type in a note (any note) it immediately freezes.

But I don’t seem to have a problem if I follow this “routine” (say when entering a citation)

  1. Add a fact type and then add a citation.
  2. Enter all the details for the citation except the research note and press OK.
  3. Add the citation media and assess citation quality, and save by using the checkmark.
  4. Now return to the citation detail and add the research note by pressing enter to create a new line, and then paste (from Word using cntrl-shift-v). Then select the back arrow and save.

I’ve been following this pattern for about an hour (entering 8 notes) with no freezing, but as soon as I try and type directly in the research note, the system immediately locks (whether I do this at the point of entering other citation details, or try and enter following the same pattern above).

Hope this makes sense!

Random - but I thought I’d report it anyway just in case………

1 Like

Further to my previous message, I’ve just Switched on today and the problem appeared as soon as I tried to enter new text in the Edit Media page.

I haven’t a clue if this will help at all but this is a screenshot of the running RM9 processes when I closed it using task manager.

This problem is now so frequent that RM9.0.1 is not really useable.

Good luck with sorting it out.

I have the same as above.

I open a person for editing.
Open a note.
Click at the end of the note.
Enter return and Space.
The cursor is a text cursor but you can not click or enter anything.
This seems to happen within two or three tries.

Thanks everyone, with all the feedback we were able to reproduce it happening on the 64-bit version of RM 9.0.1. Development’s is now working on it.

1 Like

A late addition. It has frozen twice for me, both times when adding note to media. Windows 10 and RM9.01x64 bit

We just released update 9.0.2 with this fix. Appreciate everyone’s assistance in helping us track this one down.

1 Like