Association fact type missing or corrupted

The Association fact seems to be corrupted in my database. I can add an Association fact to an individual, but when I run the Fact List report it shows an empty list for the Association fact. Also when I run the tool “Change fact type for everyone” or “Remove a fact type from everyone” then Association is not one of the fact types presented in the drop-down box. I used to have my own Association fact type but deleted this when RM9 came along - has this corrupted RM9? I just ran the Fact List report and asked for “People missing a fact type” with the Association Fact type selected and one of the persons included in the report was the only person for whom I had added an Association fact. Something is wrong ! I went through the process of completely removing RM9 from my Mac and then reinstalling, and the problem hasn’t changed.

I doubt that it’s corruption. Rather, the Association Fact Type is a new feature that has been only partially implemented. It is also an unconventional fact type. Hence, the report you mention does not yet support it. Neither does Export nor drag’n’drop.


Association is not supported on the Fact List. It should have been removed from the list until it is. It’s been reported to development.

You can already tell who has an Association by clicking on the Association tab in the People view. The columns are sortable.

1 Like

Thanks Tom and Renee.

When do you expect Associations will be exported in the Gedcom output? My publishing framework is exclusively dependent on John Cardinal’s Gedsite so RM9 Association is useless for me until it is exported in the RM9 Gedcom output.

RM development doesn’t announce their planned enhancements. We will all find out in some future release.