Adding parents in RM9

I have a question about how to use RM9.

Occasionally, I find that I have attached a child to the wrong parents, almost always to one of the correct parents, but to the wrong spouse. I know that Treeshare doesn’t manage these things, so I have to make the same change manually in both Ancestry and RM.
As I understand it, I have to unlink the child from his or her parents, and then re-attach them. If I do this while highlighting the child, both RM7 and RM9 ask me to choose between adding a new person and an existing person. After choosing ‘existing,’ I pick someone from a list. In RM7, I am then given a choice in turn of any families featuring that person, ie that person and each of his/her existing spouses, and then the option of creating a new family (ie with a new unknown spouse). But in RM9, although I am given information on the spouses that the chosen person has, and the children of that marriage, I don’t seem to be able to add a child to the existing family formed by the two people. The end result always seems to be that I always end up creating another family formed by the two original parents.

If I work the other way around, and attach an existing child to an existing set of parents, then there is no issue.

I also don’t see this covered in the documentation. Have I missed something?


See examples below, where I have unhooked someone from his (correct) parents and then tried to re-attach them. Original family view

Same person after parents detached

Add father screen, choosing the right father and spouse/family

Family page after attaching new father

Note that the mother has not been attached along with the father. Family screen after attaching the mother using the same process

New family view for the parents

Second family view for the same two parents, both of whom now have two spouses - both the same

It took me a while to understand your workflow, but after I understood it I could recreate your problem. My analysis is that there is a bug RM9 that is not there in RM7.

In RM7, when you click the + Add Father box, it first offers you in turn each of the existing families (i.e., spouses) for that father. You can say no to each family in turn until you get to the correct one. If none of then fit then you can create a new family. In RM9, it never offers any of the existing families for the father and goes straight to creating the new family. That is the bug.

Compared to the TreeShare and FamilySearch issues you have posted recently, this one is a very simple bug that’s trivial to replicate and that should have a very straightforward fix. In the meantime, instead of clicking on the + Add Father box, a workaround would be to right click the child and choose the Add Parents option. The workflow will then follow the RM7 model that works correctly.

To start with I was a little confused because you were doing an Add Parents type of operation for a person Daniel Johnson Keys who was physically located in the Parents position of Family View. But that should make no difference and your workflow should be supported just fine. The fact that is doesn’t is a bug.

I first tried to recreate your problem doing unlinking and relinking the way I usually would do it. First of all, I never unlink and then relink. I always relink first and then unlink so that there is never a time when the child is floating in air not connected to any parents at all. Second of all, I usually do these kinds of relinking from Descendant View set to 2 generations so that I can see very clearly what is going on.

I would set Natan Andrew Keyes as the top person in Descendant View set to 2 generations. Then I would right click Daniel Johnson Keyes and do an Add Parents. When I tried it just now on RM9, it worked (sort of) but then immediately there was an Access Violation error. It needed to rebuild Descendant View to show Danial Johnson Keyes temporarily as a child in two different families, pending the unlink I was about to do. But it didn’t rebuild Descendant View correctly and got an Access Violation error instead. My method works smoothly in RM7. Descendant View is rebuilt correctly. I can see that the child is linked temporarily to two different families. And I can see very clearly where to do the unlink to complete the process linking the child to the correct parents. So RM9’s failure to rebuild Descendant View correctly and then getting an Access Violation error is discouraging.

I’m still on RM7, by the way, but I spend much more time each day in RM9 than in RM7 while I try to work through various RM9 issues. I’m getting closer to converting to RM9, but I’m not there yet.

I just discovered another little RM9 glitch in my method to relink and unlink children from Descendant View. Sometimes after relinking a child to a new set of parents, if I right click on the instance of the child with the parents I wish to unlink it only offers me the set of parents I just relinked and never offers me the set of parents I wish to unlink. I have to switch to Family View to do the unlink.

Also, the Access Violation error I reported in my previous message is not repeatable. I ran through the same scenario in RM9 a second time and the second time there was no Access Violation error and the appearance of Descendant View set to 2 generations updated just fine.

Select the option to add parents. When you select the existing Father in the database it should give the option to add to the existing family. Easier option is to display the correct parents in the family view if they are already there and then add the existing child to them. You could also just highlight one parent and in the info box under spouse select to add a child to them.

Now that I have been through the process, I know in future to add a child to parents, but I still think that there is a bug in RM9.

Renee, you say ‘‘When you select the existing Father in the database it should give the option to add to the existing family’’. I agree that this is what it should do, but despite repeated attempts - selecting just the father, selecting the father while highlighting the correct spouse or doing the same while viewing a list of children to the two parents - it doesn’t as far as I can see.

I think this is a bug and should go on the list to be fixed. Either that or there needs to be some very clear guidance in the documentation on exactly how to do it.


With one person highlighted in any view “add child” will give the option to add to a known family or to that person and an “unknown” spouse. If in family view, adding to the existing family through the add child box gives the option of adding to that family only.

You are quite right that you have to option to select a family when you add a child to an existing parent. As I discovered, this is an easy way to link the two together, but what I first tried to do was to join the two together by adding parents to children.

If you do the really obvious thing and click on the ‘add mother’ or ‘add father’ buttons in front of you, then you get the option to add a new or an existing person, but nowhere does the system give you the option to add to one of that person’s existing families (as RM7 did).

In fact there is another way to proceed which also works. If ignore the ‘add father’/‘add mother’ buttons and right click on the person, you get this menu

Selecting this, and on the next screen selecting either the father or mother, you then get presented with a screen to ‘add father’. If you choose to select an existing person there you get this listing of that father’s associated families

This works perfectly, and is exactly what RM7 does does if you click on the ‘add father’ button. The problem is that when you click on ‘add father’ RM 9 does not follow the same process.

Renee wrote above ‘When you select the existing Father in the database it should give the option to add to the existing family.’ It should, but it doesn’t. This is a bug.

I don’t remember what RM7 did but when I get to that screen in RM9 and say yes, both parents are added together which seems to be the optimum result. What are you expecting to happen? If the desired result is to add to the father with a different mother, clicking no adds the child to the father and gives the option of adding a new mother or choosing an existing person. Next option is to add a marriage event (or choose no marriage). In all scenarios, my “child” gets added to the chosen parents properly.

If you right click, choose ‘add parents’, then add the father, you get the option to add a person to a family as shown on the screen print above.

But if you use the much more obvious choice to ‘add father’ or ‘add mother’ using the buttons right in front of you on the screen in large print, you never get to the screen showing the family and have no option to add the child to it; you can only create a new family (using the same parents) to add the person to. This is not what happened in RM7, not it is it what Renee says should happen.

Renee says (quoting her now for the third time, with apologies, as I hoped that I was crystal clear the first time). ‘When you select the existing Father in the database it should give the option to add to the existing family.’ But if you click on the ‘add father’ button, and then select the existing father from the list, it never gives you this option. All you can do is create a new family. As Renee says, it should give you this option. Not giving you this option is a bug.

I agree with Alan’s analysis that there is a bug. There is a workaround - several workarounds, in fact. But the existence of workarounds does not mean that there is not a bug.

Clicking on the + Add Father or + Add Mother boxes in Family View is a trap with no options. Doing so adds a new individual with a null spouse rather than offering the same options that are available, for example with right click and Add Parents of selecting an existing couple.

If you click on + Add Father and then click on + Add Mother (or vice versa), then the second Add is fine and gives you the appropriate options. But the first Add does not provide the appropriate options.

Sorry, but I have not seen any of the issues either of you describe. Parents get added appropriately. Children get added to the correct family defined by me without fanfare or unexpected “unknown” parentage.

I see I am quoted but the first part continues to be missing.

I apologise for misquoting you. That does indeed work. I had not initially seen the right click ‘add parents’ and thought you were referring to add mother or add father, collectively as ‘add parents’.

That is the distinction I have been trying to make. Right click followed by Add Parents certainly works perfectly. The + Add Father and + Add Mother boxes are traps which lead you into trouble. That’s where I think there is a bug which needs to be fixed, namely they don’t ask you if you want to add a new person or an existing person.

1 Like

I’m with alainemk. Can’t make it NOT work in Pedigree/Family tabs.

Very strange. I can’t make it fail right now, either. I was able to recreate the problem several times during this discussion, and now I can’t. It makes me feel like a crazy person.

I wonder if it was fixed in If it was not fixed in, then there must have been some other very unusual condition that triggered the failure. I tested on several different people in my database and saw the failure. It wasn’t just a test of one person.

After reviewing all relationships, I did note using Jerry’s process, adding the parents individually to the child with the +Add Father, +Add Mother boxes results in a double spousal link between the parents. One with the child, one without. That is only when an existing couple is added separately. Adding two existing people not previously connected results in the expected family group.

I’m out and about (away from my PC), but I ~believe~ that has also been problematic with RootsMagic 7. It’s due to those functions being unclearly “independent of” and “merely accesory to” the Add Parents functionality.

NO @thejerrybryan did NOT FIX this bug-- it still happens each and every time you use ADD FATHER ICON AND ADD MOTHER ICON in the pedigree view or the family view

It does NOT happen in the descendant view as you are right clicking Add Parents and the box comes up for you to select which family you want

It also does NOT happen if you use the + plus sign in upper right hand corner

I checked both RM 8 and RM 7 also-- RM 8 is exactly the same as RM 9 BUT RM 7 always gives me the option of which family to add it to…

so @rzamor1 we really do need this fixed please as I spent 3 weeks helping a person fix their database of errors caused by this-- neither of us knew this was the problem-- I just finally told them to use the family view only and to add a child to the parents…

One other note for anyone who is new reading this thread-- If you do end up with a child in a new family ( with the same parents), besides unlinking the child, you must also unlink the spouse to get rid of that marriage