Yet more bugs in 9.0.2

Today I ran the person tools and especially noted the Clean of Places and People, all were checked and verified that they were as they should be before accepting.

Then I worked on my Ancestry tree and added one person and a few media items related to that person

Ran Tree Share and accepted the new person.

Ran the Tools and when I ran the Data Cleaner for Places and People some of the prior entries that were cleaned were there again.

So I cleaned them again, ran all the tools again, ran the backup with media process.

Just ran Data Cleaner again and the same
Stott Hill, Bradford, Yorkshire.
came up as requiring cleaning so it was cleaned.

Ran it again and yes, it is still showing as requiring cleaning

Presently with this and other issues I have zero confidence in RM 9

What are you changing Stott Hill, Bradford, Yorkshire too?

That is the correct name, Ancestry placed a Period after Stott Hill & RM changed it to a Comma but Data Clean did not register the change, eventually I added England and RM accepted it.
Data Clean all OK now
Its an odd quirk that it accepted about 20 others where Periods had been placed insted of a Comma by Ancestry and none of these had England in the corrected place names