Why can't I see MP4 video files listed when attaching media files

MP4 video files not appearing in the roots magic 8 import dialog box. If I use drag and drop the MP4 video files will link to media. However if I navigate to the folder with the MP4 vid’s in then roots magic 8 shows an empty folder! Any help appreciated. I have the latest updates.

I developed a script years ago to reset the assigned media category according to the file extension and observed then that RM’s filter for video extensions in its file explorer was narrow and hid numerous types. Its scope is still the same (.avi, .mov, .mpg, .mpeg, .wmv) despite the growing number of types. When in the “Select filename” dialog, enter “*.mp4” or “*.*” in the “File name” field and that exposes them. Or switch the filter to the right of that field to Document, which is the “*.*” filter.


1 Like

For me, the Select Filename dialog window has a dropdown to the right of the Filename: block and an option shown as

Document Files ( * . * )

That will show ALL filenames in a folder to which you have browsed (including .MP4)

1 Like

Another option is to change the ‘Media Type’ from “Image” to “File”. This also makes all file types eligible to be added to your db as media. MP4 is not recognized when Media Type = Video but adding a mp4 file as Media Type = File results in launching the default MP4 player defined in your OS when you double-click on the media in RM8.

1 Like

Regardless of the Media category assigned to the MP4, the operating system’s default player is launched.


RM8 should not require the user to choose between jpg and non jpg (ie pdf) files when adding media. This is an annoying extra click oversight which does not occur in FTM 2019 which has just had a minor free update.

1 Like

Thank you all for your help, with which I have resolved the issue.