WebHints Problems after Upgrade

After the upgrade, my Ancestry and FamilySearch webhints quit working. My MyHeritage webhints continue working and I don’t use FindMyPast webhints.

I got my Ancestry webhints working again by logging on again to Ancestry from inside RM. It took a while because TreeShare had to go through the whole checking for changes process instead of just logging on. I can’t get my FamilySearch webhints to work at all. I have turned the hints off and on and I have re-entered my logon credentials which were correct anyway. Any ideas?

The problem can’t be at the servers. All my webhints continue to work perfectly in RM7.

In addition to FamilySearch’s webhints not working in RM8, clicking on the FamilySearch icon for a matched person in FamilySearch doesn’t work in RM8 since 8.2.6. The error message is “FamilySearch not responding”. Clicking on the FamilySearch icon for a matched person in FamilySearch continues to work in RM7.

Since both FamilySearch webhints and connecting to FamilySearch matched people continue to work in RM7, the problem can’t be the FamilySearch server, the internet, or things like that. I have reloaded my RM8 database from RM7 and I’m certain that RM8 has the correct credentials for my FamilySearch account.

In Settings => WebHints, I see the message “To see FamilySearch hints, do Settings > WebHints and provide your user name and password”. So RM8 obviously knows it has a problem. But I have certainly provided the proper user name and password manually, plus RM8 properly imported the same information from RM7 and RM7 is still working.

Just tried FS Webhints at RM 8.2.6. Works OK for me.

I am receiving all hints including Ancestry and FamilySearch. RM 8.2.6 Windows 11. The only issue is that after a time of inactivity on Ancestry, I get the “connected tree not found” message. To clear that, I need to exit RM and restart, relogging into Ancestry. I do not have my Ancestry log-in “remembered” and log in each time.

1 Like

I forgot to mention that I am Windows 10.

I can get Ancestry to work and I don’t get the “connected tree not found message”, but I do lose the Ancestry logon periodically and have to logon again. I never lost the Ancestry logon on 8.2.5.

I still can’t get FamilySearch to work at all on 8.2.6, neither the hints nor the connection to a matched person. Do you get both the hints and the connection to a matched person to work?

I am Windows 10 too. Have not tried against Ancestry.

Yes, both hints and connections to a matched person work.

I have uninstalled RM8, including that I deleted the RootsMagicUser.xml file for RootsMagic 8. That clears all the options. I reinstalled RM8. I have temporarily turned off antivirus and VPN.

I had to logon to Ancestry again in RM8 because of deleting RootsMagicUser.xml, but it now works. I won’t know for a while if RM8 loses the Ancestry logon periodically.

I had to logon to FamilySearch again in RM8 because of deleting RootsMagicUser.xml. Having done so, I still get the FamilySearch is not responding message when I try to see a FamilySearch match. I do see the correct FamilySearch userid in RM8 at this point. I cannot see the FamilySearch password in RM8 it is not displayed in the RM8 user interface. I know it’s correct because I pasted it in from where I know it is correct. The userid and password are both encrypted in the RootsMagicUser.xml file so I can’t see them from there.

It’s like something is blocked between RootsMagic 8 and FamilySearch. But with antivirus and VPN turned off, it’s hard to see where the blockage might be. RM7 still connects to FamilySearch just fine, both for hints and to see a FamilySearch match. I’m out of ideas at this point.

I installed RM8 on a second computer which didn’t previously have any version of RM installed. It was the latest download which is symptoms of not being able to contact FamilySearch are identical to the symptoms on my primary computer.

What I’m wondering is whether there is a way to install just as a test. I would like to know for sure if the problem is in, or at least that is the problem on my computer. Other users have reported being able to use FamilySearch with which is very puzzling. Because of that, it’s hard to know if is “the” problem of it’s just my computer.

I always just use the automatic RM updates and I don’t keep the install files for each update. I’m beginning to wish I did so I could more easily go back to as sort of a test.

In the Facebook group, those reporting a problem installed the Microsoft patch and are working now on FS. No comments on Ancestry.RM Blog Post re: Microsoft Win 10

It had occurred to me overnight while I was sleeping that this problem is simply the Windows TLS problem that has already been much discussed and that I wasn’t putting 2 + 2 together properly to come to that conclusion. I wasn’t going to bother with the Microsoft patch because it looks hard to install and my production data is still on RM7. But I’m doing more and more work where I do the same work in RM7 and RM8. So I’m going fight through the Microsoft patch. It seems very likely that doing so will fix the problem.

I installed the Microsoft emergency patch, and all now seems well. I get hints from both Ancestry and FamilySearch. The direct connection to matched people in FamilySearch now works. We shall have to see if the Ancestry logon becomes forgotten again and has to be re-executed occasionally.

The Microsoft emergency patch was actually quite easy to install and went very fast. It was trying to remove the Microsoft update that first caused the problem that was so hard that I chose not to do it.

For the moment, I’m not getting MyHeritage hints in RM8, but I’m not presently getting them in RM7 either, so that’s probably just some temporary problem at MyHeritage. I suspect that if they come back in RM7 they will also come back in RM8 at the same time. I don’t use FindMyPast hints so I can’t report on their status.

My apologies for misremembering the information that was posted on Facebook about this problem.

1 Like

Yes Agreed - it unchecks the log-in – not sure if that it is by design due to server issue etc.