Uploading RM9 to Ancestry resulting with missing photos

A few years ago using RM7 I uploaded my tree to Ancestry including 2599 photos. I never synced the sites afterwards. Now using RM9 I decided to create a new tree on Ancestry to reflect the additional 2,000 odd names and 142 additional photos which now totalled 2741. The first upload was correct for the additional names but only uploaded 2414 photos. So I deleted the new ancestry tree and created tree two. This time only 2332 photos were uploaded to Ancestry. Again I deleted and tried upload number three. This time only 2237 photos uploaded.
I checked the missing photos that were on RM9 and not on Ancestry and could see no reason for the shortfall of photos. Different photos were missing on each upload.and all were in a common folder. Anyone had this problem before? I am at loss to see why 400 to 500 photos do not upload on each attempt. Any suggestions?

I would check in RM to see if you have any red Xs in the Media (meaning the links are broken) and fix them.
Also when you upload to Ancestry, I would not delete the tree, rather give it another name if you upload multiple times. You can always delete or rename it when you happy with it.

Hi MadDog
Thanks for reply. No red Xs in RM. Yes I have left the last upload on Ancestry but wonder now where to turn. Perhaps RM10 may resolve if there was any changes to the program in that area.

1 Like

possible v10 but I would still KEEP v9 just in case (it asks you if you want to uninstall when installing v10) Good Luck

On mac you are NOT prompted to replace RM9 but just get both on the computer which is a mess since they seem to share some files.

I have upgraded to RM10. An upload to Ancestry transfers 2316 photo from RM10.

To summarise:

Total photos on RM10 for uploading 2741

First upload 2414 RM9
Second Upload 2332 RM9
Third Upload 2237 RM9
Fourth Upload 2316 RM10

So it is obvious with no changes to RM that not all photos are being uploaded in the transfer to Ancestry as well as variable uploads every time. In fact at least 400 photos do not upload to Ancestry.
So there is an identified problem in the upload of RM to Ancestry.

Perhaps certain media file types are being botched by RM and/or Ancestry. Check # of jpgs, heic, pdf files to see if one type is being missed. RM does not handle non jpg files well and requires the user to tell it to use a non jpg file like a pdf.

1 Like

Thanks Rooty
All the images are jpgs so they should all be accepted by Ancestry. One of the strange situations is that different images are not uploaded on each occasions. There is obviously some strange issue in the uploads between RM and Ancestry. I run a PC with 32 meg of ram and an updated version of Windows 10 so my PC should not be an issue.

With an adequate pc setup perhaps RM has a timeout issue uploading to ancestry depending on your internet connection and how busy the receiving servers are. In the past uploads would fail with a slow connection. FTM has never had such an upload issue.