SQLite Error 11 - database disk image malformed

Since upgrading to version 8.5 today I have had two databases give me this error “SQLite Error 11 - database disk image malformed” and then be unusable.

In the second occasion it only appears when I have the Places tab open. If I attempt to do a Place Clean it fails part way through with the same error. The Places Tab doesnt show the list of places.

Note that this is the Mac version of RM8 on an M1 MacBook Pro

Does anyone know how to download an older version of RM8 ?


An older version will report the same problem. This is a file corruption occurring on the drive in an area of data that likely holds some of the PlaceTable or its indexes. Running the database tools might repair it but probably not. Restoring from a backup probably will but the drive may still have a bad spot. Use the OS drive utility to check and block off bad sectors

I don’t know how safe it is mix older versions but on my Mac I always “keep” the old version when installing an update. I do this by renaming the application adding the version number to end of the name. I can even run multiple versions side by side at the same time.

I have not used Places and have not seen the SQL error.

Glen Gunselman

Do you also rename all of the associated object libraries that get installed alongside the main application? There’s a chance newer bersions of them are installed, too.

No . For most applications on MacOS the “file” that we see in the Finder Applications folder is a special folder. control click and select Show Package Contents. You can drill down from there to find the RootsMagic executable.

The RootsMagic “package” is not very interesting. Family Tree Maker 2019 is more interesting.

I would NOT change anything in the “package”.

Have a good day,
Glen Gunselman

I’m having the same exact issue since upgrading to RM 8.5.0 on my Mac. (Did not have this issue on prior RM8 versions). I’m also on a Macbook Pro M1, using OSX Ventura 13.2.1. I contacted support via chat and he had me run all the database tools. Even after running each of the database tools, I still get the “SQLite Error 11 - database disk image malformed” error. I have an open ticket and have sent them my database file. Hope they can figure out why I’m seeing this error. Until I get resolution, I’m not going to open any of my other databases for fear they will become corrupted.

I’m quite confident that this was not caused by the update (not upgrade) to 8.5.0 from an earlier 8. Your database file has been corrupted by some other cause. Of course you have recent backups? You may try restoring progressively earlier through your backups until you find one that passes the integrity test.

If the first successful restore goes so far back as to undo a lot of work but you can still open the current file, maybe it will allow an export to GEDCOM. If it completes without that error, import into a new database. Then have a look at https://sqlitetoolsforrootsmagic.com/gedcom-dnd-transfer-losses/ and assess whether the restored version or the GEDCOM version presents you with the lesser job of getting back to where you want to be.

If you have the techie aptitudes to use SQLite (I’ve not seen evidence that RM Support does), you could attempt some of the recovery strategies I’ve tried with mixed success: https://sqlitetoolsforrootsmagic.com/corrupt-database-recovery/

Thank you, Tom, for the detailed response and suggestions. I was able to recover from a Time Machine Backup file. Although it was back in April, I’m not too concerned as I had fortunately not made many changes since then.

1 Like

Sounds like you need to keep your time machine drive connected to get continuous ~hourly backups for more depth. I use a 2nd TM drive connected every 10 days plus an automatic cloud service backup. TM drives have failed on me when I most needed them hence the 2nd drive.

I’m using a pair of Macbook Pros for this, not Windows. Filesystem corruption can still occur on OSX but its way, way, way less likely. Both times I saw this I happened to be cleaning up places. Both times I subsequently tried booting into recovery mode and running disk utility and didnt see any corruption.

The fact that I routinely see what look like concurrency bugs within OSX RM8 makes me skeptical that this is a “simple, vanilla” disk corruption error.

Can I ask which sqlite3 GUI you use with OSX?

Random Voodoo observation. A few hours before encountering this issue I had saved gedcom and imported it to ancestry. Just for fun, I created a new DB on my other laptop and downloaded the ancestry tree into it. I then go to run a FamilySearch Automatch …

It tries a few matches then gives the familar “Error Family search is not responding” error and invites me to cancel or retry. Neither cancel nor retry do anything at first. Then, a minute later I see "Unexpected Error- SQLite Error 14 - unable to open database file. Maybe or maybe not related.

I don’t use MacOS. You might have a look at SQLite Studio and DB Browser for SQLite.