Shareable Drive - This app can't run on your PC

Using RM 9.05 on a Windows 10 PC, I created both a Shareable Drive and a RM To-Go on another USB drive; each of these procedures successfully creates a USB drive. When I try to use either USB on a Windows 10 laptop (separate PC) I get the message: “This app can’t run on your PC. To find a version for your PC, check with your software publisher.” I also tried to do this by using the “Run as Administrator” option. Any other ideas?

Are you running Windows 10 S Mode on the laptop? If so you need to turn that off or the only apps you will be able to run are from the Windows Store.

You might want to take a look at

Nope, not in S mode, Windows 10 Home, build 22H2.

Next thing to check is which version of Windows is on each machine. Did you install the 32-bit or 64-bit RM? Is the laptop the opposite of the other computer?

1 Like

There it is! Desktop PC has 64-bit OS and (I assume) 64-bit RM, the laptop PC has 32-bit OS. I tried the Shareable Drive USB on another laptop (another 64-bit Win 10) after this, and it worked there; so the 64 v 32 OS is the problem. Thank you for the speedy help!


1 Like