RootsMagic Android App

I have problems getting the Android App to work.

I couldn’t find one in the the normal Play Store, but found a Version 1.01 (2012-2014) in the Amazon Appstore. Tried it on a couple of Android devices but it doesn’t even get into my Dropbox account. I get this splash screen when it fails.

Naturally I’ve checked that the Dropbox account is accessible through normal login, it has the Apps/Rootsmagic directory structure, and a couple of .rmgc files, the latest just generated by RootsMagic 8 on my Windows PC.

So Windows Rootsmagic 8 software can get there, just not the Android App ! And yes, I can login to Dropbox thro’ browsers on all the Android devices too.

What confuses me is that it’s telling me the app is ‘not correctly configured’, but there seems to be no way of configuring it…

Does anyone know where Dropbox downloads the .rmgc file to, on Android devices, then I can probably put it there myself. Or is there a later/better version of the App anywhere ? Thanks in advance.

I’m an iPhone user rather than an Android user, but the location is the same either way, namely it’s \dropbox\Apps\RootsMagic\ But you have already confirmed that’s where RM8 put the RMGC file.

When RM8 creates the copy of the RMGC file, it doesn’t know or care whether the mobile device is going to be an iPhone or an Android. Since I don’t use Android, I can’t guarantee that the Android app doesn’t want the RMGC file somewhere else, but it wouldn’t make sense for it to be somewhere else.

I can run the Dropbox app on my iPhone and search for RMGC files. The first one that comes up is the RMGC file created by RM8. I would assume that you can run the same test on the Dropbox app on your Android. If you can run that test successfully, then then I’m not sure what else you could try. Note the this little test does not involve the RM mobile app at all. It just involves the Dropbox mobile app to the sure the file is on my mobile device.

I just ran one further test. My RM mobile app was still using the RMGC file put into Dropbox by RM7. So I tried the RMGC file put into Dropbox by RM8 in the RM mobile app. It came up just fine. As I was saying, the mobile app doesn’t know the difference between RMGC files created by RM7 or RM8. And when RM7 or RM8 is putting an RMGC file into Dropbox, they don’t know if your mobile device is iPhone or Android.

My Android Version is 1.4 (copyright 2012-2015). Still works on Samsung Galaxy A51 Android 11, more or less. I rarely use it and just made it crash on the database opened in the last session which was months ago and I’m not even sure which one it was - it could have been from RM8-Beta.

However, RM7 for 2-3 years now cannot save to Dropbox cloud on my Windows 10 pc, nor can RM8. I have to save to the local Dropbox folder.

I think you’re SOL for the RM app unless you can get it from RM Inc and sideload it. Since it’s read-only, you might consider other approaches:

  • a GEDCOM viewer app: you’d export from RM to the shared cloud system’s local folder
  • upload to an online tree, e.g. TreeShare to Ancestry or FamilySearch Family Tree and use your mobile’s browser or their apps, which can also support working on the tree. not just viewing
  • upload to your own tree website, e.g., RM’s MyRootsMagic.com or GEDCOM and John Cardinal’s GEDsite and view with your browser

Thanks guys, everything about Dropbox is fine, I can talk to it from all my devices, as can Windows RootsMagic8, the files etc. are where they should be - Dropbox is not the problem.

The only problem is the Android app (from several devices) just doesn’t even get me a Dropbox login screen.

So,
a) are there any configuration tweaks on the app ? I can’t find any.

b) when the app pulls the file down from Dropbox, where does it put it on the Android filesystem ? I could do that manually if no data conversion is involved from Dropbox to App.

c) where can I get that newer version of the Android app, because there obviously is one ?
Just the RootsMagic.apk file I guess would do it… Anybody got one ?

I just used DuckDuckGo and searched on Rootsmagic.apk and found two sites with copies of version 1.4. Your decision if you trust them.

Aptoide

APKPure

1 Like

Thanks BobC, DuckDuckGo is a new one on me, useful …

My antivirus got suspicious, so I’ll dig out my old android phone to initially download to - don’t mind if that gets polluted…

RM8 can save directly to Dropbox and has been able to do so for some time now. If your RM8 doesn’t, then you may have some other issue that needs to be tracked down if you want to do a direct save as opposed to the local folder.

The direct save to Dropbox was broken in RM7. The problem was caused by changes in Dropbox and that RM7 was not updated to reflect the changes in Dropbox.

The direct save to Dropbox has always worked for me from RM8 ever since I first tried doing it. Reading through this thread, it sounds like the OP’s problem is getting the correct version of the RM mobile app installed on the Android device. It looks from this distance as if everything else is working.

1 Like

Agreed. Something about socket unavailable but Dropbox itself is fine as was some other app (I forget which) could direct upload when last checked some months ago. So I suspect the fault lies with RM Inc’s interface to the Dropbox API.

All sorted, I got a link to a pukka v1.4 Andtoid App from a very helpful chap on the Facebook group.

So avoid the v1.01 on Amazon App Store !

BobC - those two links - thanks for going to the trouble and looking tho’ - were complained about by my virus checker, and either failed or went away forever when I checked them on an old, retired, phone…

Here is the working 1.4 !
Message me if you’d like a copy.

Footnote : If anyone from RootsMagic Support reads this, please take the v1.01 Android App off Amazon App Store, it doesn’t work, and certainly doesn’t do RootsMagic any favours, by wasting my/our time !! :frowning:

7

The RootsMagic App is currently not available from the Google Play Store. The RootsMagic App is still available to download directly from our website. The directions have been added to the RootsMagic Help Wiki, under FAQ Support Questions.

RootsMagic App no longer in Google Play Store
http://wiki.rootsmagic.com/wiki/RootsMagic_8:FAQ_Support_Questions#RootsMagic_App_no_longer_in_Google_Play_Store

Thanks, I just checked if the Amazon App Sore one was still there, search found one -strangely, clicking on it in the App Store opens the 1.4 App on my Android phone…

I’ll bookmark the WikI for future use ! :slightly_smiling_face:

You might like to be warned that searching the internet for rootsmagic.apk finds sites like Aptiode which offer a download - but it’s their own ‘installer’ that gets downloaded, which probably doesn’t do the Android device much good :frowning: at all…
You have to uninstall the Aptiode program and any files that came down with it, as it seems to take over from the normal Android installer. Beware :imp:

1 Like

If you are using Windows then just pressing F1 in RM8 will get you the Wiki. Not sure about Mac but sure there will be an equivalent.

I also use RM8’s Home tab a great deal to get links to the Wiki, to the Online Community, and to lots of other stuff. So far, using the Home tab in this manner has seemed easier for me than managing a bunch of bookmarks. I’m sure that the easiest way to manage this kind of information will vary a great deal from user to user.

It just seems to me that RM8 just does not support an Android App. I had no problem with the Android v1.4 app on a Pixel phone with RM7. But when I switched to RM8 and tried to open it in the Android app crashed. I did all the following:

I followed all the steps in the FAQ “Android App Crashing or Forced Closed” with the v7 file. No help.

I then followed the instructions to export the v8 file to v7 format and again ran the database tools with no errors reported, uninstalled and reinstalled the app, three times. After each try, the app opened, but when I selected the rmgc file in Dropbox I received an error message and the file would not open, but the app did not crash. I actually have two different files and the results were the same with both.

I then went to an older PC laptop that still has version 7 installed and opened the file in Dropbox with no problem. I again ran the database tools in v7 and there were some indexing errors found in the integrity test, which were fixed by Rebuild Indexes. I ran all the tools again and they reported no more errors.

I then again reinstalled the app and tried to open it and once again it will not open. Just continually crashes and closes until Android reports that the app keeps stopping.

In v7, I tried to save a backup of the exported v8 file (now v7 again) to Dropbox and received a message from Dropbox that my current browser (v7?) is not supported. It did however save another copy of the rmgc file in a TempRMBackup folder under Apps\RootsMagic.

On April 27, 2022 I reported all of this to RM in an email and received the following response:

"Thank you for contacting RootsMagic Support.

I will do the testing the best I can, I just don’t currently have an Android device to work with.

Jackson
RootsMagic Support"

I have not heard anything since. Apparently no one at RM uses Android phones. Also, the RM8 Wiki only mentions using the iOS app, not Android. RM7 previously specifically supported the Android app, however the Wiki cited by rzamore1 re using RM7 did not work for me.

Conclusion: give up trying to use the RM Android app with RM8 (or even 7 now) and use TomH’s suggestions.

That would be correct. RM recently stated that the Android app is history. It doesn’t run on the latest Android releases, so unless you have an older Android device, you are out of luck. Renee from RM support has mentioned there are other apps capable of importing your data via GEDCOM. There is also the Ancestry app if you have an Ancestry tree.

Don’t waste your time on old android app versions. The RM iOS app is also ancient (2015) and is a read only viewer of limited use. Just put one or more trees on Ancestry.com and use their excellent and continually updated app on an iPad. This app allows editing, etc and sends you new hints.

It’s not just newer Android devices having an issue with the RM App. It broke on older devices where it once used to work. Once we saw it was every Android device with this issue we retired the app. That’s what makes me lean towards Dropbox having made changes on Android devices that effected the app.