Rootmsmagic app on iPhone problem

Still fighting with the Rootsmagic app on iPhone - never works correctly . Deleted everything and started over. Thought it finally worked . Then I saw the picture above - where my Dad’s date of death was entered correctly in the information but beside his picture, the program grabbed his father’s date of death and put it by his picture. I don’t have time to check every name title and see if it did this craziness on each name .
What is causing this?

Not a mobile user, but it appears to be a descendancy timeline depiction of James with correct information in the expanded popup and showing in the non-expanded popup the duration of his living relationship with his birth father. When the second father figure is selected for a descendancy timeline, in the app, does the non-expanded popup show a duration from either marriage date to birth mother or adoption date all the way through death date of second father? If so, makes clear the timelines of two “linked” fathers.

I’m not really a mobile user very much. I only use it because their pedigree layout for family books is by far the best visual layout I have seen. I’m not sure of your explanation but the
Descendent view on my phone shows the same error. How does it show I put it in the correct info but just grabs a death date from anywhere for the photo box?

I suspect this can be fixed by running the database tool Rebuild Indexes on the source database and then replacing the mobile copy with the updated file.

This is the pedigree on my PC- the information is correct there by his name (Smith, Jr died 2021, his father died in 1949) so isn’t it a specific mobile problem? It only happens on the phone. I have deleted the app, reloaded the file in dropbox and re done all of it - same result.
The information is correct as it shows on my PC - it has to be some kind of a fluke problem with the mobile app.

  1. Your post is silent about having done Rebuild Indexes on your computer.
  2. Can you be sure that you have replaced the file on your phone with the one having rebuilt indexes? Rename a copy of that database to X and transfer it.
  3. I don’t have iPhone but do have the Android app to which I can no longer transfer databases. I also have the app on an iPad 2 that displays full dates where the mobile app only shows the year. My hypothesis might therefore be wrong as it is based on how the computer app generates the DeathYear value.

If this were a programming error, it seems extremely unusual to have gone unreported for so long.

Rebuilt it and fixed that problem.Thank tou.

I have another problem with my colors on my phone pedigree chart. My Thrift line shows up as black background so their names are white and don’t show. Problem-I didn’t choose black- I chose teal… why is black showing up?

That looks like an issue with the theme selected on your device. Try selecting a different theme and see if that helps.

I looked under every heading on the app - couldn’t find anything related to a theme . Searched online- couldn’t find an answer- probably because I am totally lost. How do I find the theme choice?

I think Renee was talking about your phone theme, not the app. I use an Android phone so I can’t tell you exactly how to change themes on your iPhone

From what I’ ve read, iPhones need an app to add themes. No themes added that I know of unless the powers to be did it in an update.

Google iphone theme or wallpaper for details. Macs have system wide light/dark/auto background settings. iOS now has complex choices for wallpaper, widgets, etc. Keep it simple or you will end up with a mess.

If I understood what you just said, I probably would not be on here searching for answers.

What @Rooty just said is that it is possible to change the theme on an iPhone but that it is easy to make a mess if you try to do too much. This, along with Renee saying that this looked to be theme involved, would seem to indicate that somewhere along they way you have changed some stuff, whether you intended to or not, and this is messing up the fonts and colors in the RM app.

I would suggest maybe finding someone else with an iPhone to help you get your settings back to the default settings, or even Google how to do it. If things display normally, then cautiously start changing things such as fonts. If a change messes you up, then you can undo that change.

Thank you -I understand the explanation now.

You must remember that the RootsMagic App for the iPhone hasn’t been updated in six years! It’s Amazon that it still works at all.

Thanks. The only reason I even fight for it is that it has the most stunning pedigree layout that I use for family history books.