RM8 Media Drop and Drag

In RM8 is media drop and drag a feature that has yet to be activated.

1 Like

Not sure where you are dragging and dropping from (drop and drag?) but it works fine from File Explorer in Windows 10

Yeah, I (Windows user) tried to drag and drop a file from File Explorer as new media into a source - it totally did not work. Instead, I had to use the ‘Filename’ input field from the ‘Add New Media’ tab (there’s a little document icon that appears when your focus is on the Filename field, and if you click it, it brings up an Explorer dialogue box that lets you find your file):

I’d like to know that answer too as I am unable to drag and drop. Thanks!

Click add new media. Select the “Drop New Media” option on the left. Drag and drop the item into the box on the new window. Once you have dropped it in the box, the box will say, One media item added. Close the window and you will see the new image. You can drag and drop more than 1 item at a time.


Yup, theoretically that should make it happen, but it does not work. I get this error icon when I try:


…and when I let go of the mouse to “drop” it, absolutely nothing happens.

Thanks. That worked!

Thanks for all your replies and comments on dragging and dropping (as opposed to drop and drag!!!). Terry, I am trying to drag mainly jpg images from a File Explorer folder in Windows 10. It works just fine in RM7 but in RM8 I am getting the same results as kmsperling. I have tried resetting the program settings (Shift+Ctrl+U) and have even tried a fresh reinstall of RM8.0.1.0 but I am still unable to get the drag to drop into the box.

A couple of screenshots - one during the drag process followed by one after dropping

Yes, but as you can see from my own screenshot taken during the drag process (upthread), I do not get that nice “+ Copy” experience when I drag, I instead get a “nice try, it ain’t gonna happen” icon. For me, dragging and dropping simply doesn’t work.

1 Like

I just tried the same, and found that if I try to move the media file(s) to be dropped into another blank space within the “drop” window it does work. The active area for dropping files seems to be near the top of the white space to the left of center. This is what worked for me. Using WIN10 and the 8.0.1 version of RM8


I’ve tried dragging it all over the place in the hopes that at some special spot it might “take”, with no luck. But I’ll try it concentrating on the top left area!

UPDATE: Mindy, you genius!!! Top left corner of the box is the magic spot! Thanks lots!


Very clumsy compared to FTM. Instead of just dragging a jpg or pdf into a person edit screen or fact you have to choose add media get a drop window, drag only ONE file in and approve it. In FTM I just drag a bunch to a person’s media window and then to the appropriate facts/events.

I use both options of adding media depending on which machine I am using. If I am on my desktop PC which has 2 monitors I use drag and drop with File Explorer open on one monitor and the Add Media window on the other. If I am using my Surface with a smallish screen then I drill down to the file location using the Filename option so having either option available from the same window suits me.

Nope, tried all day, will not drop correctly. While here, I can’t copy the file name and paste it in the caption as I did in RM7. Others??

Terry, I am using a desktop PC with 2 monitors in exactly the same manner as you. I have now upgraded to Windows 11 and appear to be making some progress in that I can now drag and drop to a location outside the box. The “favoured” location on my 23" screen seems to be about 1 inch “north-west” of the top left hand corner of the box, however I was not aware that a drop had been achieved until I noticed that the narrative below the box had change to tell me that 1 item has been added. I am still unable to copy and paste into the media caption field but at least I now get a blinking cursor in that field and the copied caption no longer appears in the date caption.

Seems like the screen coordinates are off.
Are you using a high resolution monitor?

Richard, I am using high definition monitors but they are not high resolution.

I also had trouble at first , but it seems to be working now as posted.

I have the same problem but the ‘fix’ seems to be the ‘invisible’ square outside and just top left of the drop box. I think this is called ‘Thinking outside the box’!
Thank you to all who have struggled with this and discovered the ‘cure’.
Win 10 and dual HD screens.