RM8 for Mac OS - Access Violation Error

Thank you. My genealogy software path started with Reunion many years ago. I switched to RM in about 2014, having decided I needed much more robust citation functionality. I was very pleased to learn they were working on a “native” app. I didn’t install RM 8 until May 2022. I’m on an iMac - recently upgraded to Monterrey (macOS 12.5). I was hoping the OS upgrade might help - but no dice. I can run RM8 and look at stuff, but as soon as I want to add or edit anything - ACCESS VIOLATION. Very bummed.

We are always looking for the exact steps that reproduce errors. Make sure to send in error reports. Then open a support ticket with the exact steps to recreate it.

I have been leery about rejoining RM8, after having been a tester. I quit that after only a couple of months. However, after having upgraded to Monterey, I decided to give it another chance to see if there were any improvements from when it was first released. I have seen none. In fact I am noticing just about as many Access Violation Errors as I did as a tester. And, they don’t appear to be in any one specific area. However, being that most of what I am working on is in direct association with connecting RM8 with FamilySearch records that is where most of my issues are at this time. I have no less than 2 or 3 usually more every day. They are not with the same procedure. Sometimes, it is using the edit to change the French date to English, another time it is transferring one name from FS to RM.
Then when I am closing the program as suggested it doesn’t close properly. I then have to Force Quit. Although, I had some problems with the RM7, it was far superior to RM8 from my viewpoint. Although I have tried other softwares, I haven’t found anything that is as good as RM7 was. I am not at the point of quitting Genealogy for lack of decent program.

Unfortunately, RM 7 will no longer run on macOS Monterrey, or I’d probably try to go back to it. I have an old MacBook Pro that I used with RM 7, should still work, and at least not crash as often (it its too old to run RM 8). And I have a vintage Windows system running Windows 10 that presumably wouldn’t have as many issues with RM 8. However it has a pretty loud fan and will quickly turn my already too warm office into a sauna (we have A/C but I would also need a fan to get it into my office). I prefer quiet.

The other option would be to run Windows (to run RM8), or a previous version of macOS, (to run RM7) in a VM. However, I have had no luck with Parallels in the past (even now there are bits of it it I’ve been unable to remove), and now they want you to have a subscription; same with VMWare Fusion, which works great, but is even more costly as they target enterprise customers. VirtualBox is free, but when I was kicking its tires awhile back I was getting occasional crash reports that seemed to emanate from some daemon service even when I wasn’t actively using the app. And I would need to get a Windows license for that, just in order to run RM 8 in there.

I assume you are talking about the Mac version of RM7. Have you considered trying to run the Windows erosion of RM7 under full CrossOver? There is a 14-day free trial that you could experiment with, and although it then costs, you don’t need a Windows license.

NOTE - I only use it under Big Sur as Monterey doesn’t support my old Mac, but I see no reason why it shouldn’t be fine as the latest version of CrossOver supports High Sierra to Monterey, and on past experience one might expect them to ship a new version (that you would be entitled to upgrade to) when Ventura reaches GA.

My experience has been very good for the several years that I have used iTunes . RM7 is very stable and I leave it running for days, most of which time my Mac sleeps. I am a heavy user of the Family Search interface - I don’t use Ancestry Treeshare - and it just picks up when I sign into the Mac again the next day. (I’m still using RM7 as my production system, hoping that the performance of RM8 on the Mac will eventually become more usable.)

I had not heard of CrossOver. That seems like the cleanest solution, though I cannot think of any other Windows app that I’d really have any need to run. Of course, I would probably just install RM8. I have not seen reports it is unstable on Windows (but then there probably aren’t many running it with CrossOver).

For now I fired up my Windows system and was able to import my Ancestry trees with RM8. This should sync up to cloud eventually so I can see what I can actually do with Mac RM8. I was blocked because import from Ancestry doesn’t work for me except with trivial trees (it seems RM8 is sending too many ‘keep alive’ calls and Ancestry terminates the login session).

I have some stuff on FamilySearch so maybe I’ll see how TreeShare works with that.

In the end I’ll probably stick with FTM 2019 as my main tool.

Bruce’s mac RM7 is a custom wrapper from the crossover people and is better than buying crossover to make your own wrapper. however he pays big $ for this each time the yearly mac OS update appears and probably will stop that cash drain now that he thinks he has an acceptable mac version.

According to tech support there is no problem with file upload to ancestry but like you mine fail if I include media even in tiny files. RM seems to believe only a very few mac users have upload and access violations.

FTM 2019 will remain my master database and I will use RM8 only to identify data errors to be fixed in FTM.

According to tech support there is no problem with file upload to ancestry but like you mine fail if I include media even in tiny files. RM seems to believe only a very few mac users have upload and access violations.

Have you given us a small test file that fails to upload media yet? We would like to look at it.

It turns out that even having tree downloaded with media successfully (using RM8 for Windows), I still get Ancestry login session prematurely terminated when doing TreeShare sync, followed by AVE. I have a case opened for this, but am not optimistic about resolution.

I assume I would have same issues with upload, but that’s not my use case.

Wonder if there is some way to enable logging for RM8/Mac? I am seeing absolutely nothing in Console, and crash reports never make it there either.

And for some reason, one of the trees that I downloaded with RM8/Windows won’t go into TreeShare mode, only shows Upload/Download options.