RM 10 Set Relationship fails

Win 11 64 bit fully patched on a very fast PC and a very large db (308k individuals and 44 years of stuff).

RM 10.0.0, the “Set Relationship” command fails to complete. Checked Root person, ran Tools twice, restarted RM, rebooted PC, closed un-essential programs. Execute “Set Relationship” command and it ran for over 14 hours with a Please Wait response, remains unfinished.

Any thoughts ?

Run the database tools under File, Tools and check again. If Set Relationships fails to complete open a support ticket. We will need a backup of the database to test with. The support agent can send you a link to upload it.

I have the same issue. Setting the relationship in RM9 took, perhaps, 2 seconds. In RM10, even after running all of the usual tools, it hangs on “Setting Relationships”. There is clearly a bug here.

@JanKingshott – are you running Windows or Mac–reason I ask is because I had no problems with the Set Relationship in RM 10 as far hanging–too abt 2 seconds on Windows 11 64 bit…

If you used set relationship under the pencil icon, you MIGHT try going to the Command Palette and try that one–probably won’t work BUT worth a shot…

I’m running Windows 11, 64-bit. I was, indeed, running it from the pencil icon, but the Command Pallet hangs as well. It’s one of a number of things that aren’t working correctly I’m afraid. Another is that the places database doesn’t seem to have loaded, as the program can’t find it. All very frustrating.

Are you referring to the file, you could download with RM 10 or are you saying that when you go to places on the left, there is no list?

I only moved 1 database to RM 10-- and I have 4 pages of places listed–
have you tried running all the database tools
have you thought abt just doing a drag and drop on everyone in the file to see if that might get rid of these problems— sometimes you just end up with a bad copy when moving a file and need to just redo it…

as an FYI for you, when I moved my file, I did it by gedcom…

From the RootsMagician yesterday on Facebook

“Some users are concerned that uninstalling RootsMagic 9 when installing RootsMagic 10 removes the place database. This is not the case. The actual issue arises when upgrading from a 32-bit version of RM9 to a 64-bit version of RM10. The place database needs to be in different locations for 32-bit and 64-bit Windows systems. Early versions of the RM9 place database installer didn’t place it correctly for 64-bit systems. Quick Fix: If you’re encountering this issue, you can download the place database from our Downloads page and place it in the correct directory.”

Thank you. All I see at the Rootsmagic Download page, however, is the download of RM10, which I have already used. Do you have a hyperlink to the places database, and information on where I put it?

The link is on the RM10 download page Download RootsMagic 10
Just download it and run the installer. It is placed where it is needed automatically.

There are actually two different RM10 download pages so if you went in one way, you don’t see it, the other way you do. I am guessing went through the Try It link on the main page which doesn’t have the PlaceDB file. Why they have two seperate download pages is beyond me.

Thank you. I’ve re-installed RM10, but the 32-bit version, as this seems the most compatible. The places database has been solved, but the Setting Relationships issue remains.

Set relationships with over 22K people takes less than 3 seconds on older laptop (W10 , RM10-64bit, 16gb RAM).
Curious if 32 bit vs 64bit of RM is part of issues.

The “Set Relationships” is still an issue, whether 64- or 32-Bit. I have a very large tree, but in RM9, it still only took about 2-3 seconds. In RM10, it just hangs with the dialog box “Setting Relationships”, and I have to close the program using Task Manager.

No @kevync1985 – I have Windows 11 RM 10 with 64 bit and set relationship also takes less than a few seconds…

I meant if 32bit was running slower than 64bit of same database size (and # of relationship paths)

The issue with Set Relationships on some databases has been reported to development.

Curious if database has more broken trees (# of count trees) has something to do with it? ( I have about 10 - 5 are due to associations. 4 trees I hope to find connection + main tree with 98%+ of people)
running 64bit with 22K+ People takes less than 3 seconds.

This issue still exists. How do we know that the RM developers are aware of it, and working on it?

I replied 11 days ago that the issue has been reported to development. It was only identified after the release of RM10 and we have not released our first update after the release yet.

1 Like

To the question of unlinked trees in a person’s database causing problems, they should not cause problems. I have had over 700 in my RM databases for years. Most of them come from single surname studies, where books I have transcribed have single individuals or families with just a few people.