Printing Problem (RM 10)

Using RM 10. I went to “Publish” and then created a 2 page Relationship Chart. When I attempted to print it I got the message “Cannot create texture for ‘TCanvasD2d’.” It printed only the first page. I tried it again, same result, even if I asked it to print only page 2. I then saved it as a PDF file and had no trouble printing it (outside of RM).

Seems like a bug to me. Should I be reporting bugs in this forum?

I think I have seen that error reported before. My first guess would be either a printer driver error or a communication error between computer and printer. If you can save as PDF you can then print from the PDF successfully to the printer? do you have another printer driver?

Only two prior mentions of TCanvasD2d in this Community, both from RM9, so it doesn’t sound like a widespread problem. No resolution reported, just the save to and print from PDF workaround. And the invitation to submit a backup of your database file to Tech Support to check if the problem can be replicated for analysis.

I’ve had this before as well, but when I would retry it, it would be okay. This time retrying didn’t help. I’ll try it again later today. If it is still happening, how do I contact Tech Support?

Thank you. Not sure what you’re asking. I’ve never knowingly installed a second printer driver. It’s a Brother MFC-L2710dw connected via a cable to my Dell XPS8950.

Well I am looking for explanation to you problem

may relate to this Cannot create texture for TCanvasD2D

so RM or someone can determine if the issue is within RM or outside of RM
(if outside of RM ,does it relate to print driver etc)


The Help site (F1 key) says this:

You could start a chat or with some digging around, submit a request with file attached…

Thank you. I’m trying to reproduce it today. Funny, for the same 2 page chart that I was getting TCanvasD2d yesterday, today I’m getting “UNKNOWN ERROR.” I tried other charts, to see if they have the problem. One page charts don’t have the problem. A two page chart where only the right person extends into the second page didn’t have the problem. But another two page chart, where both people extend into the second page, has the “UNKNOWN ERROR” problem. Googling TCanvasD2d shows that this message occurs for apps other than RM. I guess I’ll have to live with it, and maybe just go with the SAVE/Print PDF method.